ERROR: missing signature key for OH 4.0.2 docker image

Hi all!
I have got a dockerized version (docker-compose) of openhab running on NAS. I am trying to upgrade from 4.0.0M3 to 4.0.2
I tried the following image tag:openhab/openhab:4.0.2. I did a docker-compose up -d but I have got the following message: “ERROR: missing signature key”. I assume there is something wrong with the image but I am not a docker expert. Any tip? Thanks

Are you seeing the same thing as this topic:

Read the documentation linked but they got the same problem and that post has no solution at the moment. BTW, the issue only affects my distribution environment dockerized on a Terramaster NAS (ArmV7 architecture). After installing 4.0.0M3 I am not able to pull any OH image from there…
Tried on other docker client environment (Windows 11) and it works smootly…
Appreciate your help
In your opinion, may I contact the Docker community?

If the docker container works for others (which it does), and works on your windows machine (which you report), it sounds like the problem is the NAS environment. I’d start with Terramaster support if it were me.

1 Like

What is the output of docker info ?
Perhaps your NAS runs a very old version. :thinking:

Here is my docker info output
Containers: 4
Running: 3
Paused: 0
Stopped: 1
Images: 4
Server Version: 17.06.0-dev
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 3addd840653146c90a254301d6c3a663c7fd6429
runc version: 2d41c047c83e09a6d61d464906feb2a2f3c52aa4
init version: 949e6fa
Kernel Version: 4.4.18-g8bcbd8a-dirty
Operating System:
OSType: linux
Architecture: aarch64
CPUs: 4
Total Memory: 1.921GiB
Name: TNAS-8A5B
Docker Root Dir: /mnt/md0/appdata/docker
Debug Mode (client): false
Debug Mode (server): false
Username: fabgio75
Experimental: false
Insecure Registries:
Registry Mirrors:
Live Restore Enabled: false

WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
WARNING: No cpu shares support
WARNING: bridge-nf-call-iptables is disabled
WARNING: bridge-nf-call-ip6tables is disabled


Thanks for the info. It seems related to old Docker versions.
I can reproduce it with Docker 1.13.1 on x86_64 which is a bit older.

But I also have this with other images:

$ docker pull ubuntu
Using default tag: latest
Trying to pull repository ... 
missing signature key

I will have a look if it is fixable somehow.

1 Like

I upgraded some Docker tooling and build wborn/openhab:4.0.2 which works for me again with the old Docker. Maybe you can also give it a try?

Ok I will try! Appreciated. I’ll let you know

Ok it works perfectly! it pulled OH 4.0.2 image. I also updated docker-compose.yml accordingly!
Now i’m running 4.0.2!
Thank you so much!

1 Like

Hi There. Facing same issue, i am new to docker. Getting this message
Do i need to update anything?

Hi @Salman_Alam, do you also use an older Docker do version?
You can check the version using docker version

I rebuild the OH 4.0.3 images in my own repo using some options which creates Docker manifests that seem to be more compatible with older Docker versions. If it works I can create a PR and rebuild the official images. Can you test the wborn/openhab:4.0.3 Docker image?