Error "Request explicitly cancelled" on Apple Watch App upon launch

When I launch the Apple Watch App (iOS App 2.4.49 with openHAB 3.3 on Raspi/Docker) I almost always get the error “Request explicitly cancelled”.

Sometimes pressing “retry” (multiple times) works, sometimes it doesn’t.

Is there a possibility to debug this / get further hints on the error?

I jut saw this error too a couple of minutes ago, but in my case it just vanished and my normal Sitemap appeard on the watch…

You’re right, patience solves the problem: After waiting for 2 - 3 seconds, the error disappears. Still a bit odd. Configuration problem? Or bug that should be reported in order to be fixed?

I experienced the same thing. I was encouraged by this thread, but no matter how many times I pressed retry, same result.

Then I tried power cycling the Apple Watch, and now it works.

That made it work on the local network. To make it work on an internet connection, I had to uncheck the Always Send Credentials box. It was sending the myopenhab.org login credentials to the local server. It now works both locally connected and over the Internet.