EU Zigbee dongle

zigbee
Tags: #<Tag:0x00007fd314da8df8>

(Daniel Walters) #21

Thanks for reply! Good news indeed.

Do you, by any chance, know of any existing work to retrieve SmartMeter readings using ZigBee controllers/radios? I’ve found a few old pages of ramblings but nothing concrete yet. Those IHD are pretty useless.

Thanks


(Chris Jackson) #22

No. Smart meters employ a very robust security model in Zigbee, so I doubt you will get very far if it really implements the smart energy protocol.


(Peter) #23

Hi Chris,

I tried my old Quivicon stick with your current snapshot, but unfortunately it does not work. This stick runs at 19200 baud which Paper UI doesn’t offer. Is there a chance to set the baud rate to 19.200?

Btw. this stick runs with a custom made Linux Driver (cp210x with ID 10c4:89fb) and is accessible from minicom (19200 8N1, no Hardware or Software Flow Control).

All the best

Peter


(Chris Jackson) #24

The current snapshot does not support the Telegesis stick - only the Ember and TI coordinators should be available. I’m currently integrating it into the binding at the moment so hopefully it will be available in a few days.


(Chris Jackson) #25

I’ve created a test version of the binding which includes the Telegesis driver. Since builds are still broken on ZigBee I’ve put it here. It’s worth noting that this version is a significant change to previous versions as I’m refactoring the ZigBee library a little to support some new features in the coming weeks.

@peter.boehm - I’m definitely interested to know if the Qivicon dongle works ok - it should as the firmware is fundamentally the same as the latest Telegesis revision (R309C), but I’ve not been able to try it myself yet due to the PID issue.

Any issues, just let me know.

(Also, this version does contain the other drivers as well - currently the TI2531 and Ember in addition to Telegesis).


(Peter) #26

Hi Chris,

I was able to configure the Telegesis Coordinator with your new binding. No errors in the logs. I guess I have to find out how to resett one of my Hue bulbs. That seems to be the tricky part.

Thanks a lot and stay tuned :slight_smile:


(Chris Jackson) #27

Great stuff - thanks Peter.

You need a Hue remote control (or maybe another ZLL compatible controller) to do this. I bought one a while back for exactly this purpose (round remote control). If you have one I can guide you through it - it’s pretty simple.


(Peter) #28

Yep, thats what I googled, but unfortunateley I have none of these devices. Browser based resett does not work (described here: https://community.smartthings.com/t/hue-bulb-factory-reset-solved-if-your-hue-bulb-is-on-a-zll-channel/84967).

So I have to buy a remote controller tomorrow…


(andres_meyer) #29

Where do I see when the Zigbee binding is building normally again and is (I guess) normally included into the snapshot distributed via apt-get?


(Chris Jackson) #30

At the moment the build seems to be broken. I’ve submitted a PR which I think will solve it, but let’s see once it’s merged.


(Peter) #31

Realy Great stuff - Thanks Chris! :slight_smile:

For the sake of simplicity I just bought a new white ambiance bulb. And guess what, this bulb was found immediately in the inbox as a Generic ZigBee Device and the best is: It works!

Many thanks Chris for your work!

Please let me know if I can help with logs or tests.


(Daniel Walters) #32

Hi Chris

I’ve recently seen posts where people have claimed to have gotten the Xiaomi sensors working directly with their SmartThings hub so I’d like to try my luck getting them to work directly with OH using a Zigbee USB stick.

I’ve recently received a TI CC2531 stick (this one - not sure if it’s a clone) - have you got any documentation/links/tips on how I can prepare it to start sniffing/communicating with ZigBee/Xiaomi devices?

Thanks


(Chris Jackson) #33

Not really. There is information on the repo site on github about programming the sticks, and I think TI have some sniffer firmware, but I don’t have much experience with either. I have one of these sticks for testing, but most of my development is done with Silabs hardware and sniffer.

If you search around the web though I’m sure you should find something on this.


(Scott Karns) #34

Hi, Daniel. This post documents how I got a CC2531 USB dongle working.

Good luck!


(Daniel Walters) #35

HI Scott, I’m a bit confused. Using Raspbian I managed to flash the dongle with cc-tool but yet I don’t see it appearing in /dev so I’m unable to configure the binding.


(Scott Karns) #36

Daniel,

I assume you disconnected the SmartRF04EB Firmware Downloader from the CC2531 ZigBee USB Dongle after flashing the dongle. Have you tried unplugging the CC2531 dongle, waiting several (say 5?) seconds, then plugging it back into your RPi? Once you’ve tried that, what does the output of lsusb show?

On my my system, I get the following:

[15:46:53] scott@rpi3:~$ lsusb
Bus 001 Device 007: ID 0803:3095 Zoom Telephonics, Inc. 
Bus 001 Device 009: ID 0803:3095 Zoom Telephonics, Inc. 
Bus 001 Device 008: ID 0658:0200 Sigma Designs, Inc. 
Bus 001 Device 006: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 005: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 004: ID 0451:16a8 Texas Instruments, Inc. 
...

The Texas Intstruments device with ID 0451:16a8 is my ZigBee dongle. Your CC2531 should have the same ID.

I have my CC2531 dongle symlinked to /dev/ttyUSBzigbee using a udev rule:

[15:54:57] scott@rpi3:~$ cat /etc/udev/rules.d/50-usb-serial.rules 
SUBSYSTEM=="tty", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", SYMLINK+="ttyUSBzwave", GROUP="dialout", MODE="0660"
SUBSYSTEM=="tty", ATTRS{idVendor}=="0451", ATTRS{idProduct}=="16a8", SYMLINK+="ttyUSBzigbee", GROUP="dialout", MODE="0660"

I had to modify the value of the EXTRA_JAVA_OPTS environment variable in /etc/default/openhab2 so java can “see” both my Z-Wave and ZigBee dongles:

EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyACM2:/dev/ttyUSBzigbee:/dev/ttyUSBzwave"

You will have to reboot your RPi after updating the udev rules – more info available here.

Hopefully something in what I’ve provided here will get you going.

Good Luck!


(Belmondo2001) #37

Hello,
under Linux you can add the Qivicon dongle
without a custom made kernel.

echo 10c4 89fb > /sys/bus/usb-serial/drivers/cp210x/new_id


(Peter) #38

I didn’t know that this is possible. Thank’s for the info!


(Chris Jackson) #39

Thanks - while I doubt many people will be keen on doing this, I’ll add it to the readme on the library repository as it’s useful info.


(Ben Clark) #40

Would you know what the range is like for the ETRX357USB? Do you think it’s worth getting the LRS version for the average UK household?