Eurotronic Spirit Z-Wave Plus doesn't work

Tags: #<Tag:0x00007f61793838a8> #<Tag:0x00007f61793837b8> #<Tag:0x00007f6179383560>

Hi,
i recently bought a Eurotronic Spirit Z-Wave Plus and am desperately trying to get it to work.
openhab2 and openhab2-addons are from the current snapshot.
I can include it to the network. The first few minutes, it is displayed as unknown device.
After that, the right template is assigned and i can, theoretically, change the configuration.
Wether the configuration parameters nor setting temperatures is being applied.
The lifeline association is forgotten instantly, so read values from the device dont get to the controller.

What am i doing wrong? Does anyone have a clue or a similar problem?

What UI do you use? I have had trouble getting Z-Wave stuff to work form the PaperUI. Start from HABMIN and take it from there.

Since my first Z-Wave products i switched to habmin because it didn’t work at all in PaperUI (500 internal server error all the time).
In this case i started with habmin, out of desparation i tried PaperUI afterwards, none of them helped.

A couple ideas/questions… See below.

Config parameter #2 for this device in the database looks problematic as the default is outside the allowed range. This might be causing PaperUI to choke.

Can you clarify what you’re trying to do with the temperature. Are you trying to change the scale (i.e. Celsius/Fahrenheit)? If so, there’s a defect in HABmin that prevents this from working. The only way to change the scale is with PaperUI.

This is a bit of a stretch, but try changing parameter 2 to something in the allowed range (5-30). Maybe this will get you past the error.

I tried multiple times setting the config parameters, including #2 (to 10 in my case) but the thermostat doesn’t accept it.
The UI says, it is the new value, but the LCD on the thermostat is always on.

I didn’t try to change the scale, but applying the setpoints or changing the mode, but no reaction of the device.

I have the PaperUI error with all my Z-Wave devices, theres also a thread in this forum about it.

This is ok - or it should be, but maybe PaperUI doesn’t support the ‘correct’ definition. Some time back it was agreed that the options that are defined can be outside the range - so a UI should allow the range (5 to 30 here), plus any options (so also 0).

I would agree with @mhilbush - try a value that is between 5 and 30 - if this works I think we should raise an issue against PaperUI to have it fixed and not make the database wrong to work around this.

Sorry. I completely missed the change that allowed values outside the min/max.

That’s probably because I missed adding this to the documentation :wink:

I don’t think it even gets applied to the device, no matter what value i choose.

Do i have any options to directly debug this?

You could put the zwave binding into debug mode, then view the behavior in Chris’s zwave log viewer. That might provide some insight into what’s going on.

You might want to exclude the device, then include it again in order to capture the inclusion/initiation process, as well as any config changes you’re trying to make through HABmin.

http://www.cd-jackson.com/index.php/openhab/zwave-log-viewer

I received my Eurotronic Spirit today and it was working right from the start.

Using openHAB 2.2.0-1 (Release Build) with all bindings that came with the distribution.

@Julian_Kuchlbauer what are your experiences so far?

After including it says Unknown Device. It stays in this state until i rename it. Even after correctly showing Spirit…, values arent read and parameters arent being applied.

For debugging other devices, I took the steps @mhilbush suggested (above). It always helped me understand what was going on – or not.

I relied on instructions provided here: https://docs.openhab.org/administration/logging.html

log:set DEBUG org.openhab.binding.zwave

I can only confirm that the device is working well with the current stable version of OH2.

Thats the log, unfortunately, i have no clue, what this means.

This should be detected ok - what version of the binding are you running?

Snapshot 2.3.0.201801020943
Before i tried with the stable release, same result.

The device looks like it’s detected - the parameters etc are all there so I think it’s fine. Does it also show channels etc?

Everything there

Cool - so no problem then…