Eurotronic Spirit Zigbee Thermostat again

Tags: #<Tag:0x00007f6179875050> #<Tag:0x00007f6179874e70>

Hi,

i have a new Eurotronic Spirit Zigbee Thermostat which does not work as expected.

First of all, i had a lot of problems to join this device with my a new Zigbee network. My environment:

  • fresh installed lxc with Debian 10.3
  • OH 2.5.2, later snapshot 2.5.3.202003010329
  • coordinator BitronVideo 2010/10 with Firmware 5.8

It was NOT possible to join, i did all those things like clearing cache, change to latest snapshot, enable unsecure joins, change transmit power, reset Spirit and so on. Without any luck. I had to reinstall OH 2.5.3.x package - then it worked?!? On another Zigbee network with Telegesis coordinator it joined without any problems.

But my problem now is: why does my Spirit device show all channels as output-channels?

SPZB0001

Versions:

213 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee
214 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.console
215 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.console.ember
216 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.dongle.cc2531
217 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.dongle.ember
218 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.dongle.telegesis
219 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.dongle.xbee
221 x Active x  80 x 2.5.3.202003151008      x openHAB Add-ons :: Bundles :: ZigBee Binding
222 x Active x  80 x 2.5.3.202003151009      x openHAB Add-ons :: Bundles :: ZigBee CC2531 Bridge
223 x Active x  80 x 2.5.3.202003151009      x openHAB Add-ons :: Bundles :: ZigBee Console
224 x Active x  80 x 2.5.3.202003151009      x openHAB Add-ons :: Bundles :: ZigBee Console Ember
225 x Active x  80 x 2.5.3.202003151009      x openHAB Add-ons :: Bundles :: ZigBee Ember Bridge
226 x Active x  80 x 2.5.3.202003151009      x openHAB Add-ons :: Bundles :: ZigBee Telegesis Bridge
227 x Active x  80 x 2.5.3.202003151010      x openHAB Add-ons :: Bundles :: ZigBee XBee Bridge

Thanks in advance

Given that it did join, the issue was likely finger trouble or range issues. The join itself doesn’t have anything to do with the binding - the binding configures the coordinator during the binding start and then it is up to the coordinator to join the device. One of the most common issues is people not resetting the device during the join process.

Hi Chris,

thanks for your answer. I’m aware of the importance of resetting and did this very often, that was definitely NOT the reason. Unfortunatly i deleted the logs when i reinstalled the package.

But anyway, why are all channels only output channels?

Typically there will not be any logs for joining - if the device doesn’t join the network, then the binding does not even get advised that the device exists.

What do you mean? Do you mean you can’t control anything? I’ve tested this device in the past and I think you should be able to control the setpoint and I see this in the list of channels in your image.

I had this simple mode for item links enabled, so my items are autocreated.
Sorry for asking beginners question: but what type of item do i have to create in paper-ui to set the value of “Occupied Heating Setpoint”?

Currently it is autocreated this way:
category: HVAC
type: number
dimension: temperature

I think it should be a number for the setpoint.

Yes. That’s it…
Sorry, my fault

Now it works - although i don’t understand in which case the device switches from unoccupied to occupied heating mode.

Is it the default behaviour that changes done on the device are not displayed in OpenHab?

No - the device should send reports. This is configured by the binding during initialisation.

Hmm.
No reports. I waited about 14h now… The other directions works.
Should i rejoin the device? Could it be a Telegesis-thing? I could test it with my BitronVideo stick.

I’ve had a look at the debug logs when I configured the setpoint at the physical device.
touch device.log (1.7 KB)

2020-04-12 11:59:08.305 [DEBUG] [transaction.ZigBeeTransactionManager] - notifyTransactionCommand: ReportAttributesCommand [Thermostat: 605B/1 -> 0000/1, cluster=0201, TID=C3, reports=[AttributeReport [attributeDataType=SIGNED_16_BIT_INTEGER, attributeIdentifier=16387, attributeValue=1650]]]

(I set the setpoint to 16.5°C)
It seems the device reports the change to OH, but nothing happens.

@chris,
I am looking for some Spirit device specific source code or configuration at org.openhab.binding.zigbee , but I can’t find something. Is this the wrong location or is the ZigBee binding so generic that there is no device specific part needed?

Please can we have the discussion in one place. It’s a mess if we now swap to an old discussion from 4 weeks ago when we’ve been discussing this on another thread over hte past couple of days.

ok - which one should we take?

What do you mean? Which what?

My question was about the chat. But now I saw you answering in the other one.

So let’s continue at Cant connect Eurotronic Spirit Zigbee to OH using BitronVideo Coordinator

Sorry for the confusion.

As I said above - we have been discussing this on another thread for the past 2 days, so swapping now to a 4 week old thread just makes it difficult to find the logs etc that are posted in a different thread.

Well, this is where the questions were - where we have been communicating for 2 days, so yes, I replied to the questions there.