Extending z-wave with secondary controller - Using Razberry with Aeotec z-stick

Tags: #<Tag:0x00007f6175416300> #<Tag:0x00007f6175416120> #<Tag:0x00007f6175415fe0>

Hi All,

I need to extend my z-wave network as 4 hops is not enough. I have read elsewhere that it is possible to use two controllers but I’m having great difficulty.

  • Primary: Razberry with z-way
  • Secondary: Aeotec Z-Stick Gen5

Using the Razberry alone works perfectly using the z-way binding. I would like everything under one system for example I don’t want to use both the z-way and z-wave bindings together.

My main issue seems to be that the inclusion/interview process does not fully complete.

I’ve searched this forum and cannot find a solution and I’ve spend countless hours trying to figure it out. I’m hoping that someone can help here so there is a guide on the forum that will help me and others.

My process:

  • Install Razberry and z-way software on my Pi3 using:
    wget -q -O - http://razberry.z-wave.me/install | sudo bash

  • Install the z-way binding in OpenHAB

  • Test it is working by adding a device, item and sitemap

  • Plug Aeotec Z-Stick into a PC, download Zenys Tools, install and set stick into learning mode

  • Log into z-way, go to expert mode and click include device

  • Everything apart from CommandClass: Version interviews correctly. I cannot force it either.

I read the following here but no solution was given

The interview of the Version Command Class is usually the biggest hurdle because its interviewed first and the interview itself involved a lot of questions.

If anyone has any ideas on how to fix the issue or simply has another solution on how I may extend my z-wave network that would be brilliant. :crossed_fingers::wink:

Thanks very much

It is not clear to me; are you trying to include the same devices in both the Razberry and the Aeotec, or are you adding some devices to one and other devices to the other. I ask because I’m pretty sure that a lot of zwave devices will only support one controller at a time.

Beyond that is beyond my knowledge.

Many thanks for responding.

Apologies for not being clear. I’m trying to have some devices on one and some on another.

I’m not 100% sure myself if the Razberry allows a second controller, their documentation and support is very limited. That said even when the interview of the z-stick is not 100% complete I’ve managed to add a device to it which then shows up in my Razberry Z-Way software. Well it displays but it does not turn the device on or off.

The instructions state how to use the Razberry as a secondary controller but not if or how you can add a secondary to it.

Is there any other way you know of that will allow me to have two networks running in the same house. Working in one control panel or at worst separate?

I’ve read that I can use two instances of OpenHAB and MQTT between them but I’d rather not go down that route as it sounds like an overkill…

For completeness of my topic here are the instructions that I’ve read:

https://razberry.z-wave.me/docs/RaZberryEndUserManual20.pdf
https://razberry.z-wave.me/docs/zway.pdf

I don’t think you can do this with a “secondary controller”. ZWave allows multiple controllers, but a secondary controller infers that it’s on the same network, and then you’re still limited by the 4 hop issue back to the primary controller.

If I understand correctly, you really want a second controller - ie on a second network - that is connected back to OH via IP? I’m not very familiar with Z-Way, but it it runs over an IP network (which I think it does?) then it should allow you to do this.

Oh dear, I was that focused on trying to add a second controller that I neglected to notice that I would still be limited by the 4 hops. I just assumed I could 4 hop to the secondary then 4 again but that’s still 8 in one network! :roll_eyes:

Yes I think you understand me correctly. The house is way too big for one network so I need to find a way to run two or possibly more and have it all controllable through one openHAB sitemap.

I’m not sure I understand your potential solution. Are you saying I could add another Pi with Razberry attached to my network and add that to the z-way binding as well?

If that would work then great but it’s expensive as the combined cost of another Pi & Razberry is £90

Is there another more common / recommended way of doing what I want? I’m not fixated on z-way, I just want to find a solution that works and is reliable.

Hello @Curtis

I’ve got the same issues with a far too big house (or too good walls) for one controller. I ended up having 3 Raspberry Pis each with a Z-Wave controller and each responsible for one level of the house.

One of them is the “main” system while the others are very minimalistic (no Basic UI, no rules, etc.) and I have them talking to each other using the mqtt-eventbus. Therefore install the MQTT binding and configure Mosquitto as message broker. The “main” Raspberry is the one that sends commands and subscribes to state changes, while the other 2 “clients” subscribe to the main one’s commands (e.g., issued through the UI or triggered by rules on the main one) and publish their state.

That works pretty well to me and I have now a quickly responding, full-house coverage of my house. I anyhow noticed that more than 20-30 z-wave devices on the controller start to introduce high latency form command to execution so this solved my issues on that end as well.

Hope this helps. If you have more questions, I’m happy to help.

EDIT: It costs indeed a bit more (if you don’t have anyhow a spare Pi laying around as I did), but it’s worth the cost. I had myself some spare, old Raspberry Pis around since I upgraded to Pi 3 for Kodi to run that more smooth and now those old ones are again in use for OpenHAB where they are powerful enough for, especially when not taking care about the UI or rules.

This shouldn’t be the case unless there are timeouts - eg if you had some devices that were a long way from the controller/repeater, then there would be timeouts, and this would add latency. I suspect that this is the issue that you may have solved by adding more controllers…

Hello @chris

that might be as well the case. It was definitively not related to the Z-Wave binding, as I faced that issue on a Somfy Box with Z-Wave stick and on Domoticz as well. It actually runs best with OpenHAB in my experience.

Is there any experience on larger numbers of devices connected to a controller? I had cases (about 40 devices connected to the controller) where it took over a minute to turn on a light, while the Fibaro relay responsible for that was just 2-3 meters away from the controller. However, it was not always the case that that happens. Sometimes it responded within a second, but sometimes it took very long.

If the controller can’t find a device (ie the first attempt to communicate fails) then the controller can use a method called “Explorer Frames” which will “flood” the network a little to try and find the device and this I think takes a few seconds so this might be a possible explanation…

Yes - people are using some large networks.

Normally, this should not be the case, but possibly during binding initialisation when there is a lot of traffic, this might delay things. Distance is not really relevant though - the delays will be with queueing in the binding. That said, the binding does prioritise traffic so that configuration, or status information have lower priorities than commands like turning on your lights.

My guess is that there may be an underlying connectivity issue - if there are timeouts or delays, especially during startup, then things will likely get slow. Another issue is over use of polling, or setting data update rates too high.

I will be looking to add more diagnostic functions to the binding in the medium term.

There is no problem with a large number of devices. I’m using 114 devices in my network without the lag you reported. All responses are within one to two seconds (max). For me it was a good idea to spilt network controller from openhab rule-engine.
My Openhab instance is virtual with plenty of resources, while my razerry is a raspberry. I’ve added a second controller only for failover. Both raspberries use one virtual IP to communicate with openhab (heartbeat, failoverd).

I think your problems could be related to polling or update rate. Normally polling is not even needed with most zwave devices, as they report their updates to main controller.

If you would like to have a second network within your home, this should be no problem. Just connect the second controller via mqtt,http-api, rest…

Don’t try to use a controller in a VM (passthru). There are plenty of timing issues with virtual serial passthru. I never got it to work with good response times.

Hi @antares2001

I think I need to figure out how to MQTT between openHAB instances as I’m sure it will be really useful in future. I currently use the MQTT binding for connecting openHAB to SmartThings. So hopefully I’m already on my way to figuring it out.

I’ve seen the thread on this forum relating to how to do it so I’ll start there.

@Curtis

I suggest you to use the mqtt-eventbus.conf so that all changes of devices are propagated. That made it most effective and easy for me.

Good luck and have fun :slight_smile:

1 Like

@Curtis

My house is setup with both a Pi3 with Razberry board (running zway) and a Pi3 with z-stick (running OH2 with z-wave and z-way bindings). No need for MQTT command stuff. (I am using MQTT for other things but not this). As long as your large house has a common wi-fi network then you should be able to do what you are doing now. Just put the Razberry zway system near center of one house region and Z-stick system (running OH2 zwave and zway) near center of another house region, each acting as controller for their region (hence bound to those zwave devices in that region). Using OH2 you can bring all those devices into a single Habpanel (for instance). (I do all this. ) Since OH2-z-way binding talks to the IP address of the Razberry box, as long as you have common wi-fi, this should work fine. (I am having a difficult time imagining a house so large that you’d have end-devices more than 4 hops away from their respective controller when laid out by regions). That being said, if your house is truly that large, I don’t know if the z-way binding has been tested with multiple z-way servers all feeding one OH2. @pathec would most likely to know that.

3 Likes

Cheers, I’ll give your solution a whirl too. I’m a bit of a tinkerer so like to try out many possible solutions.

The house is 200 years old, has high ceilings, 20 rooms and an out-house that needs signal too. Not my house though unfortunately, its a friend of mines. We have 3 Netgear Orbi’s in there at the moment which struggle to get Wifi throughout. I think it has as much to do with the build of the property as much as the size.

? interior stone walls

Well yeah but some are COB and some are about 20cm thick. Could be interference with other stuff too. In any event z-wave and Wifi both struggle in that house.

Should go like you may need more than two controllers. If you have already fought and mostly won the wifi challenge in that house, have you considered using mainly wifi devices?

You will probably want to have at least as many controllers as you have wifi app/repeaters and you will want to have a pretty dense mesh network of devices so each individual device has at least two parties paths to it’s controller. This may mean installing repeaters or mains powered devices whose main purpose is to fill out the mesh rather than control something.

And in my experience, the network is more times for creating the mesh horizontally rather than vertically. If you have multiple floors you might need to add some repeaters to connect the floors. I for example, I have three floors , one of which is a basement. My controller is on the top floor and except for a battery powered smoke alarm was the only ZWave device on the floor. Well, the main floor and basement had a full mesh but only the power outlet in the room directly under the controller could see the controller. This other quickly became overwhelmed and the network was unreliable. I added a repeater to the top floor and now everything has two paths to the controller and it works great.

Good luck!

1 Like

Agree with @rlkoshak on this. Solid walls are going to be a problem. Was just having a thread with @trumee who is in India (partially) on this. (Wiring is another issue in India --sidebar - my wife is Indian – I’ve been there many times and know a fair amount about Indian construction and wiring practices. )

Your walls are stone/COB and thick–so you are going to have serious issues with transmission for z-devices.

I think a little systematic science is in order. I would get two or three plug-in z-wave range extenders and probe the environment for reachability. Basically stash a controller in what you think would be central to a zone, and systematically move a relatively portable z-device farther and farther away from it to see if you can maintain contact, inserting the range extenders either line-of-sight through non-stone, or possibly one stone wall from the either the controller or a prior range extender.

Make yourself a map of the real problem, in other words.

1 Like

Good suggestion in using z-way binding for second controller. I have my garage 80m away. Too far for zwave, but i can get wifi there. My original plan was to setup a new openhab instance a propagate stuff with mqtt to the main openhab instance, now if using your suggestion I can do with one openhab instance and 2 zwave controllers!
:+1:

1 Like

Thanks very much everyone I really appreciate your feedback. I certainly have enough food for though now. I’ll try a few options and see what works best.