Factory-resetting Fibaro FGS 222 relay switches

Does anybody have a reliable procedure for factory-resetting Fibaro FGS 222 relay switches? The official procedure is to reset by holding the B button for 3 sec. after connecting the mains voltage to the switch (implying that you’ve cut the power previously). That didn’t appear to work, but obviously there is zero feedback. The only way to know is if you succeed in including them again.

I tried every reset procedure I found online, including pressing the B button for 3 seconds, then cutting the power, then pressing it again (maybe?). The consensus seems to be that you need to cut the power, then press the B button as the power is restored (i.e. it requires two people). I can’t get anything to work. Since I also failed to attach physical switches to the relays to operate them manually when I have problems like this, I’m seriously considering throwing them away and buying something else, but I don’t know what. They control the heating and cooling, so this is no trivial matter. Fortunately I still have a gas boiler I can switch to in the cold weather.

Please, I’m out of ideas.

Bonus question: are there alternatives to the Fibaro relays that control two switches?

I suspect not. I’m going to end up buying two more of the same brand. Or maybe I could use four different relays if they’re compact enough.

There’s a similar from Qubino (Flush 2D or something like this) which can also drive two circuits. The channels look like the following for each circuit:

1 Like

OK that looks interesting. I have also so far failed in my attempts to connect physical switches to the Fibaros so that I can manually control them, which really is a basic requirement for situations like these. I might have another stab at that and see if the reset procedure involving the S1/S2 switches works. If not, I’ll look at the Qubino.

Alas, it seems the Qubino relays can only handle 4A each, not enough for a heat pump.

Checking out other alternatives: The Aeotec Nano switches are also underspecified for heat pumps: 10A max, 5A each for the dual version. There’s an own-brand Vesternet switch that handles even less. There’s a Heltun (never heard of them) single switch that can handle 16A, but I’d need four of them, at £70 each. I’m also not sure I trust myself rewiring it to use two separate switches instead of one.

Edit: The Philio double 1.5 kW switch would actually do it. But I think if I can’t get these working I’d opt to buy two Fibaro FGS-223 switches, which, being a newer model, have what sounds like an easier reset procedure (there’s an LED!).

I wonder about this line from the manual: “Remove the device from the wall switch box”. Does that imply disconnecting all the other cables apart from live/neutral?

Usually the heat pump is at a a place (e.g. basement) where the optical appearance of the relay does not matter that much - have you thought about a sonoff 4ch? The latest ones can sustain 10A per channel, have 4 channels. It’s pretty easy to mount them on a DIN rail.

1 Like

I don’t have the device, so can’t advise on the procedure, except I do not think messing with the power is necessary. I think the instruction simply means the device needs to be powered to be factory reset. Have you tried putting the zwave binding in DEBUG and trying the inclusion in OH. Maybe it has been factory reset? or maybe there will be some messages that help.

Just a thought, before spending money.


The relays are in a pretty narrow cupboard built into the wall. Not much space unfortunately. It’s pretty crowded as it is.

Yeah I could try that, in case there any hints.

How big is the current relay?
sonoff 4ch is 45mm x 90mm X 40mm ( 1.7" x 3.5" x 1.5")

40mm x 37mm x 16mm

Quite a bit smaller. The Fibaros are the smallest on the market, I think.

You could also look at the shelly 2.5 which also drives two channels with 10A each.
But reading the shelly community it is no advised to constantly power something with it (e.g.) radiator pump for the heating that runs 24/7 - the shelly might overheat: https://www.reddit.com/r/homeassistant/comments/o5sf1t/shelly_25_overheating/

The heat pump definitely doesn’t run 24/7. Maybe 12-14 hours per day in summer at the absolute most. In any case, I think I’ll opt for a newer and hopefully more usable version of the devil I know and get the Fibaro FGS-223.

I’ve tried everything. The Z-Wave log is activated at the debug level, but unfortunately you almost certainly have to put the Z-Stick right next to the Fibaros, which means you’re not going to log anything. Trying to include them from openHab nothing appears in the log.

I’ve spent enough time on this.

The nightmare continues. The two FGS-223 relays arrived yesterday. I fitted one and included it on the first attempt. The “IN” terminal has vanished on this model, but apparently that doesn’t matter. However on the second the Q2 screw was completely stuck. After trying to dislodge it for an hour I gave up. I set up a return and ordered another, supposedly to arrive today. Today I find out that it’s due tomorrow. Why? Apparently “Premium” delivery means we’ll give it a go, but no guarantees. So I cancelled that and ordered another, for “urgent” delivery today, which supposedly is guaranteed. Sigh.

Why the urgency? Because my gas heating doesn’t seem to be doing anything. The floor is no longer heating. Somehow, the valve controlled by the relay that has not yet been fitted must have switched state from the boiler circuit to the heat pump circuit (just because I disconnected some wires?). But I’m not able to turn on the heat pump heating either, despite the fact that this is job of the relay that is fitted and, apparently, working. So I have to cross my fingers that it will work once both relays are fitted and working. Meanwhile, no heating of any kind, on one of the coldest days so far.

Hopefully I’ll have more luck fitting manual switches to these relays than to the other ones, so that at least I can activate the heating and cooling manually when all else fails.

You seem to have bad luck with those components. What kind of valve do you have? I could imagine that the fgs 222 is not designed for inductive load (which a valve usually is). In addition, closing or opening the valve (depending if it is normally opened or closed) will result in feeding the energy from the coil back to your circuit. That could lead to the problem that the contacts in the relay are getting welded together due to short current peaks

That’s a important thing. Always have a fallback for cricitcal systems like heating in case your home automation components fail

If I remember correctly, it’s a three-way valve that allows me to switch between the heat pump cooling, heat pump heating and boiler heating. When both switches are off, it defaults to the boiler circuit. I don’t have more details here with me, I’m afraid.

But in that case I would have experienced problems before attempting this whole reset procedure. The system has been running without problems for five years, almost always using the heat pump, but on at least one occasion I switched to the boiler, as indeed I did the other day when I lost control of the relays (both heat pump valve switches were in the off position at that point). Now it appears that one of the valve switches moved to the “on” position when I was attempting to fit the new relay last night - this is the only reason I can think of why the boiler would be heating water and yet failing to heat the flat.

I’ve made multiple attempts to fit manual switches, both momentary and toggle switches, with no success. That’s probably going to be a subject for another thread.

Now I think I have a bigger problem. I’ve just read that the FGS-223 model cannot be used as a dry contact relay, which I believe is exactly what I need for the valves/heat pump. The older model did have this option. This just gets worse.

I think I need the FGS-224. :man_facepalming:

All’s well that ends well. More tomorrow.

After ordering a new FGS-223 I realised that this model was no good, because I need dry contact relays (I stumbled on an e-commerce site completely by chance where they explicitly warned about this limitation). Fibaro had changed the specs. This explains why the “IN” terminal had vanished, and why, when I tried to test the one relay that I’d successfully installed, nothing happened.

With fifteen minutes to spare, I ordered two FGS-224 relays for same-day delivery. In this model, the dry contact option is back (though there is no power meter). I wired them up without any problems (the “IN” terminal is back), and included them in openHab fairly easily. The first one was included without being recognised, perhaps because I’d knocked the power back off at a key moment. On the second try it worked. Including and excluding seems much easier than for the FGS-222, and exclusion also does an automatic factory reset. The LED helps a lot.

I switched heating back to the heat pump, and it worked straight away. I still have to test the boiler.

I’ll have a go at reviving the old relays by connecting just the L+N wires and connecting them to a switched socket so I can easily turn the power on and off.