Fibaro Door Window contact FGK-10x


Anybody that have successfully added at Fibaro FGK-10x sensor to their network in OpenHAB?


Yes - it works well - once you get it included! This device seems difficult to include - it’s nothing to do with openHAB. I’ve included these devices a number of times directly to the Aeon stick, and I’m still not really sure how to reliably get them included…

Once included, it works well.

OK, thanks.

I have tried to include the device several times, both from HABmin and directly with my Z-stick S2. The device are being listed as unknown to both OpenHAB and HABmin after inclusion, but it does get a zwave network node ID though. I have several other devices from Fibaro and Aeotec added successfully to my network.

Where do I step wrong with this device?


If it’s got an ID, then it’s included (and hopefully ok). You still need to wake the device up so that it can be configured though - this needs to be done with the device reasonably close to the controller (let’s say 5 meters), and openHAB needs to be running. Wake the device up by triple pressing the button inside the cover (not the one of the back). You might need to do this a few times - leave at least 10 seconds between each time though to give OH some time to do its thing…


Didn’t know about the button inside the device :blush:I will try that and report back, hopefully the device will change from gray to green in HABmin after performing the wake up procedure.



I have gotten the device propperly registered with my zwave network, so far so good. I can see the following in my zwave debug log when opening an closing the magnet sensor.

2016-03-27 17:01:49.670 [DEBUG] [ApplicationCommandMessageClass:38  ]- NODE 29: Application Command Request (ALIVE:DONE)
2016-03-27 17:01:49.670 [DEBUG] [ApplicationCommandMessageClass:56  ]- NODE 29: Incoming command class SENSOR_BINARY
2016-03-27 17:01:49.670 [DEBUG] [.ZWaveBinarySensorCommandClass:82  ]- NODE 29: Received Sensor Binary Request (v1)
2016-03-27 17:01:49.671 [DEBUG] [.ZWaveBinarySensorCommandClass:102 ]- NODE 29: Sensor Binary report, type=Unknown, value=255
2016-03-27 17:01:49.671 [DEBUG] [b.z.i.protocol.ZWaveController:635 ]- Notifying event listeners: ZWaveBinarySensorValueEvent
2016-03-27 17:01:49.671 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2016-03-27 17:01:49.672 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 29: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_BINARY, value = 255
2016-03-27 17:01:49.672 [DEBUG] [ApplicationCommandMessageClass:85  ]- Transaction not completed: node address inconsistent.

2016-03-27 17:01:58.702 [DEBUG] [ApplicationCommandMessageClass:38  ]- NODE 29: Application Command Request (ALIVE:DONE)
2016-03-27 17:01:58.703 [DEBUG] [ApplicationCommandMessageClass:56  ]- NODE 29: Incoming command class SENSOR_BINARY
2016-03-27 17:01:58.703 [DEBUG] [.ZWaveBinarySensorCommandClass:82  ]- NODE 29: Received Sensor Binary Request (v1)
2016-03-27 17:01:58.703 [DEBUG] [.ZWaveBinarySensorCommandClass:102 ]- NODE 29: Sensor Binary report, type=Unknown, value=0
2016-03-27 17:01:58.703 [DEBUG] [b.z.i.protocol.ZWaveController:635 ]- Notifying event listeners: ZWaveBinarySensorValueEvent
2016-03-27 17:01:58.704 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2016-03-27 17:01:58.704 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 29: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_BINARY, value = 0
2016-03-27 17:01:58.705 [DEBUG] [ApplicationCommandMessageClass:85  ]- Transaction not completed: node address inconsistent.

I have configured a item like this
Contact Door_GF_Hall_zw "Inngangdør [%s]" <frontdoor> (Doors) {zwave="29:command=sensor_binary,sensor_type=10"}

and i sitemap entry like
Text item=Door_GF_Hall_zw label="Inngangdør [%s]"

The problem is that the door is reported to be OPEN, regardless of what state sent by the sensor.

I can see som entries in the zwave log that might point out a problem, but I’m not have the proper zwave skils to understand what the problem might be.


The log looks fine, but I would try changing the string to the following -:


Hi, and thanks a ton for helping out. Highly appreciated!

Actually I got it working by using the following binding config.


Now status is updated with OPEN or CLOSED according to the sensor position, except in one situation. I I closed the door “with a slam” like my kids have a tendency to do, the led on the door sensor starts to blink blue for like 4-5 seconds (like the tamper button has been release), and then the door i still listed as OPEN in OpenHAB. The tamper button underneath the sensor cannot be release by a slam, because I have mounted the sensor with screws that are pretty good tightened. Is there a vibration sensor in the device that can be disabled, it doesn’t look like that to me?


No - there’s no vibration sensor in this device - I’m not sure what would cause this problem (tell the kids not to slam the door! :wink:).

Hehe, thanks for all the help!


I’m also testing this device but I’m having some issues.
I have two FGK-10x sensors: one with the 2.5 firmware and the other with v3.2.
While the one with the older firmware works flawlessly, the other one fails to be properly recognized by the zwave binding.
During discovery it is being reported as Z-Wave Node 7 (010F:0701:1001:3.2) and then no channels nor properties pop up in the thing configuration.
The version of the zwave binding I’m using is
Should I open an issue for this?

I’ve updated the database, so hopefully it will be detected if you grab the snapshot from tomorrow…

On closer inspection, the newer version you have is totally different to the older version. It looks like all the parameters and some command classes are different.

I’ve created a new database entry ( for the device - it will need the XML loading to it if OH2 is creating one (in the userdata/zwave folder).

It would be good if someone has the time to add the parameters for the device since configuration won’t be possible until this is done.

Hi Chris,

just for clarifying, if you explain to me what to do a little bit in detail, I will try do this, I found an entry of the old one of the sensor (til version 2.5?) one in your database. Do I have create an account and modify these version with the parameters of the new version? There is only a short description in the sensor box, I had to download the detailed version from fibaro, don’t know it this version the current valid one?

Thanks - I’ll try…

I’ve created the new version here. Looking at the manual, the parameters are totally different to the previous version, so someone will need to add them by hand (ie we can’t really copy the old ones and then modify a couple of them to make them the same as the new device).

I also attached the manual to the database at the link above (the manual is at the bottom of the page).

So, you will need to create an account on the database site, then let me know and I’ll give you access to edit. From here there are two things to do - firstly, if OH has created an XML file (in the /etc/zwave folder for OH1) then upload this to the site using the tools button at the top right of the page (select “Update Device”). Then you will need to manually add the parameters and the options, and also the association groups - these should all be listed in the manual, so it’s “simply” a case of adding them to the database (it should be easy, but it will take a bit of time).

Let me know if that makes sense. There is a database overview on the site with some information, or if you have questions, just fire away and I’ll hopefully be able to answer them…


Hi Chris,

link doesn’t work … so I cannat go on …

The link should be fine - there was a problem with the server but it should be working now.

Hi Chris,

Now I have registered me, please give me the edit rights. I already
downloaded the new pdf.
My nick is pd.

Hear from you

kind regards



account created and pdf downloaded, please give me edit right in your database




where do I find the xml there is no etc/zwave … my folders are:

openHAB-System: cd /usr/share/openhab
Addons: cd /usr/share/openhab/addons
Konfigurationsdateien cd /etc/openhab/configurations
Log-Files: cd /var/log/openhab