Fibaro DoubleSwitch (FGS223): COMMAND_CLASS_SWITCH_BINARY for endpoint 1 not found


my Fibaro DoubleSwitch (FGS223) is not receiving commands in OpenHab Version 3.4. Debug Output is as follows:

2023-03-19 21:40:37.225 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 24: Command received zwave:device:gid_zwave_bridge:node24:switch_binary1 → ON [OnOffType]
2023-03-19 21:40:37.226 [DEBUG] [converter.ZWaveBinarySwitchConverter] - NODE 24: Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 1 not found
2023-03-19 21:40:37.226 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 24: No messages returned from converter

Anybody can help?

Did this work before (and on what version) or is this a new device? Could try to delete thing (do no exclude) and rescan for updating (if you were on an earlier version). It looks like parameter 20 was recently changed maybe that is an issue for you?

Thanks, I yesterday newly installed OH3.4. Previously I was using OH2. When I start my old OH2 instance the switch is working perfectly.

I already tried to exclude and re-included the device, but same result. It works with OH2, but not with OH3.4.

I am not able to change any parameter. If I change it, it is automatically reset to the previous value.

Any other ideas?

I do not have the device, so I’m guessing. When I briefly looked at the history of the device (only on OH3 however) there were frequent updates of the community maintained DB, obviously one change wasn’t helpful to everyone. Looking at the channels for the device, do they look exactly the same between OH2 and OH3? Sometimes the root (0) is a copy of Endpoint 1, specifically are both channels zwave:device:controllerid:nodeid:switch_binary1 or is there a zwave:device:controllerid:nodeid:switch_binary?

Problem solved. I compared the node.xml file from my OH2 instance with the node.xml file from OH3.4 instance. The one from OH3.4 did not contain the COMMAND_CLASS_SWITCH_BINARY. Probably the node was not yet fully initialized. Finally, I used the node.xml from my OH2 in OH 3.4 an then it worked.

1 Like