Fibaro FGBS001 Universal Binary Sensor not working in openHAB2

I’m finally giving up on this one.

After slowly migrating to openHAB2 I was able to migrate all my zwave devices except this one:

I deleted it from the Things section, added it again.
I tried to reinitialize, no xml file is created.
I excluded it, did a hardware reset, included it again. Nothing
I bought a new device (!), tried to include it … no xml file created.

openHAB2 Snapshot Build #594 from today, zwave binding 20161118

Device was already on the stick, included in openHAB1.

Debug log

Log Viewer:

It’s a mains powered device …

Any ideas? After one week of trying I’m out of ideas …

Edit: Device is about one meter away from the controller

Please provide an unfiltered log. If you filter it to just this node, then we loose all the receive data messages which don’t have the node number listed as we don’t know this until much later…

From what I see though, the device probably doesn’t support the ALARM_SUPPORTED_GET message, so we can easily update the database to solve this if it’s the case.

Thx … hopefully I picked the right section from my huge debug log:

It looks like the configuration to stop this happening on EP2 was already done. I’ve added it to EP1 as well so let’s see if it solves the issue…

I’ll try and update the binding later tonight.

Unfortunately not.
I grabbed the latest openHAB2 snapshot #603 from this morning, zwave binding is now
FGBS001 Fibaro Universal Sensor node number is now 21.
Excluded the device from the controller, hard resetted it, included it again:
Still no xml file is created.
In Habmin under “Things” the screen shows a green node with “Node initialising: STATIC_VALUES” and there it stops.

Debug log:

Log Viewer

The binding hasn’t been updated yet as I didn’t around to doing it last night.

Okay, sorry for being impatient, will wait a few days longer …

That’s ok - I should get it done tonight - I just got caught up with other things last night…

I grabbed the latest zwave snapshot binding and the xml file was created instantly:

BUT: I still don’t get any commands from the device. :joy:
I linked items to all four channels (sensor_binary and sensor_alarm) and I can see they get added in the events.log, but if I physically trigger the input there is no command change.

Could it have something to do with those three messages in the device database?:

  • There are 2 association groups but none are linked to the controller. Is this correct?
  • Endpoint 1 has no command class linked to the basic class.
  • Endpoint 2 has no command class linked to the basic class.

Debug log for node 21:

Log Viewer output:

Probably - at least some updates seem to be using BASIC so this will need to be set - I’ll take a look tonight.

Some time left to take a quick look? :vulcan:

Sorry - it was a very long week at work (unfortunately week of the same another next week :frowning: ) and when I get home I’ve been trying to finish off the security classes…

Anyway, I’ve just updated the database so I’ll merge this tonight. Let’s see if it helps.

Sorry to hear, hopefully that earns a lot of money in your pocket :slight_smile:
Thanks a lot for updating the device, will try as soon as it makes it into the binding.

Sadly it never seems to work out like that ;)…

It should now be included…

Okay, will update and report …

… but unfortunately it’s still not working.

Maybe I just make a dumb mistake because I assume I’m not the only one who is using the FGBS001 with openHAB2.

I know you have a busy week so I will patiently wait until you get into this.

What I did:

  • installed new zwave binding version:
  • reinitialized the device
  • deleted device from things
  • added it again
  • added links to all four channels (sensor_binary, alarm_general)
  • -> did not work
  • added controller to association groups 1 and 2
  • -> did not work
  • changed config para 5 (Type of transmitted control frame for association group 1) to basic set and config para 6 (same for association group 2) to alarm generic
  • -> did not work

All was done with debug enabled, log can be found here (node21):


It looks like it’s at least receiving the data for the binary_sensor -:

2016-11-27 13:53:31.769 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 0D 00 04 00 15 07 60 0D 01 01 30 03 FF 45 
2016-11-27 13:53:31.816 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 21: Updating channel state zwave:device:1587db82cfc:node21:sensor_binary1 to ON [OnOffType]

The alarms don’t seem to be encapsulated in multi-channel, and as there’s no channels in the root, they won’t do anything -:

I don’t know if this should be sending these alarms in multi-channel encap?

What do you think it’s meant to send? eg if you press a button (or whatever is linked to the input) what do you think should happen? Should alarms be sent to the endpoint, or the root device. I’m not sure if you’ve looked at the log yourself in the viewer, but a lot of stuff is sent to the root…

I’ve only looked at the first log so far…

In the “old days” of openHAB1 that sensor worked as a contact for sensor_binary EP1 and EP2
Contact FibUniSens1_1 "Contact [%s]" { zwave="5:1:command=SENSOR_BINARY,respond_to_basic=TRUE" }

My assumption was that in openHAB2 it should work as a switch for sensor_binary EP1 and EP2.
So I defined it as:

But in the event.log nothing shows up and on the sitemap the two switches (actually four) are always off.

The general alarm was only meant as a test if something is coming in on this channel.

Ok - so these two channels still look like they are being sent. sensor_binary channel is however defined as a switch (as you correctly assumed :wink: ).

Strange - the binding says it is sending the state to ON / OFF for these channels :confused:. HABmin seems to think the channels are linked to items - are you sure the items are switches (sorry - I’m sure you are, but just double checking as everything seems to be working with these channels - except for the ‘small’ point that they don’t seem to actually work!)