Fibaro Motion Sensor not recognized

fibaro
zwave
Tags: #<Tag:0x00007f51ec5b5758> #<Tag:0x00007f51ec5b4cb8>

(SiHui) #13

Did Fibaro just recently expand to the market in India? That could be the reason why the firmware versions are the same, but the thing type and id are missing (I guess).
Could you please post your xml files for all devices missing? Or at least device name, firmware version, thing type and thing id?


(debjit) #14

Fibaro zwave+ IN devices are relatively new. 2018 manufactured. But zwave are available since last 1.5 yrs.
I used them with openhab 1.8 and it worked despite showing not in the database. I ignored the warning that time. Now once upgraded to openhab2 and added few new IN zwave+, everything stopped working.
I have added all xml files. Please help me to add them in the database.

Device Details:
FGMS-001 (zwave) Fibaro Motion Sensor (Node -4) v2.7

Z-Wave Node 004 (010F:0800:6001:2.7)

FGS222 (zwave) Fibaro Double Relay (Node-5) v2.2

Z-Wave Node 005 (010F:0202:6002:2.2)

FGS223(zwave+) Fibaro Double Relay (Node-6) v3.2

Z-Wave Node 006 (010F:0203:6000:3.2)

FGS213(zwave+) Fibaro single Relay (Node-7) v3.2

Z-Wave Node 007 (010F:0403:6000:3.2)

Being a new user not allowing me to attach the xml files. added the drive link.
https://drive.google.com/open?id=1xYSpoBjomzf2sk9fjVV5yLdyhago5FUQ

Any workaround to use these devices till the issue is fixed.
Thanks for the help.


(SiHui) #15

As your devices all look the same as the existing devices I’ve added the thing type and id from your xml files to the database. Not necessary to create new database entries.

http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/115
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/124
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/416
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/423

You need to upgrade to the latest snapshot 2.5 zwave binding once the changes got merged.

Yes, but it is a bit complex:


(debjit) #16

Thank you so much for your quick help. :smile:


(Bob Eckhoff) #17

is there a way to know when the 2.5 snapshot includes the update to the z-wave? I loaded an update from 1-12-19, but still getting the same error.


(Chris Jackson) #18

The only way to be sure is to check in GH -:

Alternatively, I generally do an update a couple of times a week (or at least once a week).

At the moment the system is broken though so the last update was about a week ago. I have another PR in the pipeline for the past few days, but until the CI issues are resolved I can’t merge -:


(debjit) #19

If you are comfortable in linux environment, can try "jar -xvf " to extract named (or all) files from archive. Then can check the expected changes is there or not.
Existing 2.5 zwave snapshot still not having the database changes, as Chris pointed changes are not yet merged.

Thanks


(Bob Eckhoff) #20

Thanks. That helps


(debjit) #21

In latest build #535 zwave-SNAPSHOT (org.openhab.binding.zwave-2.5.0-SNAPSHOT) all four Fibaro IN sensors (FGMS-001, FGS222, FGS223, FGS213) are recognized and working.

Thanks


(Joan Pujol) #22

This can be the problem I’ve in mine question. Or mine it’s another problem?


(SiHui) #23

If initialization is not completed wake the device multiple times, push the button inside the housing.


(Bob Eckhoff) #24

Ditto. Latest snapshot solved problem. on to next step.

Thanks


(Joan Pujol) #25

I’ve just done dozens of times (literally) with a new fibaro switch and it’s impossible. Initialization never ends.
In my case it must be something really broken because I installed HomeAssistant in an old Raspberry and changed the stick to it and it was recognized immediatally.
More details in my thread…


(Bob Eckhoff) #26

If this is the same problem as others in this thread, here is what you need to do.

  1. Use PaperUI to remove the Z-wave 2.4 binding

  2. Use sudo systemctl stop openhab2

  3. Delete both the /var/lib/openhab2/tmp and /var/lib/openhab2/cache folders

  4. Copy the latest zwave 2.5 shapshot into /usr/share/openhab2/addons folder

  5. Restart openhab2

  6. Type: sudo openhab-cli console

  7. Type: feature:install openhab-transport-serial

That is what I did. If that doesn’t do it, I can’t help. I probably can’t answer too many questions either as I am at the limit of my knowledge


[SOLVED]Get Fibaro FGMS-001 motion sensor to initialize
(Joan Pujol) #27

Thanks @apella12.
I’ve just tried and it seems that devices are detected a littler faster but still never initialized.


(Bob Eckhoff) #28

Then it is probably not the same problem. Mine popped up pretty quick after that procedure (I was close to the Zwave stick and did press the motion detector back button a few times to wake it up. The experts are going to want to look at your xml file for that node (in the /var/lib/openhab2/zwave directory). About 7-8 lines down are Device ID and Device Type. That should match one of the options in the device list. If not it needs to be added, if it is there you have another problem I can’t help with. Sorry.


(Andrew Rowe) #29

an easier option for this step might be

openhab-cli clean-cache

which deletes tmp and cache folders


(Bob Eckhoff) #30

I’m pretty much a novice and my instructions were a compilation from a few posts. However I noticed if OpenHab is still running the cache and tmp folders will reappear and if Openhab is stopped (Step 2) the Openhab-cli is not running. Anyway since I have those folders as part of my Samba, it wasn’t that hard or time consuming to do what I outlined above.


(Andrew Rowe) #31

I could be completely wrong but from memory, I’m almost positive that openHAB was stopped and the openhab-cli clean-cache still ran. Afterwards, I checked and the folders were gone. Then I started openHAB


(Bob Eckhoff) #32

Not knowledgeable enough either way. Obviously it worked for you.