Fibaro RGBW with input setup

Hi gents.

I’m trying to setup my Fibaro RGBW in Openhab 1.8 and make use of one input for an analog sensor (PIR to be precise). My goal ist to run a RGB LED strip with the motion sensor on the remaining port.

I need the input value in openhab as I want to also trigger a second RGB Strip.

I read all over the Internet and forum here but all I can find is trouble and ideas what might/should work better (e.g. using basic command).

I believe I tried any imaginable setup and approach recommended but can’t get a reading.
My second Strip (without input) works perfectly well so I’m quite sure it’s either linked to parameter 14 or the item definitions.
Also: the hardware is running off a breadboard at the moment and gives reading between 1v and 2v pending the state. So I should be able to use this as trigger in rules if I get this input reported.

Anyone got it working? I was planning to have these modules all over the house to realise a motion triggered night light with occupancy tracker. But my first one really puts me back on my schedule.


Later (when I’m on my desktop) I’ll post Screenshot of my configuration and items. However there are numerous of these already but none working one :blush:

I think you have to decide if you want one endpoint as output or as input.
There is some parameter where you can configure the endpoint.
Check the datasheet, there is an explanation.
Without configuring, all endpoints are outputs.

Hi Sebastian

Yes I assume you are right. My configuration was using channel 1-3 as output (RGB) while channel 4 is input (former W channel).
From the item declaration they seem to be one shifted. So 1:2 points to channel 1(Red). And 1:5 to channel 4 (white/input).

Parameter 14 to set the input/output behaviour is configured as hex 9998 (and converted to decimal) according datasheet. Yet I don’t get an input reading.
Still own you the Screenshots/Items. Sorry…

The FGRGBW has 8 ports, 4 are RGBW output, these you can attach your strip to.
The other 4 ports can be configured to either be all input or all output.
Since you want an input for your PIR, you need them to be all input.

What you’re possibly missing is to configure an additional association group. See section XI of the manual.
If you put your PIR on port I1, you can assign a number item to <zwave ID>:1 (or was it :2 ?) to read the value.
At the same time, you can assign a switch item to <zwave ID>:1 which then translates into the first output channel, which is always the ‘R’ (Red) port.

Also, to hook up a PIR to this actor is no good idea anyway IMHO. PIRs (usually) deliver digital value, while the FGRBGW input ports are built to detect analog voltage range.
Well, it should work. But in order to transmit a digital value, there’s better solutions. While not the cheapest of all possible alternatives, I suggest you get a FGMS motion detector. Will allow you to place it anywhere without taking care of cabling. In the long run, that’s a big plus, e.g. if you realize you need to relocate it later on for sake of better detection.

I have not specified additional report groups. This is definately not needed!

Try setting Parameter 14 to “-26471”. This will give you pin 2 as input, the rest as output.
Then set Parameter 43 to something that makes sense ( e.g.5).
This should give you automatic reports.

Now as that definitely didn’t work for me, I believe there’s different firmware versions to behave different.

Maybe you should post the configuration, items and association groups.

I have to admit I got it working once but had issues with the outputs. So I played around further and screwed it from there. So I can confirm it’s possible but the how… :slight_smile:
that much about the opening words. Now my current setup (not working)


Dimmer kitchen_led2__All “2-Helligkeit [%d %%]” {zwave=“7”}
Dimmer kitchen_led2_R “2-Rot [%d %%]” {zwave=“7:2:command=switch_multilevel”}
Dimmer kitchen_led2_G “2-Green [%d %%]” {zwave=“7:3:command=switch_multilevel”}
Dimmer kitchen_led2_B “2-Blau [%d %%]” {zwave=“7:4:command=switch_multilevel”}
Dimmer Kitchen_led2_in1 “LED input 1 [%d]” {zwave=“7:5:command=sensor_multilevel,respond_to_basic=true”}

Dimmer test_led_0 “LED CHannel 0 [%d %%]” {zwave=“7:command=switch_multilevel”}
Dimmer test_led_1 “LED CHannel 1 [%d %%]” {zwave=“7:1:command=switch_multilevel”}
Dimmer test_led_2 “LED CHannel 2-red [%d %%]” {zwave=“7:2:command=switch_multilevel”}
Dimmer test_led_3 “LED CHannel 3-green [%d %%]” {zwave=“7:3:command=switch_multilevel”}
Dimmer test_led_4 “LED CHannel 4-blue [%d %%]” {zwave=“7:4:command=switch_multilevel”}
Dimmer test_led_5 “LED CHannel 5 [%d %%]” {zwave=“7:5:command=switch_multilevel”}

Number test_led_in1 “led in1 [%d]” {zwave=“7:1:command=BASIC,respond_to_basic=true,refresh_interval=60”}
Number test_led_in2 “led in2 [%d]” {zwave=“7:2:command=BASIC,respond_to_basic=true,refresh_interval=60”}
Number test_led_in3 “led in3 [%d]” {zwave=“7:3:command=BASIC,respond_to_basic=true,refresh_interval=60”}
Number test_led_in4 “led in4 [%d]” {zwave=“7:4:command=BASIC,respond_to_basic=true,refresh_interval=60”}
Number test_led_in5 “led in5 [%d]” {zwave=“7:5:command=BASIC,respond_to_basic=true,refresh_interval=60”}

Yes some are doubled as I use different styles on different sitemaps. I tried to comment out/delete some to see if that’s the issue but doesn’t seem so.

for the sitemap:

Default sitemap

 sitemap default label="Main Menu"
  Frame label="LED" {
         Slider item=Kitchen_led2_in1
   Frame label="LED2" {
         Slider item=kitchen_led2_R
         Slider item=kitchen_led2_G
         Slider item=kitchen_led2_B

(other rooms and some non related definitions removed (to keep it simple) )

and sitemap for investigation/troubleshooting of this input

    sitemap testing label="testing items"
            Slider item=test_led_0
            Text item=test_led_1
            Slider item=test_led_2
            Slider item=test_led_3
            Slider item=test_led_4
            Text item=test_led_5
            Text item=test_led_in1
            Text item=test_led_in2
            Text item=test_led_in3
            Text item=test_led_in4
            Text item=test_led_in5

I’m running it of a RPI with ZWAY Server daughter card. Therefore I use habmin to configure the items. I did this with the other rgb strip as well and seem to work better than with z-way-server.
Zwave binding is 1.8.2

so far above it’s not working. I’ll now try above approaches and see if it’s helps.

Do you set the Master Dimmer to 100%?

Yes and no.

The rgb output works great. When I change one of the 3 channel the master follows. When I increase the master the last selected color fires up.
I don’t think this should affect the input values.

For the assocuation: what do I need to associate to? Node 1 which is openhab or the node of the second LED strip?

Here is my working config.

Dimmer     Kueche_Arbeitsplatte_Out_All            "Arbeitsplatte alle [%d]"                            (gInitializeZero)                        {zwave="23:1:command=SWITCH_MULTILEVEL" }
Dimmer     Kueche_Arbeitsplatte_Out_R                "Arbeitsplatte [%d]"                                (gInitializeZero)                        {zwave="23:2:command=SWITCH_MULTILEVEL" }
Dimmer     Kueche_Arbeitsplatte_Out_G                "Arbeitsplatte Gelb [%d]"                            (gInitializeZero)                        {zwave="23:3:command=SWITCH_MULTILEVEL,refresh_interval=3600" }
Dimmer     Kueche_Arbeitsplatte_Out_B                "Arbeitsplatte Blau [%d]"                            (gInitializeZero)                        {zwave="23:4:command=SWITCH_MULTILEVEL" }
Dimmer     Kueche_Arbeitsplatte_Out_W                "Arbeitsplatte Weiß [%d]"                            (gInitializeZero)                        {zwave="23:5:command=SWITCH_MULTILEVEL" }

The Analog input is connected to
```Kueche_Arbeitsplatte_Out_G```` (G)

Can you try this (and only this) configuration for this node?
Also when first initializing I do set the Master Output to 100%.
Try this, too.

DANKE Sebastian

It works. I don’t really get why but I have confidence now to make it nice… using my g output on w is just not “well done” and calling your input on as an output item is the next thing I could not stand. Anyway that seems to be cosmetic…

One day I think we should extend the zwave binding items list. But to do so I like to get down to what is different between yours and mine…
Let me play around with it and will answer/edit my first post accordingly.

By the way: accossiation: so in fact I didn’t need to change anything but node 1 (openhab) seems to be auto associated. So for someone with secondary controller this might be indeed one issue.

edit: notes to myself:

parameter 14:
9998 (all out except W is in) --> 39320 --> -26216 (Habmin)
9899 (all out except G is in) --> 39065 --> -26471 (Habmin)

Hi, @Spaceman_Spiff

I have fibaro rgbw 441controller and i connected red green blue wires of strip to R G B points of controller and white point is open . i don’t want to used white point. and IN points on controller are also open i don’t want to use that.

So for this situation any configuration need to do or it will work as default…?
i am talking about parameter 14 setting.


works with default.