Firefox & OH 4.0.1 issues


Since upgrading to OH 4.0.1 from 3.4.0 I have issues when using the UI with Firefox. When I make changes, like adding an Item, the Model (Administration, Settings, Model) does not get updated and does not show the changes until I completely close and open the browser again. When using Chrome it works fine.

Are there any known issues with OH 4.0.1 and Firefox?

1 Like

This has come up recently.

I don’t know enough about it too know whether this is something that the UI can manage automatically or if you need to disable something in Firefox.

It might be worth opening an issue in the UI repository.

I have issues as well since I the last Firefox update. Currently using oh 4.0.3, but it did happen with 4.0.2 as well. I I load the openhab page it stays blank. I have to press CTRL+F5 to see something. However, since a few days not even that works, the page stays blank and it loads forever.

Opening the UI in Chrome, mobile client or edge works without problems.

hi @sven1234
i have same issue often i opening white page (had this with 3.x version also but its still existing until 4.0.3). ctrl+f5 and it works.
what i got out: app.js and app.css were tried to load and they are getting a 404 and then its resulting in white page.
after ctrl+f5 they were loaded but in another way: app.b1e916848415a5f0af1b.css and app.b1e916848415a5f0af1b.js
im using nginx before openhab. But a solution for that i dont have…

Hi all,

I´m not sure if this fits here as well so I just try.

I was adding a bridge in a thing (PV forecast binding) and in firefox the list which was sliding from the bottom (with the checkboxes) was empty. Just one line with a “dot”/checkbox but no text/bridge to it.
In edge the very same thing showed the existing bridge/thing in this list.
As a result in firefox the bridge could not be selected and in edge it could.

I hope this helps a bit.

Best regards and thanks for this awsome software

1 Like

Firefox does not update the internal cache in case of changes on the server site. :rage:
My workaround:
With the extension “Clear Cache” the cache is reset and the site reload.

Yes, that works quite well - still hopefully this can be resolved somehow. Firefox is still a major browser and I think there must be a way to implement it so it works with Firefox as well.

I have just created a PR that sets another cache control directives as suggested by the mdn web docs, and according to my tests, it seems that Firefox now handled cache revalidation as expected, so this issue should be solved once my PR is merged.


FYI I have similar problems with FF (on the other hand chrome is working perfectly).