Gardena Binding is not working anymore (HTTP 403 forbidden)

Hello openHAB community,

since today my Gardena Bindung 2.4.0 is not working anymore.
I am on openHabian with openHAB 2.4.0 stable.

2019-02-25 17:38:22.848 [hingStatusInfoChangedEvent] - ‘gardena:account:a4c3e5cc’ changed from UNINITIALIZED to INITIALIZING

2019-02-25 17:38:23.094 [hingStatusInfoChangedEvent] - ‘gardena:account:a4c3e5cc’ changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): Error 403 Forbidden

Any idea?
Somebody with the same problem?

Tanks in advance!

same here. Can anyone help out?

Hier ist die Anwort von Gardena zu diesem Thema:

Wir bedauern die Ihnen entstandenen Unannehmlichkeiten durch unser smart system sehr.

Für die genaue Ursache dieses Fehlers haben wir leider keine zweifelsfreie Erklärung.

Am gestrigen Montag wurde durch den Push die URLs umgestellt, was zur Folge hat, dass eine neue API besteht.
Wir können uns vorstellen, dass dies möglicherweise die Ursache für Ihr Anliegen ist.

Wir hoffen, dass Ihnen diese Informationen weiterhelfen.

Für weitere Fragen stehen wir Ihnen gern zur Verfügung.

Freundliche Grüße

i. A. Stefan Harder
Hans-Lorenser-Str. 40
89079 Ulm

2019-02-26 14:00:32.222 [TRACE] [ng.gardena.internal.GardenaSmartImpl] - POST request:
2019-02-26 14:00:32.223 [TRACE] [ng.gardena.internal.GardenaSmartImpl] - POST data : {“sessions”:{“email”:“xxxx”,“password”:“xxxxxxx”,“sessionTimeout”:30,“connectionTimeout”:10,“refresh”:60}}
2019-02-26 14:00:32.477 [TRACE] [ng.gardena.internal.GardenaSmartImpl] - Status : 403
2019-02-26 14:00:32.478 [TRACE] [ng.gardena.internal.GardenaSmartImpl] - Response: {“message”:“Missing Authentication Token”}

2019-02-26 14:00:32.478 [DEBUG] [ternal.handler.GardenaAccountHandler] - Disposing Gardena account ‘home’
2019-02-26 14:00:32.479 [DEBUG] [ternal.handler.GardenaAccountHandler] - Error 403 Forbidden
org.openhab.binding.gardena.internal.exception.GardenaException: Error 403 Forbidden
at org.openhab.binding.gardena.internal.GardenaSmartImpl.executeRequest( ~[?:?]
at org.openhab.binding.gardena.internal.GardenaSmartImpl.verifySession( ~[?:?]
at org.openhab.binding.gardena.internal.GardenaSmartImpl.loadAllDevices( ~[?:?]
at org.openhab.binding.gardena.internal.GardenaSmartImpl.init( ~[?:?]
at org.openhab.binding.gardena.internal.handler.GardenaAccountHandler.lambda$0( ~[?:?]
at java.util.concurrent.Executors$ [?:?]
at [?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( [?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ [?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
at java.util.concurrent.ThreadPoolExecutor$ [?:?]
at [?:?]
Caused by: org.openhab.binding.gardena.internal.exception.GardenaException: Error 403 Forbidden

They indeed did change the API. You need to retrieve a session token first based on your email address and password which in turn acts as a bearer authorization header. That’s what I learned from a quick look at the network requests. Don’t know if anything else has changed.

yep, that is what I guessed but dont see anything in their “smart” portal that would let you grab a token.

It’s the first POST request to
Submitted data is {“data”:{“type”:“token”,“attributes”:{“username”:“”,“password”:“PASSWORD”}}}

I got the same problem, any new ideas? New message is : Gardena%20openhab%20Prob

get the token via curl seems to work:

curl -s --data ‘{“sessions”:{“email”:"???@???",“password”:“xxxxxxxxx”}}’ --header “Content-Type:application/json”

=> the binding is still offline:

I changed the API endpoints and response structure to get the token and authorization provider from the new API.

I didn’t have time yet to test it intensively so USE AT YOUR OWN RISK!
If it works it is still only a temporary solution until the original author decides to fix it.


Thx for fixing it - for me its working now …

What would a 2.4.0 user need to do to get this working?

This JAR should work for 2.4.0 too.
Simply put it in your addons/ folder (e.g. /usr/share/openhab2/addons/) and restart openhab.
Please remember to REMOVE it again when you update openhab2 with an updated version of this binding.

1 Like

Well, that works perfectly. You, sir, are a wizard!

for me its works too. But I get an warning in the log…

2019-03-02 20:44:33.758 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler GardenaAccountHandler tried updating the thing status although the handler was already disposed.

For me this workaround didn’t work.

openHAB 2.5.0 Build #1533


reboot openhab, try to reconnet to Gardena Smart Home Account


In the logfile I have the same entry as Cernon

2019-03-03 13:27:15.768 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler GardenaAccountHandler tried updating the thing status although the handler was already disposed.

you have a tip for me?

After I removed the binding, restarted openHAB, reembedded the Gardena Binding the status is back to Online :slight_smile:


Hi - just wondered if the new binding has been merged into the latest openHAB version?



Same question here as I consider buying a Gardena system or another one

Not sure this is the same problem, but I always loose connection and see the following error inside the gardena app:

Same for me. I had to deactivate the binding (removing the account data) in order to make the app work again as previously. More info here: