Gardena Binding: Various problems / errors

Tags: #<Tag:0x00007f5c9330adf8>

I have recently installed the Gardena binding and configured the items und things. I get the following warnings, that occur very frequently.

2020-02-22 19:07:30.275 [WARN ] [internal.handler.GardenaThingHandler] - Channel 'gardena:watering_computer:xxx:yyy:outlet#valve_open' cannot be updated as device does not contain property 'outlet:valve_open'
2020-02-22 19:07:30.279 [WARN ] [internal.handler.GardenaThingHandler] - Channel 'gardena:watering_computer:xxx:yyy:outlet#manual_override' cannot be updated as device does not contain property 'outlet:manual_override'
2020-02-22 19:07:30.283 [WARN ] [internal.handler.GardenaThingHandler] - Channel 'gardena:watering_computer:xxx:yyy:outlet#button_manual_override_time' cannot be updated as device does not contain property 'outlet:button_manual_override_time'
2020-02-22 19:07:30.288 [WARN ] [internal.handler.GardenaThingHandler] - Channel 'gardena:watering_computer:xxx:yyy:ambient_temperature#temperature' cannot be updated as device does not contain property 'ambient_temperature:temperature'
2020-02-22 19:07:30.292 [WARN ] [internal.handler.GardenaThingHandler] - Channel 'gardena:watering_computer:xxx:yyy:ambient_temperature#frost_warning' cannot be updated as device does not contain property 'ambient_temperature:frost_warning'

What needs to be done to fix this problem.

I am using openHAB 2.5.1 on a Raspberry PI - all versions are up-to-date.

Thank you for the support.

1 Like

How did you configure the Thing and Item in PaperUI or files?

I configured the Thing using Paper UI

Have you tried creating an items file and use the channel info from PaperUI for the link?

If you can post a screen shot of the Thing and channel it may help to see if there is a config issue or something else missing.

I fully used PaperUI to discover the things, which I added afterwards and created an items file using the information displayed in PaperUI

That is the recommended way. :+1:

Please post the items file also.

EDIT:
Also it may help to set the binding to DEBUG or TRACE via the console and see if there is any additional info that may help.

How to do that?

From the command line type sudo openhab-cli console this will take you to the Karaf console. Once in the console type log:set TRACE org.openhab.binding.gardena and replace TRACE with DEBUG to for the debug output.

Afterwards you will want to turn this off so replace TRACE/DEBUG with INFO to set it back to normal.

@CHTHSCH looking back at the log in OP it mentions the “device” does not contain the property. Makes me wonder if the device or OH version is not up to date. :thinking:

I can’t help much with the device but I can provide a link to a more recent snapshot of this binding.

From the link use only the jar file not the one ending with sources.jar

https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/addons/bundles/org.openhab.binding.gardena/2.5.2-SNAPSHOT/

You will want to uninstall Gardena binding via PaperUI first then place the jar file in usr/share/openhab2/addons, restart OH, and rediscover your Things.

If the above version does not work there is a 2.5.3 you can try.
https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/addons/bundles/org.openhab.binding.gardena/2.5.3-SNAPSHOT/

FYI you will need to remove the 2.5.2 jar when adding the 2.5.3 and like above restart OH the rediscover Thing.

Thanks for your support. Much appreciated!!

turning on DEBUG and TRACE did not provide any additional information except:

2020-02-23 21:35:19.251 [DEBUG] [ng.gardena.internal.GardenaSmartImpl] - Refreshing gardena device data

I also tried the two SNAPSHOT versions. Both with the same result as the 2.5.1. version. So these did not solve the problem

Update

I finally put the vale outside. Do not expect frost anymore. When I tried to start irrigation, I got this error message:

2020-03-14 13:48:50.407 [nt.ItemStatePredictedEvent] - Wasser_Ventil predicted to become ON
2020-03-14 13:48:50.424 [vent.ItemStateChangedEvent] - Wasser_Ventil changed from OFF to ON
==> /var/log/openhab2/openhab.log <==
2020-03-14 13:48:50.448 [WARN ] [internal.handler.GardenaThingHandler] - Ability 'outlet' not found in device 'Bewässerung'
org.openhab.binding.gardena.internal.exception.GardenaException: Ability 'outlet' not found in device 'Bewässerung'
	at org.openhab.binding.gardena.internal.model.Device.getAbility(Device.java:115) ~[bundleFile:?]
	at org.openhab.binding.gardena.internal.GardenaSmartImpl.sendCommand(GardenaSmartImpl.java:331) ~[bundleFile:?]
	at org.openhab.binding.gardena.internal.handler.GardenaThingHandler.handleCommand(GardenaThingHandler.java:228) [bundleFile:?]
	at sun.reflect.GeneratedMethodAccessor686.invoke(Unknown Source) ~[?:?]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_222]
	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_222]
	at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:152) [bundleFile:?]
	at org.eclipse.smarthome.core.internal.common.InvocationHandlerSync.invoke(InvocationHandlerSync.java:59) [bundleFile:?]
	at com.sun.proxy.$Proxy8108.handleCommand(Unknown Source) [?:?]
	at org.eclipse.smarthome.core.thing.internal.profiles.ProfileCallbackImpl.handleCommand(ProfileCallbackImpl.java:74) [bundleFile:?]
	at org.eclipse.smarthome.core.thing.internal.profiles.SystemDefaultProfile.onCommandFromItem(SystemDefaultProfile.java:48) [bundleFile:?]
	at sun.reflect.GeneratedMethodAccessor651.invoke(Unknown Source) ~[?:?]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_222]
	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_222]
	at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:152) [bundleFile:?]
	at org.eclipse.smarthome.core.internal.common.Invocation.call(Invocation.java:52) [bundleFile:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_222]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]

Please help. There is something wrong with the binding.

I am using:
Release = Raspbian GNU/Linux 10 (buster)
Kernel = Linux 4.19.97-v7+
Platform = Raspberry Pi 3 Model B Plus Rev 1.3

openHAB 2.5.2-1 (Release Build)

Gardena Smart System Firmware 4.2.7

Looking at the Things pic posted above and the log I do not see Bewasserung?

Ability 'outlet' not found in device 'Bewässerung'

Do you have simple mode turned on in PaperUI?

Bewässerung is the name of the device in Gardena Smart System

May it be, that the problem is caused by the ä in the name of the device?

No, renamed to Wasserhahn and still have the same problem. I deleted the device in PaperUI and searched for it again after I did the renaming.

Not sure if the ä is the issue, b/c the log found the device, but try changing it and see what happens.

I would think the problem is “outlet” not being found in the device. If you have simple mode turned on and created the things manually you may have duplicates that are causing this.

To check for duplicates:
Look in /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.link.ItemChannelLink.json and make sure there isn’t a Link hanging around. Also, for items check: /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.items.Item.json

Note, If you find a duplicate make sure to stop OH before making any changes to these files.

Don’t know what you mean with simple mode. I added the thing automatically in PaperUI: Inbox - + - Gardena Binding …
The thing gets discovered automatically

This file: /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.link.ItemChannelLink.json is empty, only contains {}

This file /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.items.Item.json is also empty

Opened both with nano.

It a setting in PaperUI that auto creates your things.

That’s good, you have no duplicates.

You can view the contents of a file using cat e.g. cat /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.items.Item.json

I would stop OH and clean the cache then do a few restarts (make sure OH has fully reloaded between restarts, watch the logs) and see if that helps.

If the problem continues try using files to create the Thing and items like in the documents examples.

Hi all,

I create all my things and items on file level, not in PaperUI. Also for Gardena. Since I started this season ~1 week ago, I face the same problem as described above, only with watering_computer, and those 5 channels as mentioned by CHTHSCH: outlet#valve_open, outlet#manual_override, outlet#button_manual_override_time, ambient_temperature#temperature, ambient_temperature#frost_warning, while the rest are working. Watering Computer received a firmware update when I started it. Sensor and power outlet act well. Cleaning and rebooting openHAB doesn’t add any value. Used PaperUI to crosscheck channel detection, all expected show up. As Gardena/Husqvarna did quite some internal changes for the Feb release, I do expect some blocking changes in communication or naming of those parameters in their protocol: properties are promoted to the binding, but cannot be found/read from the query.

This file does not exist on my system

These are the settings I used