Get only error while trying to use Rest call via [http-Binding]

Tags: #<Tag:0x00007fc8f6647028> #<Tag:0x00007fc8f6646f38>

Hello everybody! I’m trying to use OH3 with my FENECON FEMS Controller, which provides Data from my PV-Battery via REST-call.

I do the following test on linux commandline:
curl http://x:user@192.168.0.227:8084/rest/channel/_sum/ConsumptionActivePower

as result I got

{"address":"_sum/ConsumptionActivePower","type":"INTEGER","accessMode":"RO","text":"","unit":"W","value":591}

Now I use the http-Binding with this settings:

UID: http:url:FEMS
label: HTTP URL Thing
thingTypeUID: http:url
configuration:
  authMode: BASIC
  ignoreSSLErrors: true
  baseURL: http://192.168.0.227:8084
  password: user
  refresh: 5
  commandMethod: GET
  contentType: application/json
  timeout: 3000
  username: x
  bufferSize: 2048
location: Garage
channels:
  - id: Verbrauch_Haus
    channelTypeUID: http:number
    label: Energie
    description: ""
    configuration:
      mode: READONLY
      stateExtension: /rest/channel/_sum/ConsumptionActivePower
      stateTransformation: JSONPATH:value.$

I got this errormessage:

2021-02-28 14:15:29.672 [WARN ] [p.internal.http.HttpResponseListener] - Requesting 'http://192.168.0.227:8084/rest/channel/_sum/ConsumptionActivePower' (method='GET', content='null') failed: HTTP protocol violation: Authentication challenge without WWW-Authenticate header

Where is the problem?
The username is “x” and the password is “user”.
I have no Idea what I’m doing wrong with this binding?

Thanks a lot for your support!

Have a look to [SOLVED] OH3: http authentication issue could be that it is the same issue which seems to be solved in the snapshot of the binding.

Thank you @Wolfgang_S for your hint! I try, but it won’t help.
It’ a bit strange, because I do the update, but in the adminview of OH3 (Settings / Addons / Bindings ) I got still the versioninfo 3.0.1 in case of 3.1.0.

Reboot of the machine was done, no change.

When I got the the OH-konsole and do

bundle:list -s |grep http
I got (beneath others) :
279 | Active | 80 | 3.1.0.202103010326 | org.openhab.binding.http

So the binding itself has 3.1.0, but how can I “say” OH to use this one?!

I would guess that the console is correct. Do you or did you have a http binding .jar in the addons folder?

There was a file openhab-addons-3.0.1.kar in the addons-folder.
I put it away and made a reboot, but it’s still shows 3.01 at the http-binding.

Now I testet the bundle:list again:

openhab> bundle:list -s |grep http
279 | Active | 80 | 3.1.0.202103010326 | org.openhab.binding.http
292 | Waiting | 80 | 3.0.1 | org.openhab.binding.http

So it looks like there are “peaces” of the 3.0.1-Binding still there - maybe I have to remove it somehow?

I’d try bundle:uninstall 292 (more a guess then an advice).

I do clear the cache of OH3, now it looks like this:

openhab> bundle:list -s |grep http                                                                                   
147 | Active |  80 | 3.0.1                   | org.openhab.core.io.http
148 | Active |  80 | 3.0.1                   | org.openhab.core.io.http.auth
220 | Active |  80 | 4.1.42.Final            | io.netty.codec-http
277 | Active |  80 | 3.1.0.202103010326      | org.openhab.binding.http

Only the correct 3.1.0-http-Binding is there - but in the frontend still the 3.0.1 is shown.
And the error with the

HTTP protocol violation: Authentication ch
allenge without WWW-Authenticate header

is also still there…very strange.

Very strange, indeed!

I’d try:
uninstall/install the http binding from MainUI, if this doesn’t help
bundle:update for the two weird bundles, after that
:thinking:

Uninstall / install the http binding brings back the 3.0.1-Version in the konsole.
After that I make the update via konsole via

update org.openhab.binding.http https://ci.openhab.org/job/openHAB-Addons/lastSuccessfulBuild/artifact/bundles/org.openhab.binding.http/target/org.openhab.binding.http-3.1.0-SNAPSHOT.jar

And it’s still the 3.01 in the frontend…I have no idea, whats went wrong. -(

Maybe a little bit off-top in this thread: how can I update to the 3.1.0 milestone-build 2?
I have a normal debian-installation.
Before I wasting more time in searching ghosts…

Look at the Download page of the documentation

After the update to OH 3.1 M2 it works without a problem.
Thank you for your support.