Getting error messages in console

sorry for my silliy question, but my OpenHAB3 throws out following error messages since a couple of week

network, openhab-persistence-influxdb, openhab-binding-amazonechocontrol, openhab-transformation-jsonpath, openhab-binding-harmonyhub, openhab-binding-nuki, openhab-binding-mqtt, openhab-binding-netatmo, openhab-transformation-map, openhab-ui-basic, openhab-binding-yamahamusiccast, openhab-binding-lgwebos, openhab-binding-ntp, openhab-binding-http, openhab-binding-astro, openhab-binding-velux, openhab-binding-knx’: Error:
Error downloading mvn:org.eclipse.jetty/jetty-client/9.4.43.v20210629
Error downloading mvn:org.eclipse.jetty/jetty-io/9.4.43.v20210629
Error downloading mvn:org.eclipse.jetty/jetty-http/9.4.43.v20210629
Error downloading mvn:org.eclipse.jetty.websocket/websocket-client/9.4.43.v20210629
Error downloading mvn:org.eclipse.jetty/jetty-util/9.4.43.v20210629
Error downloading mvn:org.eclipse.jetty/jetty-proxy/9.4.43.v20210629
Error downloading mvn:org.eclipse.jetty.websocket/websocket-api/9.4.43.v20210629
Error downloading mvn:org.eclipse.jetty.websocket/websocket-common/9.4.43.v20210629

How can that be solved?

br Leo

This means that OH cannot download and install the configured add-ons.

First restart OH.

If that doesn’t clear it up, try Clear the Cache.

If that doesn’t work, check your network and firewall settings. Something is preventing OH from reaching the service where the add-ons are downloaded from on the Internet.

As a last step, you can download the add-ons.kar file that corresponds to your version of OH (release, milestone, snapshot) from Download openHAB | openHAB. Place that file into the addons folder (see the installation instructions page for your OS for where that folder is) and OH will get the add-ons from the kar file instead of the Internet. But remember when you upgrade OH you’ll have to download the kar file again.

According to @wborn in openHAB 3.3 Milestone discussion - #152 by wborn

Which OH3 version are you on ?

I am on 3.3
What i did is reboot several times but the messages come again.
Clean - cache - The system is not responsive after the reboot, need to restore from backup bit I fear that this brings back the zombies sleeping in my config.

I downloada the add-ons.kar file, placed it in addons folder and got the following message:

2022-10-06 17:31:53.905 [INFO ] [core.karaf.internal.FeatureInstaller] - Some .kar files are not installed yet. Delaying add-on installation by 15s.

And then the error messages appeared again.


Seems that it solved, no really idea how.
I stopped the service, cleaned the cache, started again, and again i didn’t come up (basic ui).
After a reboot i saw 14 apt updates, did an apt-get upgrade and update.
started the console and did a feature:refresh and for the first time not jetty errors appeared.
Now it is up and running and the erros have disappeared.

Thanks for the help you provided.


This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.