Go-E Charger Wallbox Binding

Hi guys,
I also have the problem with “expected an int” with OH3.3.
Can someone provide a JAR-file with the fix?
I think the binding for OH3.3 does not support it…

Thank you very much!

I have a go-e gemini flex that I can control with the binding. I am using OH 4.1.1 with the go-e binding 4.1.1 on a raspberry pi.
I can set the current values, phases, read temperature etc. . The only thing that I cannot do is starting the charging. I tried to use forceState but this isn’t working. I can see allowCharge going from off to on when I start the charging via the app. The forceState then is going from 1 to 0. When I switch charging off in the app allowCharging goes to off and forceState goes to 1. In neither state of allowCharging I can set the forceState value via OpenHab (slider).
Does anyone has a solution for this problem?

You need to send a command to Transaction Item, e.g. 0.

ForceState ist used to Stop, continue or “Auto” the Connection

My GO-E Homefix had some temperature-related problems (oxidized Pin of one plug, overheated pin-case smoldered). I send the box to GO-E, they offered to send me a new Gemini for an interesting price.

In https://github.com/openhab/openhab-addons/issues/15075 a problem with decimal instead of integer values is stated. I didn’t have this problem with my old box although it had the newest firmware version.

I had to switch from API version 1.0 to 2.0. This solved the integer / decimal problem.