Google Assistant answer me with Setpoint and not with Ambient Temperature

Hello, I’ve configured my thermostat with this items :

Group SST “Termostato Casa” { ga=“Thermostat” [ useFahrenheit=false ] }
Number termostatosoggiorno_temperatura “Temperatura Soggiorno [%.1f °C]” (SST) {channel=“souliss:t52:71:8-5:value”, ga=“thermostatTemperatureAmbient” }
Number termostatosoggiorno_umidita “Umidità Soggiorno [%.1f %%]” (SST) {channel=“souliss:t53:71:8-7:value”, ga=“thermostatHumidityAmbient” }
Number termostatosoggiorno_setpoint “Regola Set Point [%.1f °c]” (SST) {autoupdate=“false”, channel=“souliss:t31:71:8-0:setpoint”, ga=“thermostatTemperatureSetpoint” }
Switch termostatosoggiorno_setasmeasured “Set temp. attuale” (SST) {channel=“souliss:t31:71:8-0:setAsMeasured”}
String termostatosoggiorno_modo “Modo” (SST) {autoupdate=“false”, channel=“souliss:t31:71:8-0:mode”, ga=“thermostatMode”}
Switch termostatosoggiorno_power “Termostato” (SST) {channel=“souliss:t31:71:8-0:system”}

And it is correctly shown in basic UI. And work.

When i ask for temperature GA respond me with setpoint. (Termostato casa è impostato a 19°)
When i ask for humidity GA respond me correctly… !!!
Tried to ask temperatura soggiorno, temperatura di casa, etc.etc.

What can i try to have ambient temperature as answer and not setpoint???


Have you tried asking GA the same question, but with different words?

As in, phrase your question differently?

What does the thermostat widget show in Google Home / Google Assistant?

Are the values correct there?

For example, the above is correct.

Where current temperature is 13°c

Yes,! But it answer me with "termostato casa is 21,5 degree) and not “temperature is 26,4 degree”…


I’m getting these results

But I can’t work out how to ask what the current setpoint is

It is so strange… Please can you post me your items?

Sure, I use items that are shown in this generic template for Velbus assets.

I have the same issue.

It seems to be linked to “modes” .When modes are set/working everything is fine .
For some reason they “dissapear” in some rooms. i can set modes manually ,and it works for a few days.

So some rooms work and some dont.

1 Like

Can you explain better? If you set to HEAT for example it works ?

yes, not matter which “mode” i set ,it works.

cooling ,heating and so all works.

Setting it in Google APP that is.

Actually mode is missing in basic UI when not working. but but setpoint and ambient temp is shown.