Google Assistant Thermostat Setpoint not working

Hi Guys! I’m not able to set correctly a Thermostat in openHAB 2.5 with Google Assistant. I’ve followed instruction at but still failing.

I cannot adjunt Basement Setpoint, its grayed out.

My final plant is to make it work with Tasmota IR HVAC (I’ve already make it working). But now trying at standalone and still failing. Below my items and sitemap file.
Any ideas of what I’m doing wrong o need to change? Please note that I’ve used basic example from openHAB page but need to modify HK_Basement_Mode from Number to String at item file and need to MAP modes at Sitemap

Any help would be appreciated!!

items file

Group g_HK_Basement_TSTAT "Basement Thermostat" { ga="Thermostat" }
String HK_Basement_Mode "Basement Heating/Cooling Mode" (g_HK_Basement_TSTAT) { ga="thermostatMode"[modes="off=OFF:WINDOW_OPEN,heat=COMFORT:BOOST,eco=ECO,on=ON,auto"]}

Number HK_Basement_Setpoint "Basement Setpoint" (g_HK_Basement_TSTAT) { ga="thermostatTemperatureSetpoint" }
Number HK_Basement_Temp "Basement Temperature" (g_HK_Basement_TSTAT) { channel="mqtt:topic:localbroker:multisensor-living:Temperatura", ga="thermostatTemperatureAmbient" }
Number HK_Basement_Humid "Basement Humidity" (g_HK_Basement_TSTAT) { channel="mqtt:topic:localbroker:multisensor-living:Temperatura", ga="thermostatHumidityAmbient" }

Sitemap File

Frame label="Sensores" {
Text item=Temperatura_Test label="Temperatura Test" icon="temperature"
Text item=Temperatura_DS18B20_Test label="Temperatura Test DS18b20"
Text item=Humedad_Test label="Humedad Test" icon="humidity"
Text item=Presion_Test label="Presion Test" icon="pressure"
Selection item=HK_Basement_Mode label=HK_Basement_Mode mappings=[ off='OFF',heat='HEAT',cool='COOL',on='ON' ]
Text item=HK_Basement_Setpoint label=HK_Basement_Setpoint }

Hi @martinmatias, please use code fences (the </> button on the formatting bar) so that your code is easier to read.

That being said, here’s your problem from what I can see.

Your sitemap item is Text, not Setpoint.

Hey Russ!! Excelent, that solved my problem, THANKS!.
I’d like to note that it was not described into the tutorial. I’d thought that Google Assistant consider only item files but note sitemap. I think that google-assistant explanation should include sitemap description needed for GA works.

I’ve also corrected the quotes into my post as sugested.

You are correct, Google Assistant and sitemaps have nothing to do with each other.

Your thermostat items are just that: items. You’ve tagged them so that they can be discovered by GA, same as you can do with a regular light switch. That enables you to use GA to control them, either through voice or the Google Home app.

Your sitemap is a separate user interface, and all you’re doing is adding items to it according to the sitemap documentation. When you update your thermostat via Google, it updates the item. When you access the sitemap, it retrieves the item state.

So, your problem wasn’t with Google Assistant at all. It was just with your sitemap. :wink:

Ok, but I wasnt able to set temperature from Google Home. Since I’ve updated Sitemap I was able to set temperature from Google Home. That why I’m saying that tehre is a relationship betwen GA and Sitemap.
Make sense?

No, that’s coincidental, not causal. You could have no sitemap at all and Google Home would still work if the items are defined properly.

When you said this, I thought you were referring to your sitemap (since the item wasn’t correctly defined). If you’re talking about it being “grayed out” in the Google Home app, then the most likely reason I can think of is that the thermostat mode was set to “Off”, in which case you can’t change the setpoint.


As far as I remember from another simular thread a week old, the modes for the thermostat isnt working.
I think we´re waiting for @MARZIMA to deploy the changes to the integration.

I just tried adding modes out of curiousity. This works to customize which modes show up in the Google Home app:


But as soon as you add conversions, they break in Google Assistant.


So, now it’s strange that @martinmatias’s thermostat works in GA, since it doesn’t sound like he changed the modes at all.

Sure is strange… I have no idea how he managed that… It shouldnt be working, unless Marzima har deployed the changes lately.

But it is deployed. :thinking:

Was it deployed at the time he original wrote it?

Just wanted to put it up here as well that the mode mapping is probably not working still.
posted some screenshots here -

It works, you just have the modes attached to the wrong item. :wink:

You’re not the first person to think that the GA modes would be attached to the string item with “ga=ThermostatMode”. They actually belong with the group item, but it’s an easy thing to miss when you’re figuring this stuff out.

Yeah, thanks a ton for pointing that out. I just finished the alexa mapping so overlooked that it needs to be at group level :wink:

1 Like