Google Home Blinds mismatch

Tags: #<Tag:0x00007faee01e0e60> #<Tag:0x00007faee01e0d20>

Ok so I finally switched in Google Home my Fibaro based blinds from being lights to the Blind type. So I no longer get the that acknowledgment “setting two light brightness to 40%”

And while it works there is very strange mismatch.
Open and close commands work as expected but the percentage settings are reverted to the command that I was normally issuing to the blind controllers
100% is open
0 is closed
If I task google to open the blind to 30% it will set it at 70%

Surprisingly it is not relevant if I say “close blind to 30%” or “open to 30%” it will set it to 70% in OH.

open blind to 80% will set it to 20%.

@MARZIMA is that fixable?

Also it is very annoying that you can’t set the blind to x % as that seems to be reserved for the dimmer lights.

all the best Maciej

In openHAB a rollershutter is 100% closed or 0% closed (aka open). While some manufacturers think the other way would be correct, simply think of the function in comparison to a dimmer. A light will brighten to 100%. If it’s already bright, a light won’t make it dark. The blind is working the other way, so it’s making 100% dark. if it’s already dark, it can’t make it brighter, so 100% is definitely the lower position :slight_smile:

As there are some systems which use it the other way, there is sometimes a parameter to change direction (and therefor percentage). afaik this should be true for fibaro.

The Fibaro blind control has indeed switches both for inverting the blind control and inverting the percentage values.
But that does not solve the problem.
Inverting the direction screws us open/close commands. They are inverted and saying close the blind - opens it . So that is a dead end.
They switch for inverting % does work by inverting the values that now position 30% is 30% of the surface is obscured. But with that change Google Home still sets position to 70 when you say “close/open blinds to 30%” No switch in controler will fix that.
That is clearly wrong!

Hmm… then I’m out of ideas…