Google Home connection issues

New install of OH 3.2 on a Pi4

I can’t connect in the Google Home app.

Here’s the steps I’ve followed

Added the Openhab Cloud Connector
noted the 2 keys
created new account on using same email id as the one used within the house on the Google devices
added basic Items file with this item: ‘Switch fire { ga=“Fireplace” }’
On my Android phone i tried to add the Openhab app
logged in to myopenhab when requested
Clicked ‘allow’ when asked to approve 0auth2
Then it appears to do something, but, it just takes me back to the beginning of the adding Openhab service. shows Google Assistant added
Google Account page for applications security does not show Openhab as approved as a 3rd party app. This is where i think this is failing…

I’ve double checked the account secret/uuid, both appear correct

Any ideas please??
Thanks, Colin


1 Like

I’ve also tried removing and re-adding another Google Home app, which worked, so my problem seems specific to the Openhab service

Tags were deprecated two years ago and removed last year.

so is this page: Google Assistant | openHAB no longer correct??

Whoops, sorry. I confused myself.

I got the metadata and tags mixed up (because I haven’t looked at them in awhile and that’s typically the problem).

Can you show me your actual item definition, pasted directly from your text file? The other thing that happens sometime is that smart quotes gets inserted and have to be edited out. Your earlier example has smart quotes.

Switch fire { ga=“Fireplace” }

And you may need to replace them with regular quotes:

Switch fire { ga="Fireplace" }

I believe that you won’t be able to add OH to Google Assistant if there are no devices tagged for GA.

I’ve used the item below, the only item, and its still not working…

Switch DiningBureauLamp_power “Bureau TP Link Lamp Power” (gGFDiningLights) { ga=“Switch”, channel=“tplinksmarthome:lb130:CAC04C:switch” }

Can you confirm that the item definition does not have the smart quotes, per my message above? I’m guessing that’s not the case, but just want to be sure.

normal quotes used, double checked :slight_smile:

I didn’t even know Smart Quotes were a thing lol

I can now see: shows Google Assistant added
Google Account page for applications security also shows Openhab as approved as a 3rd party app.
That’s progress!
When i try and add Openhab in the Home app it still does not appear to add

Yeah, smart quotes have tripped up a lot of people in the past. On that note, code snippets are easier to read if you put them in code fences using the </> button.

Okay, so if you can access your system through myopenHAB, then the secret/UUID are fine.

Question: do any of your items not have labels? I realize that your earlier example did not:

Switch fire { ga="Fireplace" }

I vaguely recall that if any devices at all are missing labels, then GA won’t work (even if those devices aren’t exposed to GA).

i have a test items file that im using when trying to get GA working, my other tiems files are renamed during my testing.
in my test.items file i have a single item:

Switch colin "Colin "{ ga="Switch" }

If that’s the case, I really don’t know what’s stumping you here. Best I can suggest is to go back to square one by removing OH from Google and Google from myopenhab, then trying to link them again.

1 Like

i’ll give that a go, thanks for your support so far :slight_smile:

More than happy to help. Keep me posted!

1 Like

My actions tonight:

  1. unlink Openhab from Google
  2. unlink Google from Openhab apps
  3. rebooted Pi
  4. tried relinking from Google Home app

Both Openhab and Google Account management page are showing linkage, however within the Google Home app on my phone still shows Openhab not linked.


Russ, would you be able to give me a working item line from your config please?

Actually, let’s try an alternative. Instead of text files, try creating an item in MainUI and add the Google Assistant metadata. If that doesn’t work, then the problem is somewhere else.

Same result

Okay, if it’s not working from MainUI then we’re barking up the wrong tree.

I hate having this feeling that it’s most likely something stupidly simple that we just aren’t seeing.