Google Home Integration


also it is a little bit difficult to prevent Google Home to switch off all items discovered through the Hue bridge. I for example use the following items with Alexa:

  • Siren
  • Rollershutter
  • Lights
  • Doors
  • Sprinkler System

The problem with the command “turn the lights on” all of these devices will be enabled. Any idea to prevent this behaviour?
I tried to create specific rooms like the light room with all lights inside but Google Home turns all the time all discovered devices on and off :frowning: Also I still miss the dimming funtion. Why this is not working here but with Alexa?

best regards René

I’ve also had issues where GH could not find the bridge and was getting “Couldn’t find Hue Bridge” no matter what i tried. For whatever reason I also could not get GH working with my ecobee thru “wink” as it was saying “Device is not setup”.

I’ve then tried to do factory reset on GH (15s holding of mute button) and when it came back up all devices got added perfectly and now both Openhab (hue emu) and ecobee (thru wink) are working without any issues.

Hopefully this works for someone else as well.

I’ve tried resetting GH as well, but i still cant connect to Philips Heu Emulation.

How do you enter the rollershutter into HueEmulator?

I am also having trouble with Dim the light and the Brighten the light. Is anyone using these commands with success?

Same here, also not working for me. I asked somewhere else as well but still haven’t found anyone for which it’s working.

Please help. I have Google Home Hue Emulator running and paired. But I don’t see my Z-wave devices in Google Home app. http://openhabian/api/discover.xml displays: {“lights”:{}}
Reading the README it says. Device tagging. How do I do it?

Hi i upgraded to 2.20 and followed everything but even though my G home app recognizes the hue bridge emulation, it ask me to press the link button on the bridge and eventually times out. Please help me and I greatly appreciate it.
PS. I have paring enabled and i changed it to port 80 in paper ui but is there a way i can manually press the emulation’s button or something , Im pretty new to all of this. thanks in advance Amit.

did anybody find a way to avoid this?
same happens to me

So, I’m also having the same issue as everyone else with no devices found during the scan. Everything is set up as I’ve read elsewhere.

Have checked:

  1. Port 80 is open
  2. Have output from api/discover.xml as below

I’m attempting from Australia, not sure if that matters. Really wondering if Philips have blocked Openhab at the discovery stage.

{"lights":{"Spot_Light1":{"state":{"on":true,"bri":255,"hue":0,"sat":0,"xy":[0.0,0.0],"ct":500,"alert":"none","effect":"none","colormode":"ct","reachable":true},"type":"Dimmable Light","name":"On Off","modelid":"LWB004","uniqueid":"Spot_Light1","manufacturername":"openHAB","swversion":"66009461","pointsymbol":{"1":"none","2":"none","3":"none","4":"none","5":"none","6":"none","7":"none","8":"none"}},"Spot_Light2":{"state":{"on":true,"bri":255,"hue":0,"sat":0,"xy":[0.0,0.0],"ct":500,"alert":"none","effect":"none","colormode":"ct","reachable":true},"type":"Dimmable Light","name":"Brightness","modelid":"LWB004","uniqueid":"Spot_Light2","manufacturername":"openHAB","swversion":"66009461","pointsymbol":{"1":"none","2":"none","3":"none","4":"none","5":"none","6":"none","7":"none","8":"none"}}}}

Port 80 is open, but to speak with openhab you have to direct port 80 to 8080.
I’m sure there are tutorials in this thread on how to do that.

Sorry wasn’t clear, I’ve port forwarded via NGINX, and I can access OH via port 80.

Must I leave the stable version to get this to work?


I’m having problems getting this to be discovered.

I have Hue Emulation settings defined as:

  • Pairing Enabled
  • Web Discovery Port: 80
  • Discovery Address defined as my rpi’s ip (

Within the rPi i have iptable configured to redirect port 80 to 8080:

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 8080

When attempting to discover the Hue (emulator) bridge within Google Home, the discovery fails. I have downloaded the Hue App from google play and attempted to discover the bridge as well – no luck.

The address i’m being sent to when attempting to add/discover the Hue Bridge within Google Home is

Has anyone had any luck getting this to work… any suggestions/ideas i should try?

This is not working any more

1 Like

Hello @Kai,
apparently this solution doens’t work anymore. Do think any other workaround may be possible?

OK, sorry!
I should have searched a bit first.
Obviously some guys are already investigating if they find another workaround.

I don’t know about other workarounds. But as mentioned in my initial post, the easiest solution will be the official Google Action, once it is publicly available.


You could try the IFTTT approach. Its working ok.

1 Like

You do not want to run your server processes as root. Ever.