Google Home & openHAB connection How-To

Hi everybody. Do you have any idea why I cannot connect my Google Home to openHAB? I have exposed the items, I login to myopenhab (through the assistant or the google home app), I authorise the connection and when I return to the app, it tells me that it failed and I need to try again later.

I have tried using an iPhone and an Android phone. I have also tried leaving only one item in openHAB. No luck…

Can you post your items file? Most likely, either the tags are incorrectly typed/spaced, or you have tags that aren’t supported yet (and the Action currently fails without warning when that is the case).

I’m posting the (extremely) simple items file that I created for testing:

Switch Living_Room_RetroLamps "Retro Lamps" (none) [ "Switchable" ]

(the test sitemap is just as simple, btw)

Also, I removed my hue add-on (just in case), so now I have a very lonely openHAB with just one thing. Still doesn’t work.

Thanks in advance! :slight_smile:

edit: after removing the hue add-on and ALL leftovers, it worked! I’ll try gradually adding things now.

Ah, was it the hue emulation add on, or the binding? I didn’t seem to need to remove either of those, but then I never fully configured/used my Hue emulation add on (once I saw the official action was in progress).

It was the hue binding. I never installed the hue emulation add-on. I tried adding it back (once I made sure that all my items are playing nicely - I must have said “hey google, sync my devices” about 100 times :stuck_out_tongue:) and so far, it seems to be working. I’ll let you know If something goes wrong. Thanks a lot! :smile:

Hi Bartus,

EDIT: I tried it a third time, then it worked :wink: Below you can find the original issue.

EDIT2: I think I know what the problem was. In PaperUI I exposed the items for “apps” (like Google) too late.

in another thread you told me that support for German language will follow, but I was very surprised to see in my google home app (on my smartphone) that openhab is listed as an available plugin.

So I gave it a try without success:

As described in your video I added the [ “Switchable” ] tag to one of my items (a Sonoff tasmota mqtt switch).
I connected my local openhab with myopenhab cloud and can successfully use the habdroid app.
Then I added openhab as a “device” in google home app on my smartphone, as described in your video.

BUT even though lists “Google” as connected application (see screenshot below), I don’t see any devices on my smartphone (google home app). So I added openhab as “device” again on the smartphone and now I see Google twice listed in but still no devices on the smartphone :-/

Any idea what’s wrong? Does this mean that German is STILL not supported?

@StefanH I am having the same issue? Did you ever fix it? If you did how did you fix?

Well, it “just” started working once I told my google assistant to synchronize my devices. then I said something like “turn on xxx” and they appeared in the openhab cloud menu. I am not sure at all but I have the feeling it just takes some time to sync.

Ok thanks! Very strange. I have waited multiple days and had an issue.

I have the same problem but in french…

This is strAnge that only a few people have the issie. I am installing openha b on Ubuntu now to try vs openhabian.

No luck using Ubuntu as the problem is in the openHAB cloud —. Google side it appears.

Maybe one of these days someone will answer with useful knowledge on how to debug, until then

Same problem here, in Italy…

Same issue. Still, after many months, Surely people are not giving up on this?
I feel its a problem with my .items file:
Switch Coffee_Machine [ “Switchable” ] {mqtt=">[broker:/cmnd/sonoff-gpo3/POWER:command:ON:ON],>[broker:/cmnd/sonoff-gpo3/POWER:command:OFF:OFF]"} also says Google Application was authorized.
Google home app says Accounts now linked but then pops up “Something went wrong. Try Again”

I would really like to get this working. Please help.

Nope, works fine here without issues.
How about trying with just a test switch?

Switch TestSwitch "Test Switch" [ "Switchable" ]

Make sure to ask google to sync your devices: “OK Google, sync my devices”, which should result in a reply like “Ok, syncing your devices for OpenHAB”.

Then add the switch to Habpanel or BasicUI to monitor if you can switch the test switch

When I was facing a similar problem, I removed all other items from my file and only tried with the problematic one. Once you get it working, start adding more items (that are Google Home or Home Kit related).

Also, make sure your quotes are simple " and nothing fancy like “ ”, which seems to be the case with your code.

FIXED. Yay. Thanks for your advice RolfV. It works now and here is my string:
Switch Deck_Lights “Deck Lights” [ “Switchable” ] {mqtt=">[broker:/cmnd/sonoff-gpo4/POWER:command:ON:ON],>[broker:/cmnd/sonoff-gpo4/POWER:command:OFF:OFF]"}

Hello everybody,

I’m new on OpenHAB and trying to integrate KNX and Google Assistant.
Lighting and switches are working, but for thermostat, I have some problems.
I can read the ambient temperature, but mode, and set point as well is not operating.
here is items code:

Group    Office               "Office"         <office>        (Home)                   ["Room"]
Group    Library              "Library"        <office>        (Home)                   ["Room"]

Switch        demoSwitch         "Light [%s]"               <light>   (Library)  ["Switchable"]     { channel="knx:device:bridge:minbox:demoSwitch" }
Dimmer        demoDimmer         "Dimmer [%d %%]"           <light>    (Office)   ["Lighting"]   { channel="knx:device:bridge:dimbox:demoDimmer" }

Group g_office_thermostat "Thermostat" <climate> (Office) ["Thermostat"] 
    Number        cTemperature    "Temperature [%.1f °C]"    <temperature>  (g_office_thermostat) ["CurrentTemperature"]  { channel="knx:device:bridge:DMD:cTemperature" }
    Number        setp    "Set Point [%.1f °C]"  <temperature>  (g_office_thermostat) ["TargetTemperature"]  { channel="knx:device:bridge:DMD:setp" }
    Number        fanspeed    "Fan Speed [%.0f]"  <fan>  (g_office_thermostat)   { channel="knx:device:bridge:DMD:fanspeed" }
    Switch        mode         "Mode [%s]"   <heating>    (g_office_thermostat)   ["homekit:HeatingCoolingMode"]    { channel="knx:device:bridge:DMD:mode" }
    Switch        power         "Power [%s]"  <switch>   (g_office_thermostat) ["Switchable"]  { channel="knx:device:bridge:DMD:power" }

and here is things code:

Bridge knx:ip:bridge [ 
] {
    Thing device minbox [
    ] {
        Type switch        : demoSwitch        "Light"       [ ga="0/0/6+<0/0/7" ]
    Thing device dimbox [
    ] {
        Type dimmer        : demoDimmer        "Dimmer"      [ switch="0/0/1", position="0/0/3+<0/0/5", increaseDecrease="0/0/2" ]
     Thing device DMD [
    ] {
        Type switch        : power        "switch"       [ ga="0/1/7+<0/1/8" ]
        Type switch        : mode        "heating"       [ ga="0/1/3" ]
        Type number        : cTemperature   "Temperature" [ ga="9.001:<0/1/4" ]
        Type number        : setp   "Temperature" [ ga="9.001:0/1/5+<0/1/6" ]
        Type number        : fanspeed   "fan" [ ga="5.010:<0/1/0" ]

your helps appreciated.

Can you control it manually via the PaperUI Control or your sitemap?

yes, it’s working fine thru sitemap, paper-ui and Android app (openhab app)
as I understand, [“homekit:HeatingCoolingMode”] will change the mode by string, but in KNX mode will control by 1 bit object. 0 = cooling and 1 = heating mode and for switching on and off the thermostat, there is another 1 bit data point.
I guess I have to find a way to transform [“homekit:HeatingCoolingMode”] from string to number as explained.