Grafana not showing in HABpanel - error in dev console

Folks,

I have HABpanel working well on the RPi.
I have Grafana installed and working well in a freenas jail.

Both work well without any problems. However, when trying to show grafana in HABpanel frame I get errors in the console.

The panel keeps refrshing but ultimately stays blank.

Options?

thanks
C

no one? :frowning_face:

Does anyone run Grafana separate to their OH RPi?

C

I do :grinning:

I added a frame in habpanel and inserted this url:
http://192.168.1.10:3003/dashboard/db/openhab-dashboard?panelId=7&fullscreen

had to tweak the config of grafana to disable the logon for these panels.

Nudda. Yours is the same as mine…
I’ve got http://10.10.50.116/dashboard-solo/db/shed?orgId=1&panelId=3&fullscreen to no avail.

I can open that exact url in incognito browser and it’s fine.

Really frustrating me. No cool graphs :frowning:

make sure the url is working in a frame. you can test it with a html file.
As this works, so does habpanel.

<html>
<frameset>
  <frame src="http://10.10.50.116/dashboard-solo/db/shed?orgId=1&panelId=3&fullscreen">
</frameset>
</html>

1 Like

Did you try this (first google search result):

yup, tried all those :frowning:

In the frame I get the same thing - it flickers, sometimes it manages to render the title before reload.
I’ve tried this with and without cookies and in chrome, FF, Edge and IE. :slight_smile:

None of them work.

Hi, have you got it run in the meantime?
I am facing the same problem here… no solution so far :disappointed_relieved:

Thanks!

Don’t know if you already solved it, but i faced the same problem. After some searching around found this in de grafana docs about the update to 6.2:

I think more people will face this problem when they update to a newer version of grafana.
to fix the problem:

  • open /etc/grafana/grafana.ini
  • add allow_embedding=true under [security]
  • restart grafana.service
  • F5 habpanel -> Fixed! (hopefully)
7 Likes

Unfortunately it does not work, even making allow_embedding=true
Using Grafana 6.2.2 with HABPanel. None of the graphs are being shown.
Link in the browser is displayed perfectly. In HABPanel does not work.
No nice graphs indeed… :frowning:

I create simply html file with following content:

<html>
	<iframe src="http://192.168.1.114:3000/d-solo/7pNtW1kRk/temperature?orgId=1&refresh=30s&panelId=2" width="450" height="200" frameborder="0"></iframe>
</html>

but the browser tells:
192.168.1.114 connection denied.
2019-06-16_17h47_23

browser tells me:

Refused to display ‘http://192.168.1.114:3000/login’ in a frame because it set ‘X-Frame-Options’ to ‘deny’.

I’m having the same problem as well, tried the fix of @FutureCow but that didn’t fixed the issue in my case, does anybody has another fix that we could try?

Ah, this was my bad, I forgot to remove the ; (unmention), it is working now :slight_smile:

1 Like

Do I understand @Stehof you were able to resolve the problem?
I followed the @FutureCow fix but was not successful.
Any support from others?

I think you have the same problem, grafana is blocking iframe.
You put the allow_embedding=true under security in the ini file?
Have you installed grafana with a package? You edit the right ini file? Restarted grafana? Check some logs of grafana, you might find some more info.

Yea I was able to solve it, I forgot to remove the ; symbol at the front of the line

allow_embedding=true

Did you remove the symbol as well?

1 Like

@Stehof
indeed! Works for me as well now. Question for 100 Points. Who the heck comments with ; the line? All files I worked so far under linux were commented by #. This made me confused.


# set to true if you want to allow browsers to render Grafana in a <frame>, <iframe>, <embed> or <object>. $
#;allow_embedding = false --> orginal line
allow_embedding = true

Result (nice grafana chart included :slight_smile: ):

3 Likes

Another hint from my side:
please make sure your browser is not blocking scripts. It took me also a while to remove this blocker…
Thanks everybody for support!

@wiewior great that it’s working for you as well, indeed pretty confusing that all the script comment there lines with # and in grafana suddenly uses a ;

Thanks, this post helped a lot. But i as well needed to enable anonymous acces in grafana.ini to get it to work.

# enable anonymous access
enabled = true
2 Likes

awesome ! Thank you guys… I had exactly the same problem and your suggestions solved it