HABmin, zwave things, items, and dashboards

Nope it won’t let me remove it. Same server error as trying to change parameters.

Interesting. Did you try using PaperUI too?

Yes both had in and paper. Habmin just shows it as being changed then reverts if you move to another device and back. Paper pops up an error message, barely long enough to catch.

1 Like

Unfortunately I don’t know what the error is - it’s not coming from the binding - it’s somewhere in ESH. Of course that’s not to say that something the binding has set in the configuration hasn’t caused it,although the normalisation is meant to solve that. In any case, I’ve no idea from these messages what the issue is - sorry.

How does one tell when snapshot changes have moved to stable?

i.e. It looks like stable was built a few hours ago. If I get that now is the NZW39 change available or is that still only in snapshot? (to clarify, referring to openhabian in this question)

The stable and beta releases are announced in the forum under the Announcements category. Ths is a good category to set to Watching (top right corner). Snapshots of openHAB-Distribution and opeHAB2-Bundles are usually built nightly. The zwave binding also has a development branch, that Chris distributes builds from about weekly in this thread (link in the first post). If you’re willing and able, you can build any of these yourself too.

The NZW39 changes to the device database should be in the snapshot build of the zwave binding (included in the OH snapshot build) and the dev binding. Since you are currently running an OH snapshot, you can uninstall the zwave binding and reinstall to get the latest version of the zwave binding. Or you could update to the latest OH snapshot.

So, I burned another SD card with openhabian, istalled it, waited an hour, went into it added the zwave binding, then added the NZW39’s. (Note: this was the image I used for my first experiment, I didn’t download a new image.)

This of course did not have the new definitions for the NZW39, so I could not attempt to change parameters.

I removed the devices, and the binding. I then used openhabian-config to switch to the snapshot. Added the binding and the things. Attempted to change parameters, the log showed a conformation that the change was made.

But, when I went back to device to check the properties, there were no properties.

Sounds like progress! :+1:

Not quite sure what you mean. Associations in Habmin? Screenshot?

This is what the properties looked like before I switched to the snapshot and what they look like after I changed a property:

After I switched to the snapshot there were things like enable/disable invert switch, 4 entries for parameter 6, etc.

It looks like you are using PaperUI. It is best to configure zwave Things only in Habmin because it will send the specific change you made. PaperUI will reconfigure all the settings when a single change is made. The only time you should need to use PaperUI for zwave device configuration is to view associations. These properties are read from the device, so you must mean that you changed a configuration parameter or association. I’d check Habmin. Under Attributes, you should see the same info as in your screenshot. Hopefully it is not blank.

Arrrrrrgh…too many interfaces. :face_with_raised_eyebrow:

Why would a given interface change what it displayed?

I hear your frustration! You may see the same thing in Habmin. Maybe the device was restarting itself and then went offline, so no properties to show? A browser refresh might help? PaperUI can be a little glitchy… another reason to use Habmin! :slight_smile:

Well, I added habmin.

Removed all the zwave devices, re-added them. But habmin won’t finish configuring the zwave controller, so the log just says the comm isn’t configured.

I’m done for today, too frustrated and have places to be, so I need to get cleaned up and get dinner.

Maybe tomorrow. :frowning:

Oh, and Thanks for the help!

How? Are you excluding them or just deleting their Things? And why? :wink: There should really be no need to delete them at this point.

If you’re using an Aeon Labs zstick and pulled it to exclude the devices, then it probably came up on another port. Restart the Pi and the controller should come up. Either shutdown OH before pulling the controller or use OH for doing the exclusions.

You are very welcome!

Well, new day new frustration.

I figured, let’s start from a clean slate and see what happens. So, I did the following:

  • unplugged Zstick
  • used ZStick to exclude all devices
  • factory reset ZStick
  • made fresh SD
  • boot
  • wait
  • login via putty
  • change default password
  • switch snapshot
  • reboot

Then, I added habmin and the zwave binding.

Used Zwave binding to find the zstick and used the discover button to find the 2 NZW39’s.

It appears, I have control over parameters of the NZW39’s.

This is progress!

BUT, now when I add the Aeotec Micro Switch (which always worked fine before) it creates a linked item which doesn’t appear to exist, won’t let me delete it. It will allow me to add a new item, both shown below in habmin:

What do you see in Items? What you see in that screenshot are Links and the Items associated to them. Deleting a Link does not delete the Item. Do you have Simple Mode turned on? I thought it was off by default.

Yeah, there was an item that had a duplicate name, when I deleted that the blank link shown above in the thing went away.

I didn’t change Simply mode…and now I can’t figure out where in the ui’s I found it. Sigh.

But, now I’m back to nearly where I was a few days back…

It appears the two NZW39 are recognized differently. In HABPanel the widget for one responds to local control and the other doesn’t. One has lifeline set to the controller and assoc group set the controller, it’s widget responds to local. The other has no lifeline and won’t update group 3 to the controller (or anything else).

Update, it just allowed to change the lifeline and group 3, now it works…I swear it didn’t a few minutes ago. :hushed:

This just won’t go away…

The configuration I change, for example, disable invert switch or the associated channel don’t seem to be persistent after a shutdown/restart of the pi.

Should OH be shutdown first so the data actually gets saved?

On another note, it also appears the snapshot definitions of the NZW39 aren’t quite right…or again I’m off in the woods.

When I select the NZW39 dimmer item in the new rules engine, it only has the options On, Off, Down and Close.

In hapanel though, if I add a slider widget and select the the NZW39 item it dims just fine.