HABPanel not working after moving to 2.5.0 Snapshot

Tags: #<Tag:0x00007f386f8ad668>

After moving to the latest snapshot (#1545), I cannot access HABPanel in my installation. All other user interfaces (Paper, Basic) and all bindings work fine. I did clear the cache and restarted openHAB. The console shows that HABPanel is active:

271 │ Active   │  80 │ 2.5.0.201903021856    │ HABPanel user interface

Did I miss any relevant change that happened from 2.4 to 2.5?

Nothing I’m aware of. What error do you get in the browser when you try to go to it?

What errors do you see in the logs when you try to go to it?

When I try to go to HABPanel in the browser, I get “HTTP ERROR 404 - NOT FOUND”.
I uninstalled HABPanel via PAPER UI und re-installed it.

It shows up in PAPER UI:

but not in my browser:

In the log I see following error message after installing the binding:

2019-03-08 19:10:20.119 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-ui-habpanel': Error restarting bundles:
Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.openhab.core.io.rest.sse.

No clue what this means. Any idea what I can do to get HABPanel up and running again?

What is means is HABpanel is not successfully installing.

Try Clear the Cache and reinstall HABpanel and see if the error goes away. If not we need to look into it some more.

Just restart openHAB and the exception probably no longer occurs.
It happens sometimes starting openHAB for the first time after an upgrade or initial installation.
See also openhab/openhab-core#597 and eclipse/smarthome#6682.

Reinstalled HABPanel after clearing the cache. Restarted openHAB and the error went away:

2019-03-08 20:39:12.413 [thome.event.ExtensionEvent] - Extension 'ui-habpanel' has been installed.

However, HABPanel still not showing up in the browser, nor does it appear in PAPER UI under CONFIGURATION -> SERVICES -> UI.

Any further ideas?

Hey,

now I have the same issue.

How did you solved this?

Thx Jan

I could not solve it so far. Therefore, and for other instability issues with 2.5, I moved back to 2.4 stable. Will give it another try soon.

Awesome!
:joy:

Exact what I did to solve the issue :partying_face:

Ok, let’s wait for the stable version then.