HABpanel referenced error prevents from installing new bindings

I was trying to add new bindings (tried like 10 different ones), and was not successful using PaperUI. I tried same using HABmin. Still unsuccessful, but the following error got displayed which references HABpanel. Not sure what it exactly means.

Any ideas what the issue is?

I also have this problem. I get the following text in the log when I try to install the regex transformation extension through PaperUI:

13:32:43.186 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-transformation-regex’: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-ui-habpanel; type=karaf.feature; version="[2.0.0.SNAPSHOT,2.0.0.SNAPSHOT]"; filter:="(&(osgi.identity=openhab-ui-habpanel)(type=karaf.feature)(version>=2.0.0.SNAPSHOT)(version<=2.0.0.SNAPSHOT))"

13:32:53.217 [ERROR] [st.core.extensions.ExtensionResource] - Exception while installing extension: org.osgi.service.resolver.ResolutionException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-ui-habpanel; type=karaf.feature; version="[2.0.0.SNAPSHOT,2.0.0.SNAPSHOT]"; filter:="(&(osgi.identity=openhab-ui-habpanel)(type=karaf.feature)(version>=2.0.0.SNAPSHOT)(version<=2.0.0.SNAPSHOT))"

My openhab version as shown when logged in to the Karaf console: 2.0.0-SNAPSHOT Build #558

I have the same problem. I think i started after installation of Habpanel.

@ysc

Any ideas how habpanel can cause this issue? Thank you!

I solved it by updating OH2 to the latest snapshot. Habpanel is now part of the non-experimental UI’s.

I did uninstall Habpanel before updating, but I dont know if this makes any difference.

Something is weird here. I had habpanel running fine for weeks, then I tried to install a new binding the other day and received the error above. I messed around with it for a few hours and then decided to just update to the latest snapshot and start over. This time, habpanel doesn’t come up in user interfaces in paper ui. I then grabbed the habpanel jar from releases (the most recent one), and that version seems to be old, as there is no option to set the number of columns in the main panel and things just look different. For some reason habpanel is not showing up anymore in extensions with experimental set to true. Any ideas?

Sorry guys, not really an OSGI expert… no idea what’s wrong here.

I tried an offline snapshot from this week and it worked right out of the box, even after adding bindings.
Maybe try following @HomeBoss’s advice.

If you mean the proof-of-concept packages from August, they are old! Don’t use those packages anymore. I would remove them but GitHub doesn’t seem to let me.

How did you update? As i can see the latest is still OH2 Beta4? Updated to the latest HabPanel, but same issue :confused:
Actually this is pretty fustrating, i can’t even uninstall the binding then install other things - totally stucked?
This is something that started appering after updated the HabPanel

Are you running the nightly builds or just the Beta4 version?

If youre running the Beta4 version and not the nightly builds (snapshots) you should change to the snapshot version.

I’m running the beta 4…
sorry, but how to get the nightly build and keep them updated?

Follow this guide: http://docs.openhab.org/installation/linux.html you need to change the repositorys.

You probably have to uninstall your current Openhab installation before installation, but your config files should be safe Good idea to make a back-up anyway.

Wrong link??

Jeg tænker ikke foredrag på Århus universitet var det du tænkte :slight_smile:

Link changed in previous post .

Nej hastværk er lastværk. Har sat det rigtige link ind.