Handling unknown devices?

Hi guys,

I’ve been running openhab2 for a few weeks now. I’ve recently got alot of problems with some new battery powered devices showing as “Unknown device”.

I’ve been checking these forums and seen that they have been added to the database and everything for like 6 months ago etc.

I downloaded a new Z-wave binding and openhab2 version last night and still having problems.

The devices that are having troubles are:
Fibaro - Flood Sensor (Gen 5)
Aeon Labs Recessed Door Sensor (Gen 5)

I’ll attach the node XML-file for the flood sensor here:
node12.xml (9.4 KB)

The door sensor on the other hand hasn’t gotten a XML-file? Looks like this in Habmin:

Thanks in advance,

For devices that show the manufacturer, or type/id as FFFF, or blank, or unknown, this means that the device has not initialised. One of the first things that happens during the initialisation process is the binding reads the manufacturer information which allows us to identify the device - until this is complete, we know next to nothing about it. The initialisation does a lot more than just this step, and until most of these initialisation steps are complete, we won’t get an XML file.

For mains devices, this is resolved quickly, and you won’t normally even know about this… Battery devices are a different story! A battery device, once included into the network will not do very much until it is configured…

To resolve this, you will need to wake up the device - probably a few times. There’s normally a button to press, or maybe press 3 times - the manual should say. You need to do this close to the controller (let’s say within a few meters) as the controller needs to communicate directly. One of the other things it will do during initialisation is to configure the device so it wakes up periodically so that openHAB can configure it again without you having to manually wake it up (it’s normally set to wake up every hour).

Once it’s initialised, you can then move the device to it’s final position.

1 Like

Thanks for the fast reply, Chris.

New to this as I am, I thought I only had to wake it up once ofcourse. I’ll get that device once I come home and click the hell out of that Action button till it shows up in Habmin. :slight_smile:

How about my other issue? Any idea why it doesn’t get any XML-file?

If it configures correctly, then yes, it should be configured to wake up periodically, so you should only need to do this once. If it doesn’t set the wakeup period though, then this won’t work.

As I said above, until the initialisation sequence is (mostly!) completed, it won’t generate an XML file.


Ok, thanks. I’ll give it another go tonight after work! :slight_smile:

I removed the device from the z-wave network, made a factory reset and included it again last night. Before I went to bed I woke the device up 4 times and placed it close to the controller.

This morning I’ve tried waking it up several times again. Still, it says “Unknown device”. What more can I try openHAB-wise? I got a brand new flood sensor I can unpack and try with so we can rule out hardware problems.

Edit: Have added and tried to wake up a brand new flood sensor now and it has the same problem. Shows “Unknown device”. I’ve added alot of batterydevices earlier, have like 10 fibaro motion sensors already. It shouldn’t be this difficult to add a battery powered device so my conclusion must be that it some problem somewhere in openHAB…

Edit2: Had to make sure that the wake up reached the controller and openHAB:

In the image above, this is working fine. As mentioned earlier, during the discover phase the device reads the IDs, and if they are no FFFF, then it’s worked. In the image above, you can clearly see this has worked fine.

So, for this device, the problem is that the device is not in the database. I guess this is the flood sensor? If so, I’ll add this tonight.

Yeah, its the Fibaro flood sensor. You need any information from me to help you add it?

Thanks for all the help, Chris.

Not for this device - I just need to add the type:id into the database which I get from the image. However if you have other devices that are showing valid device type, then we’ll also need to add them.

Not for now. I returned my door sensor because it looked damaged in one of the circuits. Ill get back to you on that when I get a new one. :slight_smile:

/ Daniel

Actually, this information was added recently for this device - how old is your snapshot?

I reinstalled the binding two days ago.

How did you install the binding - through PaperUI/HABmin?

Are you also using a recent runtime or are you using the beta version?

I’ve read that uninstalling and installing the binding again in PaperUI updates the database, so that’s what I did.

Last time I updated openHAB I downloaded the beta online disto from: http://www.openhab.org/getting-started/downloads.html

Yep - that’s fine - with one caveat… This will download the binding with the same version as the runtime. So, if you are using the nightly snapshot, it will download the nightly snapshot which is updated nightly…

However, if you are running a fixed version, then it will download that fixed version every time.

In your case - the beta version is fixed - it’s not updated (ever), so you will still have the old database from 3 or 4 months ago (ie whenever the last beta was released).

Hm ok, could you perhaps provide me the URL from where I’m supposed to download to not have a fixed version?

The latest snapshot is available on cloudbees…


Thanks, Ill update immediately and reinstall binding after that.

I’m sure this is going to be a common problem in future so I think the system needs some way to do this upgrade from the fixed versions a bit better…

Yeah, perhaps atleast some function to compare local version with latest version. Both binding and openhab.