Harmony Binding Stopped Working in OH1

Hi All,

I’ve had the harmony binding working quite well for some time until yesterday. All of a sudden it stopped working and I get the error below when starting Openhab in debug mode.
“Failed creating harmony hub connection to
java.lang.RuntimeException: Failed to parse response from Logitech auth service”

Nothing was changed in Openhab during this time. I also tried to restore to a previous backup I had taken and it’s still not working.

I have checked the login information in the config file. No problems there.
I can login and control the harmony using the harmony app on my phone.
The IP address is valid.

I’m currently using the 3 bindings at 1.8.1. I tried 1.8.3 and the latest snapshot and still nothing. Odd thing is it worked fine in OH2. I’m not ready to move on from OH1 (tried before, failed miserably), so I was wondering if anyone had any clue as to why the sudden behavior?


Logitech changed their APIs last night, and it has broken the authentication flow for almost every XMPP based Harmony library out there. Fun thing to wake up to…

Other discussions:

It looks like there is a way to bypass the need to login to the Logitech endpoint, and it does allow for control of devices. This may be sufficient as long as they don’t patch that out as a security hole.

This will require updates in OpenHAB or whatever library the OpenHAB Harmony binding is based on to get around it. Until then everyone’s SOL.

I try all OH1 bindings versions too, thanks for response.

Yeah, what they changed is going to fundamentally break the authentication flow for basically all the libraries out there. These things were figured out by reverse engineering the whole thing with wireshark to watch the communications, etc. Logitech has no official support for what any of our libraries are doing, and they have thus far refused to create a publicly accessible API.

The workaround some of us have found does work, but it uses a method that might look like a “bug” in the Logitech implementation that allows bypassing authentication. If Logitech chooses to close that loophole, someone is going to have to sniff out their new method of auth again.

1 Like

Maybe block Harmony access to updates and use this bug? :slight_smile:

I’m not completely sure its a bug. Maybe they WANT anything on your local network to have full control of everything wired to the Harmony without any authentication… Who’s to say. But the small security expert living inside my brain says “this might be a bug that will be patched”. Especially in light of all the recent DoS via IoT news articles.

Of course if anyone actually cracks open Wireshark to see if they can figure out how they changed the request, please share. :slight_smile:

Thanks for the update.

Hi All, the OH2 version of the Harmony binding does not use the external Logitech cloud service, instead it gets its access through the local network discovery protocol. Unfortunately I don’t have any plans to backport that to the OH1 version as OH2 GA is just around the corner.

I’m kind of relieved I just found this thread as strange as that sounds :grin: I just built a new server as my old ancient one definitely died two weeks ago. So I was re-installing everything from backups and got this error now. Everything else worked so I couldn’t figure out what went wrong.
Bad timing was all :unamused:

I just checked on my installation (1.8.3 with the latest binding italled via apt-get. Everything works fine on my side.

It stopped on my side as well. I have a 1.8.3 installation running.
If there are installs out there still working, I assume it is dependent on the Hub firmware as well.
Mine is a 4.11.6.

Mine is still working - I was assuming because I haven’t reset openhab. Or is it because I’m lucky with firmware?

I have the same problem :frowning:

Only solution I can see is to accelerate my testing of openhab 2 on a separate PC, so it can run the Harmony binding and trigger rules on my main openhab 1.8 PC

A little sad to see that we won’t see compatibility for ver 1.8.3 I just got started with Openhab and couldn’t figure my way around OpenHab2. I got this install working 3 weeks ago and have a lot of Harmony configurations. The family enjoys the drapes open and close every day via Harmony IR. Not sure that I am ready to move to version 2 for a while. Really bummed

So my OH1 Harmony binding has now stopped working. I was all proud of myself for getting the OH2 Harmony binding working, but now that’s broken too…

OK. This is fixed. I’d somehow uninstalled the OH2 binding. That is now working, and a simple rule pushes the OH2 Harmony status over to my OH1 system. Will take some time for me to get the hang of OH2, but even a klutz like me can setup an OH2 system this simple:

items file:

String HarmonyActivity "Harmony activity [%s]" <television> {channel="harmonyhub:hub:Livingroom:currentActivity"}

rules file:

rule "Detected Harmony change"
   Item HarmonyActivity changed or
   Item O2test changed to ON
   var String newstatus
   newstatus="wget http://user:password@url:8081/CMD?HarmonyActivity="+HarmonyActivity.state+" -P /tmp"
   logInfo("HARMONY","About to push to main openhab: {}",newstatus)

first let me tell you how much i like your binding, in fact it is the “heart” of my OH setup in the multimedia area.

it’s bad to hear, because much bindings are not ported this time… and so some of us stuck because we can’t move forward with out breaking it, and if we stay it’s broken too… :frowning: …how much work would the back port be? can we help to fix it in OH1? Is there any chance?

Sad to hear that the OH1 binding will not be updated, I do not plan to upgrade to OH2 (have tried) but did not get it to work as i wanted because of missing bindings etc…

Having used (too) many hours on my OH1 setup, its sad that the Mediacenter will not be a part of the “smart”-home anymore…

think about setting up a raspberry pi with the kind of barebones OH2 installation I mentioned above, bridging to your OH1 system. Doesn’t take long.

1 Like