Have a scrollable widget in a panel which is set to "prevent scrolling"

Dear lovely openHAB community.

I’m currently struggling with a HABPanel setup I’m trying to achieve.

Here is the situation:
My panel is set to “prevent scrolling”, which I think is necessary, because I’m using the knob-widget. When having “prevent scrolling” OFF, the whole panel tends to wobble around when using the know widget on my Ipad. - thus I have it ON.

On the same panel I have the Spotify-Playlister widget. Since it may display lots of playlists, it is a scrollable widget. https://community.openhab.org/t/custom-widget-spotify-playlists-for-spotify-binding/62868

However, my problem is: As soon as the panel is set to “prevent scrolling”, the widget is static too.

I wonder if there is a way to

  • have the “background of the panel” locked as with “prevent scrolling”
  • AND have the inside of the Spotify-Playlister widget scrollable ?

What I tried so far is to add scroll attributes in the css of the widget
<div id="xyz" style="overflow-y:scroll;">
also
<div id="xyz" style="overflow:auto;">
but without any success :frowning:

I’d be very thankful for any tip or idea :slight_smile:

Thanks and best regards
Philipp

Guys, I made some progress:

When using Kiosk Pro (lite) instead of safari and having the panel attribute “prevent scrolling” OFF, the panel stays static and the widget is scrollable as long as no widget is outside the visible area (which would trigger the panel to scroll).

However safari (and also chrome, firefox and opera on iPad) seem to not be able to do so. Even when no widget is outside the visible area, these browsers move the whole panel on touch.

Thus the above described behaviour works under the following circumstances on an iPad:

  1. ensure ALL widgets are completely within the visible area.
  2. set the panel option “prevent scrolling” to off.
  3. use Kiosk Pro (lite) as browser

Drawback:
The Lite version of Kiosk Pro prevents the iPad from turning off the screen after x minutes of not using it … thus its always on. This feature gets reintroduces with Kiosk Pro Plus, which is 50$/55€ licence fee…

Actually I don’t like to pay for a feature which an Iphone has by default, but is blocked by the Lite version of Kiosk Pro :confused:

If anyone has tips how to achieve this with safari, please let me know.

Finally I made it work with Safari on iPad.

Here is what to do:

  1. ensure ALL widgets are completely within the visible area.
  2. in Panel settings: set the panel option “prevent scrolling” to off.
  3. in Panel settings: configure an additional Stylesheet.
  4. in the stylesheet put:
    body { position: fixed; }

Thats it :slight_smile:

1 Like