HD PowerView Binding connection error

Hi all,

I’ve recently upgraded to OH 3.2 release build and now experiencing some errors in my logs to do with HD PowerView binding, please see extract below:

2021-12-24 20:51:41.763 [WARN ] [ternal.handler.HDPowerViewHubHandler] - Error connecting to bridge: java.util.concurrent.ExecutionException: "java.io.EOFException: HttpConnectionOverHTTP@107dadb::SocketChannelEndPoint@108d59a{l=/,r=/,ISHUT,fill=-,flush=-,to=12/0}{io=0/0,kio=0,kro=1}->HttpConnectionOverHTTP@107dadb(l:/ <-> r:/,closed=false)=>HttpChannelOverHTTP@1bd77f6(exchange=HttpExchange@183984{req=HttpRequest[GET /api/sceneCollections/ HTTP/1.1]@11cff9e[TERMINATED/null] res=HttpResponse[null 0 null]@a55162[PENDING/null]})[send=HttpSenderOverHTTP@6b9887(req=QUEUED,snd=COMPLETED,failure=null)[HttpGenerator@1d04057{s=START}],recv=HttpReceiverOverHTTP@1acb77c(rsp=IDLE,failure=null)[HttpParser{s=CLOSED,0 of -1}]]"

Both the bridge and all roller shutters are offline. However, the strange this is that they are still controllable through OH.

Any help would be greatly appreciated as it has always worked without any issues.

Many thanks in advanced & of course happy holidays! :slight_smile:

Hi Jeevan,

I"ll have a look asap. Seems like it might have been introduced by [hdpowerview] Add support for scene groups by jlaur · Pull Request #11534 · openhab/openhab-addons · GitHub.

Are you on a V1 or V2 Hub?

Best regards,
Jacob Laursen

Hi Jacob,

I really appreciate the quick response!

I’m currently running with a V1 Hub :slight_smile:

Many thanks,

Hi all, same issue here. I’m on docker. Network mode host. Previously everything worked. Also on hub v1. Willing to test if that helps.


Hi @Jeevs and @mark_leonard_tuil,

Merry Christmas! I’m sorry for the inconvenience. I’ll do my best to provide a solution for you as fast as possible.

I’ve now created a GitHub issue for this bug. If you have a GitHub account we can add additional information to this issue, otherwise we can continue in this thread and I’ll update the issue with any relevant information. Let me know what you prefer.

In order to provide a good fix for this I would ask you to try these URL’s in a web browser:

The first response will make it possible for me to determine which Hub version and/or firmware you are using, which can be used by the binding to determine which features to support.

The next two requests is a test of availability of two specific features.

Next, do you know the feature Scene Groups from the PowerView app? Have you ever been able to create scene groups, i.e. a special type of sceres containing other scenes?

Last, are you able to use automations with your hub?

Best regards,
Jacob Laursen

1 Like

Hi @laursen,

Merry Christmas! No need to apologise at all :slight_smile:

I’m happy to respond either way, posted updates on GitHub too, but for completeness:


{"firmware":{"mainProcessor":{"name":"PowerView Hub","revision":1,"subRevision":1,"build":857}}}

http:///api/sceneCollections/: No response (error)


{"scheduledEventIds": [],"scheduledEventData":[]}

I can see both Scene and Scene Groups in the PowerView app. However, I can only create a Scene - not Scene Group…(not using scene feature)

Yes, but again not actively using this feature as this is being controlled through openHAB

Many thanks for all your help!

1 Like

Hi, a very merry Christmas to you. No problem at all.

These are my results

{“firmware”:{“mainProcessor”:{“name”:“PowerView Hub”,“revision”:1,“subRevision”:1,“build”:857}}}

Scene collection
No response


{“scheduledEventIds”: [60928],“scheduledEventData”:[{“id”:60928,“enabled”:true,“sceneId”:58576,“daySunday”:true,“dayMonday”:true,“dayTuesday”:true,“dayWednesday”:true,“dayThursday”:true,“dayFriday”:true,“daySaturday”:true,“eventType”:2,“hour”:0,“minute”:0}]}

I don’t know / use the feature Scene Groups.

I am able to use automation. Yesterday, I added an automation to close the blinds at sunset. That works.

Thanks for your help. Let me know if I can help in other ways

1 Like

Short update, I’ve provided a first version of a fix. Please see the GitHub issue for link.

I you have additional time and strength, please have a look at my comment about sniffing packets from the Android app. If one of you would be able to pull this off, I should be able to correctly support scene groups for Hub v1.

Best regards,
Jacob Laursen

1 Like

@mark_leonard_tuil - above will not be needed. With help from @Jeevs I was able find the root cause for this issue with the v1 hub. JAR is available here..

Best regards and Merry Christmas,
Jacob Laursen


Thanks. I will install the download after Christmas. Thanks for the quick response and fix.

Thanks for sharing this info this is useful keep it up.