HEATIT Z-TRM3 Temp Setpoint not working

Tags: #<Tag:0x00007efecc1fa028>

Hi

I cant set thermostat temperature in control menu. It just read the setpoint value.

In item config, (parameter nr.9) Heating Setpoint all working, i can set correct temperature.
Can somebody help with this? Is this complicated fix? Can i do it my self somehow?

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1238#

Thanks. K

I tried set temperature setpoint from Z-Wave PC-Controller and this works very well.
Maybe is something wrong with conversion form 2 digit to 3 digit value
(set 20, command is sending 200)

One weird thing more.
From Basic UI if i tap on temp change button rapidly 15sec then the setpoint value changes sometimes.

KNew Text Document (5).txt (6.4 KB)

How is this done? Is it setting a setpoint through the thermostat class? Please can you provide a debug log showing the problem.

1 Like

I have recently got this thermostat as well. I have not tried to set the setpoint in the app/sitemap. I could however set the temperature when connecting the thermostat to Google Assistant so it seems to do something for me. Saying “Set the floor temperature to X” works and also via the Google “Home” app.

I can help debug if you need any more information.

What problem are you actually having with this device? Please can you clearly describe this as I’m a bit uncertain of the issue at the moment.

https://drive.google.com/file/d/12epbs026lTvPyFY2NyjuF0qtqv_hh4Ig/view?usp=sharing

NODE15

Setpoint type 1 = heating.
Size = 1 byte, scale = 0 = Celsius, Precision = 0 = no decimal places
Value = 0x14 = 20 = 20 degrees C

This looks fine to me.

I’m sorry for the confusion, I just pointed out that my device (same as threadstarters) seems to be working fine. I have set the setpoint successfully via Google Home/Home app but I have not tried to set it directly from Openhab, but it should be the same. My point was that this might indicate that it might be something wrong with @kaliif1234 setup.

Since it seems to work for me I just offered to make comparisons between my setup (which seems to work) and theirs (versions, logs etc) if this could be of use.

Ah - ok, thanks.

I wasn’t clear if this runs through OH? ie when you say to Google to set the setpoint, does that send a command back to OH and go through the binding, or does it use a different ZWave interface?

Thanks.

To clarify, I use Google Home/Assistant with the cloud connector pointing at my Openhab items/channels (i.e Google changes the same “Number” item as I would change directly in Openhab. So to me it seems the same).

1 Like

Yes - I agree - that should send it through the ZWave binding, and this should be exactly the same as going through the UI (as far as the binding is concerned).

Thanks.

Here you get the latest Z-Wave binding.
https://ci.openhab.org/view/Integration%20Builds%20(2.5.x)/job/openHAB2.5.x-ZWave/

I added this Heatit Z-TRM to database recently.
Can you check is it working?

How? Unless someone has a newer device it will not make any difference.

Also, from the binding perspective, the code is exactly the same as the older version - ie there have been no changes so the commands send will be the same.

Sorry, i mean Masssssy .
Masssssy can you check?

Sure - but what I meant is that unless @Masssssy has the same (new) device version as you, it will not change. Also, the binding code has not changed at all, so there will not be any difference in what the binding sends just because you added a new database entry.

1 Like

Actually I might have confused up the versions of the device. I might actually have the Z-TRM2FX version, so my input might have been completely useless. I can check later when I get home which version it is I have (bought it very recently so figured it was the latest but TRM2FX rings more bells in my head).

But again, the code in the binding is the same - so it’s not useless feedback. It shows that this command is correct.

Massssy
Please try your thermostat to see if it works
Maybe I have a broken thermostat

I’m a bit confused - hasn’t he already done that? The change you made to the database will not make any difference to how the code works, so any tests done on the binding in the past will still show the code is fine.

Also, as I showed above - the command that the binding sent for YOUR system also looks fine to me.

I’m a bit confused as well.

The thermostat works well for me on OpenHAB 2.5.4 with included Z-wave binding. However I have the Z-TRM2FX version not the Z-TRM3.