Help with Sonoff mini R2 factory reset or tasmota

Hi, yesterday I tried to setup my first Sonoff ever. I have Sonoff mini R2 and I tried to load tasmota, but didn’t get far.

I managed to connect to the device and assigned my IOT WiFi parameters. I then switched on the OTA, but the Sonoff flash software couldn’t find the device. When I tried holding the button few seconds then I am able to connect to the AIP it creates, but I can’t get the webserver on anymore. If I hold the button one minute it ruins my WiFi network. It seems that the Sonoff acts as DHPC server.
Any idea how to factory reset the device or proceed with tasmota flash?

I came across similar roadblocks to you, but I eventually got past them. I am not sure if the problem for me occurred when I maybe entered in an incorrect Access Point/Password, but I could not get it on my LAN.

After many, many reset attempts I believe I managed to reset it to factory, then I was surprised that I could use EWELink and set it up on my LAN. After I had done this, everything fell in place. (In order to get it back to Ewelink mode I held down the button for 5 seconds. I might have done this twice in a row. I don’t know but I do know it took a lot of fiddling and attempts. One thing I learnt (I think) is that when he device is in “Ewelink mode” it is pingable, but does not open communication properly on port 80 or 8081 - it is possible to connect to it on those ports but not send HTTP requests. Discovering this was another part of my breakthrough.

After this I did another reset and managed to get it into DIY mode. From there I followed instructions from Sonoff Mini R2 Switch flashing Tasmota - and it worked.

I was surprised, but ignoring the reset pin on V1 thats not present on V2, the devices must be pretty similar, because I landed up following a V1 youtube instruction to help me work through Ewelink and what was going on.

I hope this post (a) comforts you that you likely have not bricked the device and (b) gives you things to try to get it working. I am aware that, as far as answers go, its not a great one - but as no one else has answered it in 3 months, at least its something - and even if it doesnt help you, it might help someone else.

Thanks @davidgo, glad you managed but I quit and started using this binding. Some of my devices are already built into switches and I don’t have the will to lose time

Just to let you know you’re not the only one that stumbled on the challenging flashing issue.
I bricked 3 Sonoff Mini’s trying the OTA flashing with Tasmota Lite. I didn’t want to trow them in the trash so I looked for an alternative end ended up using this method:
The process of soldering the wires requires a steady hand :wink: but all in all it took me like 10 minutes max for each switch to get Tasmota up and running.
And all of them are now part of my openHAB setup :sunglasses:

Hope this helps someone to recycle bricked switches!!

So after facing a lot of problems with the slow or no response to commands by using the abovementioned binding , I decided to give tasmota another try.

My devices were connected to EWElink and as you mentioned, it was not possible to flash them. So the right procedure was to hold the button 5s 2 times, then I was able to connect to the AP of the mini and connect it to my wifi. After that I was able to flash it.

On one occasion I had to re-add the mini with the EWELink app, otherwise I was not able to open the page, although I was connected to the AP of the mini.