Homekit problem with "Accessory already in use in another home"

after a first test I have to clear and start from zero with a new house in app HOME,
I’m trying to pair iPhone with qr.code from OH4
but now I still have this error on iPhone : “Accessory already in use in another home”
I’m crazing, I try to reboot everything, clear cache, reboot, rearing… nothing …
Why this errore remain ??

Did you buy the device second hand? It sounds like someone already registered it in their home. Or do you have two homes? I would suggest to do a full factory rrset on that device.

Have you looked in the documentation HomeKit Add-on - System Integrations | openHAB at additional notes section? I believe this describes what to do to clear the pairing and start over.

Hi, sorry I wrote too quickly and I was not clear.
I mean that I can’t add the home app as the Optanhab device.
On my OH4 installation I have in fact enabled Homekit and attempted to associate it with the app via the QRcode as shown in the instructions.
This was only possible the first time.
Then I had to redo the procedure to correct errors and from that point I appear the error indicated above.

try following steps:

  • remove openhab from home app if it is still there
  • execute “clear pairing” as described in the documentation (let me know if any help needed)
  • restart iphone. after this, you should be able to add it again

There is no device visible in my HOME app.

I did it

I did iphone restart and in this evening I will do a new pairing, but :
To add openHAB to the HOME app,
is it MANDATORY to be in the same network or can I also do it from outside the home?
Thanks for the support

Remove the file ‚homekit.json‘ in userdata/jsondb

OK done,
As soon as I get home tonight I’ll try pairing again…
Thank you !!

Have a look here as well

I tried all the steps, several times … but nothing to do …
I continue to have the same mistake …
I deleted the cache, the Openhab service on the Raspberry stopped,
restarted everything, even the phone, deleted the file that You showed me above … sigh …
I don’t understand anything anymore … I’m very sad …

I had the same problem half a year ago and I try to get what I did.
Did you execute the command “homekit clearPairings” from karaf console

Good morning,
last night I did several steps, including console commands, reboots and clearPairings…
I’m not able to say exactly the sequence
but at a certain point the homekit.json file reappeared in the userdata/jsondb folder (which I had already deleted),
and following further clearPairings a new “user” section appeared inside the file
and from that point I was able to associate openHAB with the CASA app.

Then I tried several times to add and remove OH from HOME and it always works!

where do I see the items with “homekit” metadata in the app??
I declared more than one of different types but I don’t see them…

Thanks for your support and patience :star_struck:

As soon as you have installed the homekit bridge and have added the metadata to the item, the item should appear in the apple homekit app.
Do you have a homekit server on an apple tv or ipad?

I’m using HomePod mini,
it’s is declared as hub…

HomePod as bridge could have led to this strange behaviour. bridges are acting as cache. they do remember the old configuration and linked devices. it helps sometime to switch them off for time of initial pairing.

Ok Clear
I already reboot HomePod …
What could be the right procedure to makes my items visible??

Maybe that helps. ( translate it if needed). Reboot is not sufficient, need a reset I don’t use an ipod mini

Here I am again,
I did various tests, turning everything off and on again,
I reset homePod mini again,
deleted and redone the association of openHAB on the CASA app,
but I didn’t get any results,
I don’t see items with “homekit” metadata…
what else can I check?
Thank you

do you see openHAB in home/CASA app?
do you see any items or sensor in CASA app?
please share a screenshot of one item with metadata?

i would suggest to try first with only one item - something simple, e.g. simple light or switch and remove homekit metadata from all others

Yes, here you are :

but it’s declared as NON compatible with Homekit


Here you are :

Switch                Presa_75                 "Presa 75 - Luci Laboratorio"                      <light>               (GR_Laboratorio, MH_Prese)                              ["Switch"]            {homekit="Laboratorio", channel="openwebnet:bus_on_off_switch:BT_MH202:T_Presa_75:switch"}

Before of all I rest every goods and now I have only 1 item declared

I’m running this :