Homematic CCU3 connection issues - COMMUNICATION_ERROR Unknown XML-RPC tag: title

Tags: #<Tag:0x00007fc8f0d3eb48> #<Tag:0x00007fc8f0d3ea30> #<Tag:0x00007fc8f0d3e940>

OK, update was successfull. So far so good.

Even the CCU was discoverd automatically and appears in the inbox. But while adding it it stucks on “Initializing”
Manaully adding gives the same result…

anything in the openhab.log?

2018-11-22 21:11:58.297 [WARN ] [core.thing.internal.ThingManagerImpl] - Disposing handler for thing ‘homematic:bridge:e4b325c7’ takes more than 5000ms.
2018-11-22 21:13:19.869 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘osramlightify:power:84-18-26-00-00-0E-F4-D5’ to inbox.
2018-11-22 21:25:47.617 [WARN ] [core.thing.internal.ThingManagerImpl] - Disposing handler for thing ‘homematic:bridge:3014F711A0001F98A99A42AD’ takes m$
2018-11-22 21:25:55.786 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘homematic:bridge:3014F711A0001F98A99A42AD’ to inbox.

maybe sothing more interesting …

2018-11-22 20:26:33.781 [ERROR] [ome.core.thing.internal.ThingManager] - Exception occurred while disposing handler of thing ‘homematic:bridge:a4996c41’$
java.lang.NullPointerException: null
at org.openhab.binding.homematic.internal.discovery.HomematicDeviceDiscoveryService.waitForScanFinishing(HomematicDeviceDiscoveryService.java:17$
at org.openhab.binding.homematic.internal.discovery.HomematicDeviceDiscoveryService.stopScan(HomematicDeviceDiscoveryService.java:121) [222:org.$
at org.openhab.binding.homematic.handler.HomematicBridgeHandler.dispose(HomematicBridgeHandler.java:143) [222:org.openhab.binding.homematic:2.3.$
at sun.reflect.GeneratedMethodAccessor31.invoke(Unknown Source) ~[?:?]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]
at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [101:org.eclipse.smarth$
at org.eclipse.smarthome.core.internal.common.Invocation.call(Invocation.java:53) [101:org.eclipse.smarthome.core:0.10.0.oh230]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
at java.lang.Thread.run(Thread.java:748) [?:?]

This is the problem but I don’t know what is the root-cause… searching github now

can you try to: Clear tmp&cache, remove all Homematic Things and re-install the binding?

Removing all HM things, basically only ccu :wink:
uninstalled binding
reboot
installed binding
added HM
still only initializing.

but how I can clean the cache? or did the reboot already cleaned the cache?

no, the reboot doesn’t clean tmp&cache

see here how: Clear the Cache

still the same :frowning:

You may try to open up a github issue for this NPE… I don’t know what could be the root-cause…

I think my installation is bricked…

Just noticed that my fritz box binding is now also not working… even fritz box and all things were online.
Have removed the fritzbox and now while adding it back, it stucked at initializing… :-(:weary:

I am going to setup a new vm and try with a new fresh setup once again… then directly with 2.4

brand new setup… all new binsing are not workling.

same issue like before on old system with homematic. now with avm. so testing builds are really not stable :-/

2018-11-23 21:37:17.857 [WARN ] [ig.xml.osgi.XmlDocumentBundleTracker] - The XML document ‘/ESH-INF/binding/binding.xml’ in module ‘org.openhab.binding.avmfritz’ c$
java.lang.IllegalArgumentException: The XmlConfigDescriptionProvider must not be null!
at org.eclipse.smarthome.core.binding.xml.internal.BindingInfoXmlProvider.(BindingInfoXmlProvider.java:59) ~[?:?]
at org.eclipse.smarthome.core.binding.xml.internal.XmlBindingInfoProvider.createDocumentProvider(XmlBindingInfoProvider.java:141) ~[?:?]
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.acquireXmlDocumentProvider(XmlDocumentBundleTracker.java:180) ~[100:org.eclipse.smarthome$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.addingObject(XmlDocumentBundleTracker.java:205) ~[100:org.eclipse.smarthome.config.xml:0.$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.parseDocuments(XmlDocumentBundleTracker.java:351) [100:org.eclipse.smarthome.config.xml:0$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.processBundle(XmlDocumentBundleTracker.java:337) [100:org.eclipse.smarthome.config.xml:0.$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.access$4(XmlDocumentBundleTracker.java:332) [100:org.eclipse.smarthome.config.xml:0.10.0.$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker$2.run(XmlDocumentBundleTracker.java:307) [100:org.eclipse.smarthome.config.xml:0.10.0.oh2$
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) [?:?]
at java.util.concurrent.FutureTask.run(FutureTask.java:264) [?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) [?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
at java.lang.Thread.run(Thread.java:834) [?:?]

all bindings throw the same warn?
The XML document ‘/ESH-INF/binding/binding.xml’ in module [...] c$ java.lang.IllegalArgumentException: The XmlConfigDescriptionProvider must not be null! ?

I just tried M6 and installed avm & homematic and it doesn’t give me any warnings…

I have seen this error usually associated with an old JVM (or openJDK)

what is your java -version ?

java version “11.0.1” 2018-10-16 LTS
Java™ SE Runtime Environment 18.9 (build 11.0.1+13-LTS)
Java HotSpot™ 64-Bit Server VM 18.9 (build 11.0.1+13-LTS, mixed mode)

oracle latest build

aha! this is the root-cause of your problems…

We are not still there yet… OH2.x cannot run (yet) under JVM 11

You need to downgrade to JVM 8 and you will be just fine.

I feared that … I will try a new vm again. don´t like “messy” systems… :wink: should i go with oracle or use zulu for best compatibility?

Personally, I choose the “devil” (Oracle)… they own Java now :frowning:

The official recommendation is Zulu of course :slight_smile:

both work fine

:sob:

openjdk version “1.8.0_192”
OpenJDK Runtime Environment (Zulu 8.33.0.1-linux64) (build 1.8.0_192-b01)
OpenJDK 64-Bit Server VM (Zulu 8.33.0.1-linux64) (build 25.192-b01, mixed mode)

zulu installed, switched java to zulu

still same. no binding is coming online

but i think the error message seems to be different?

2018-11-23 22:29:35.811 [INFO ] [.eclipse.smarthome.binding.homematic] - FrameworkEvent INFO - org.eclipse.smarthome.binding.homematic
java.io.IOException: Exception in opening zip file: /var/lib/openhab2/cache/org.eclipse.osgi/197/0/bundleFile
at org.eclipse.osgi.framework.util.SecureAction.getZipFile(SecureAction.java:321) ~[?:?]
at org.eclipse.osgi.storage.bundlefile.ZipBundleFile.basicOpen(ZipBundleFile.java:93) ~[?:?]
at org.eclipse.osgi.storage.bundlefile.ZipBundleFile.getZipFile(ZipBundleFile.java:106) ~[?:?]
at org.eclipse.osgi.storage.bundlefile.ZipBundleFile.checkedOpen(ZipBundleFile.java:65) ~[?:?]
at org.eclipse.osgi.storage.bundlefile.ZipBundleFile.getEntry(ZipBundleFile.java:240) ~[?:?]
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findClassImpl(ClasspathManager.java:560) ~[?:?]
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClassImpl(ClasspathManager.java:538) ~[?:?]
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:525) ~[?:?]
at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:328) ~[?:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:368) ~[?:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:446) ~[?:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395) ~[?:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387) ~[?:?]
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150) ~[?:?]
at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:?]
at org.eclipse.smarthome.binding.homematic.internal.communicator.client.RpcClient.listBidcosInterfaces(RpcClient.java:118) ~[?:?]
at org.eclipse.smarthome.binding.homematic.internal.communicator.client.RpcClient.getGatewayInfo(RpcClient.java:243) ~[?:?]

2018-11-23 22:32:17.322 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘avmfritz:fritzbox:192_168_188_1’ to inbox.
2018-11-23 22:32:17.410 [ERROR] [org.eclipse.smarthome.io.rest.sse ] - FrameworkEvent ERROR - org.eclipse.smarthome.io.rest.sse
org.osgi.framework.BundleException: Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.eclipse.smarthome.io.r$
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:800) ~[?:?]
at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:729) [?:?]
at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:933) ~[?:?]
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:309) ~[?:?]
at org.eclipse.osgi.container.Module.doStart(Module.java:581) ~[?:?]
at org.eclipse.osgi.container.Module.start(Module.java:449) ~[?:?]
at org.eclipse.osgi.framework.util.SecureAction$23.run(SecureAction.java:474) ~[?:?]
at org.eclipse.osgi.framework.util.SecureAction$23.run(SecureAction.java:1) ~[?:?]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:472) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.start(ModuleContainer.java:750) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.applyDelta(ModuleContainer.java:741) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.resolveAndApply(ModuleContainer.java:511) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.resolve(ModuleContainer.java:457) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.refresh(ModuleContainer.java:1001) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer$ContainerWiring.dispatchEvent(ModuleContainer.java:1382) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer$ContainerWiring.dispatchEvent(ModuleContainer.java:1) ~[?:?]
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) [?:?]
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340) [?:?]
Caused by: java.lang.LinkageError: ClassCastException: attempting to castbundleresource://31.fwk1208442275/javax/ws/rs/ext/RuntimeDelegate.class to b$
at javax.ws.rs.ext.RuntimeDelegate.findDelegate(RuntimeDelegate.java:146) ~[?:?]
at javax.ws.rs.ext.RuntimeDelegate.getInstance(RuntimeDelegate.java:120) ~[?:?]
at javax.ws.rs.core.MediaType.valueOf(MediaType.java:179) ~[?:?]
at org.glassfish.jersey.media.sse.SseFeature.(SseFeature.java:62) ~[?:?]
at org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start(SseActivator.java:49) ~[?:?]
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:779) ~[?:?]
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1) ~[?:?]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:772) ~[?:?]
… 18 more
2018-11-23 22:32:17.549 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
2018-11-23 22:32:17.612 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2018-11-23 22:32:18.185 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-avmfritz’: Error restarting bundles:
Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.eclipse.smarthome.io.rest.sse.

if this is the first startup of OH2.4.0.M6 on a clean system, that’s fine.
stop OH2 service, run openhab-cli clean-cache wait 10 secs and then start it again and monitor logs.

is Zulu selected as the default JVM?
what does java -version show on the linux console?

edit: included openhab-cli clean-cache above.

I am tryiing now a blank new vm (again) with zulu 8 only.
have installed OH2.3 stable right now. lets see how it works

  • fritzbox is working again on stable. I will move forward to 2.4M6 now
  • OH 2.4M6 is installes. AVM binding still working OK
  • Homematic CCU is again only intializing… but without any errors in the logs…

After next 5 minutes initializing switch to:
Status: OFFLINE - COMMUNICATION_ERROR Unknown XML-RPC tag: title
Same what I had with OH 2.3. But still no error in the openhab.log

Am I missing something? CCU firewall is currently open.

HomeKit and Osram is also working fine. Just the CCU not. … :frowning:

1 Like

I found the solution!

Looks like in the new firmware is one point under security: Authentication: Default is on. It needs then user/passwort to get access to the RPC API. Since the binding has no option to enter user / pw I disabled it on the CCU and voila… it works. CCU is online and found my things.

Thank you DIM to goiing through with me :slight_smile:

Maybe the Homematic Guide should be updated with a warning or hint to deactivate the option in the CCU.

1 Like