Homematic CCU3 connection issues - COMMUNICATION_ERROR Unknown XML-RPC tag: title

Hello, I am rather new in all of this technology.

I got a new Homematic CCU3 and try now to connect it with the Homematic Binding 2.3. It tries to initialize the gateway and ends with the following error:

Status: OFFLINE - COMMUNICATION_ERROR Unknown XML-RPC tag: title

Firmware: 3.41.11

I set the firewall settings on the ccu3 already to allow anything. Any suggestions?

Hi Don, you need to upgrade your OH to something like 2.4M6

Ah ok, but 2.4m isn´t stable correct? So I need to change the repo and run apt get install openhab2 again. Does it just update and keep my settings or is it going to reset my whole setup?

It is 95% stable :slight_smile:
that extra 5% of instability will come if you deploy some buggy addon.
The core and 95% of use cases are very stable (imho)

No problems have been reported since it’s launch: [OH 2.4.0 M6] Testing Results

That is good to know. Do you know something about the update process from stable to snapshot? I have OH installed on Ubuntu so I have to update it manualy by apt.

Will my setup survive the update? :smiley:

I have already AVM FritzBox and Osram Lightify binding with several things running and additional HomeKit integration.

to milestone or snapshot?

if you are using apt: follow the installation instructions on https://www.openhab.org/docs/installation/linux.html#apt-based-systems
Change to the appropriate repo (testing=milestones or unstable=snapshots) and simply apt update and apt install (it will deploy 2.4.0 M6 on top of your existing 2.3.0 Stable and effectively upgrade it). I have added some info in the FAQ around this.

From 2.3.0 Stable to 2.4.0 M6: absolutely yes. I don’t remember any major breaking change (outside Z-Wave) that should give you lots of troubles. Backup your OH2.3.0 first of course.

Great thank. I will go ahead and try the update later tonight. :slight_smile:

1 Like

openhab-cli backup [file] first
better safe than sorry :slight_smile:

if you get stuck, we are here :+1:

OK, update was successfull. So far so good.

Even the CCU was discoverd automatically and appears in the inbox. But while adding it it stucks on “Initializing”
Manaully adding gives the same result…

anything in the openhab.log?

2018-11-22 21:11:58.297 [WARN ] [core.thing.internal.ThingManagerImpl] - Disposing handler for thing ‘homematic:bridge:e4b325c7’ takes more than 5000ms.
2018-11-22 21:13:19.869 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘osramlightify:power:84-18-26-00-00-0E-F4-D5’ to inbox.
2018-11-22 21:25:47.617 [WARN ] [core.thing.internal.ThingManagerImpl] - Disposing handler for thing ‘homematic:bridge:3014F711A0001F98A99A42AD’ takes m$
2018-11-22 21:25:55.786 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘homematic:bridge:3014F711A0001F98A99A42AD’ to inbox.

maybe sothing more interesting …

2018-11-22 20:26:33.781 [ERROR] [ome.core.thing.internal.ThingManager] - Exception occurred while disposing handler of thing ‘homematic:bridge:a4996c41’$
java.lang.NullPointerException: null
at org.openhab.binding.homematic.internal.discovery.HomematicDeviceDiscoveryService.waitForScanFinishing(HomematicDeviceDiscoveryService.java:17$
at org.openhab.binding.homematic.internal.discovery.HomematicDeviceDiscoveryService.stopScan(HomematicDeviceDiscoveryService.java:121) [222:org.$
at org.openhab.binding.homematic.handler.HomematicBridgeHandler.dispose(HomematicBridgeHandler.java:143) [222:org.openhab.binding.homematic:2.3.$
at sun.reflect.GeneratedMethodAccessor31.invoke(Unknown Source) ~[?:?]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]
at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [101:org.eclipse.smarth$
at org.eclipse.smarthome.core.internal.common.Invocation.call(Invocation.java:53) [101:org.eclipse.smarthome.core:0.10.0.oh230]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
at java.lang.Thread.run(Thread.java:748) [?:?]

This is the problem but I don’t know what is the root-cause… searching github now

can you try to: Clear tmp&cache, remove all Homematic Things and re-install the binding?

Removing all HM things, basically only ccu :wink:
uninstalled binding
reboot
installed binding
added HM
still only initializing.

but how I can clean the cache? or did the reboot already cleaned the cache?

no, the reboot doesn’t clean tmp&cache

see here how: Clear the Cache

still the same :frowning:

You may try to open up a github issue for this NPE… I don’t know what could be the root-cause…

I think my installation is bricked…

Just noticed that my fritz box binding is now also not working… even fritz box and all things were online.
Have removed the fritzbox and now while adding it back, it stucked at initializing… :-(:weary:

I am going to setup a new vm and try with a new fresh setup once again… then directly with 2.4

brand new setup… all new binsing are not workling.

same issue like before on old system with homematic. now with avm. so testing builds are really not stable :-/

2018-11-23 21:37:17.857 [WARN ] [ig.xml.osgi.XmlDocumentBundleTracker] - The XML document ‘/ESH-INF/binding/binding.xml’ in module ‘org.openhab.binding.avmfritz’ c$
java.lang.IllegalArgumentException: The XmlConfigDescriptionProvider must not be null!
at org.eclipse.smarthome.core.binding.xml.internal.BindingInfoXmlProvider.(BindingInfoXmlProvider.java:59) ~[?:?]
at org.eclipse.smarthome.core.binding.xml.internal.XmlBindingInfoProvider.createDocumentProvider(XmlBindingInfoProvider.java:141) ~[?:?]
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.acquireXmlDocumentProvider(XmlDocumentBundleTracker.java:180) ~[100:org.eclipse.smarthome$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.addingObject(XmlDocumentBundleTracker.java:205) ~[100:org.eclipse.smarthome.config.xml:0.$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.parseDocuments(XmlDocumentBundleTracker.java:351) [100:org.eclipse.smarthome.config.xml:0$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.processBundle(XmlDocumentBundleTracker.java:337) [100:org.eclipse.smarthome.config.xml:0.$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.access$4(XmlDocumentBundleTracker.java:332) [100:org.eclipse.smarthome.config.xml:0.10.0.$
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker$2.run(XmlDocumentBundleTracker.java:307) [100:org.eclipse.smarthome.config.xml:0.10.0.oh2$
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) [?:?]
at java.util.concurrent.FutureTask.run(FutureTask.java:264) [?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) [?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
at java.lang.Thread.run(Thread.java:834) [?:?]

all bindings throw the same warn?
The XML document ‘/ESH-INF/binding/binding.xml’ in module [...] c$ java.lang.IllegalArgumentException: The XmlConfigDescriptionProvider must not be null! ?

I just tried M6 and installed avm & homematic and it doesn’t give me any warnings…

I have seen this error usually associated with an old JVM (or openJDK)

what is your java -version ?

java version “11.0.1” 2018-10-16 LTS
Java™ SE Runtime Environment 18.9 (build 11.0.1+13-LTS)
Java HotSpot™ 64-Bit Server VM 18.9 (build 11.0.1+13-LTS, mixed mode)

oracle latest build