Homematic CCU3 connection issues - COMMUNICATION_ERROR Unknown XML-RPC tag: title

aha! this is the root-cause of your problems…

We are not still there yet… OH2.x cannot run (yet) under JVM 11

You need to downgrade to JVM 8 and you will be just fine.

I feared that … I will try a new vm again. don´t like “messy” systems… :wink: should i go with oracle or use zulu for best compatibility?

Personally, I choose the “devil” (Oracle)… they own Java now :frowning:

The official recommendation is Zulu of course :slight_smile:

both work fine


openjdk version “1.8.0_192”
OpenJDK Runtime Environment (Zulu (build 1.8.0_192-b01)
OpenJDK 64-Bit Server VM (Zulu (build 25.192-b01, mixed mode)

zulu installed, switched java to zulu

still same. no binding is coming online

but i think the error message seems to be different?

2018-11-23 22:29:35.811 [INFO ] [.eclipse.smarthome.binding.homematic] - FrameworkEvent INFO - org.eclipse.smarthome.binding.homematic
java.io.IOException: Exception in opening zip file: /var/lib/openhab2/cache/org.eclipse.osgi/197/0/bundleFile
at org.eclipse.osgi.framework.util.SecureAction.getZipFile(SecureAction.java:321) ~[?:?]
at org.eclipse.osgi.storage.bundlefile.ZipBundleFile.basicOpen(ZipBundleFile.java:93) ~[?:?]
at org.eclipse.osgi.storage.bundlefile.ZipBundleFile.getZipFile(ZipBundleFile.java:106) ~[?:?]
at org.eclipse.osgi.storage.bundlefile.ZipBundleFile.checkedOpen(ZipBundleFile.java:65) ~[?:?]
at org.eclipse.osgi.storage.bundlefile.ZipBundleFile.getEntry(ZipBundleFile.java:240) ~[?:?]
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findClassImpl(ClasspathManager.java:560) ~[?:?]
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClassImpl(ClasspathManager.java:538) ~[?:?]
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:525) ~[?:?]
at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:328) ~[?:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:368) ~[?:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:446) ~[?:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395) ~[?:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387) ~[?:?]
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150) ~[?:?]
at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:?]
at org.eclipse.smarthome.binding.homematic.internal.communicator.client.RpcClient.listBidcosInterfaces(RpcClient.java:118) ~[?:?]
at org.eclipse.smarthome.binding.homematic.internal.communicator.client.RpcClient.getGatewayInfo(RpcClient.java:243) ~[?:?]

2018-11-23 22:32:17.322 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘avmfritz:fritzbox:192_168_188_1’ to inbox.
2018-11-23 22:32:17.410 [ERROR] [org.eclipse.smarthome.io.rest.sse ] - FrameworkEvent ERROR - org.eclipse.smarthome.io.rest.sse
org.osgi.framework.BundleException: Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.eclipse.smarthome.io.r$
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:800) ~[?:?]
at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:729) [?:?]
at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:933) ~[?:?]
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:309) ~[?:?]
at org.eclipse.osgi.container.Module.doStart(Module.java:581) ~[?:?]
at org.eclipse.osgi.container.Module.start(Module.java:449) ~[?:?]
at org.eclipse.osgi.framework.util.SecureAction$23.run(SecureAction.java:474) ~[?:?]
at org.eclipse.osgi.framework.util.SecureAction$23.run(SecureAction.java:1) ~[?:?]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:472) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.start(ModuleContainer.java:750) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.applyDelta(ModuleContainer.java:741) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.resolveAndApply(ModuleContainer.java:511) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.resolve(ModuleContainer.java:457) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer.refresh(ModuleContainer.java:1001) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer$ContainerWiring.dispatchEvent(ModuleContainer.java:1382) ~[?:?]
at org.eclipse.osgi.container.ModuleContainer$ContainerWiring.dispatchEvent(ModuleContainer.java:1) ~[?:?]
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) [?:?]
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340) [?:?]
Caused by: java.lang.LinkageError: ClassCastException: attempting to castbundleresource://31.fwk1208442275/javax/ws/rs/ext/RuntimeDelegate.class to b$
at javax.ws.rs.ext.RuntimeDelegate.findDelegate(RuntimeDelegate.java:146) ~[?:?]
at javax.ws.rs.ext.RuntimeDelegate.getInstance(RuntimeDelegate.java:120) ~[?:?]
at javax.ws.rs.core.MediaType.valueOf(MediaType.java:179) ~[?:?]
at org.glassfish.jersey.media.sse.SseFeature.(SseFeature.java:62) ~[?:?]
at org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start(SseActivator.java:49) ~[?:?]
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:779) ~[?:?]
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1) ~[?:?]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:772) ~[?:?]
… 18 more
2018-11-23 22:32:17.549 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
2018-11-23 22:32:17.612 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2018-11-23 22:32:18.185 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-avmfritz’: Error restarting bundles:
Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.eclipse.smarthome.io.rest.sse.

if this is the first startup of OH2.4.0.M6 on a clean system, that’s fine.
stop OH2 service, run openhab-cli clean-cache wait 10 secs and then start it again and monitor logs.

is Zulu selected as the default JVM?
what does java -version show on the linux console?

edit: included openhab-cli clean-cache above.

I am tryiing now a blank new vm (again) with zulu 8 only.
have installed OH2.3 stable right now. lets see how it works

  • fritzbox is working again on stable. I will move forward to 2.4M6 now
  • OH 2.4M6 is installes. AVM binding still working OK
  • Homematic CCU is again only intializing… but without any errors in the logs…

After next 5 minutes initializing switch to:
Same what I had with OH 2.3. But still no error in the openhab.log

Am I missing something? CCU firewall is currently open.

HomeKit and Osram is also working fine. Just the CCU not. … :frowning:

1 Like

I found the solution!

Looks like in the new firmware is one point under security: Authentication: Default is on. It needs then user/passwort to get access to the RPC API. Since the binding has no option to enter user / pw I disabled it on the CCU and voila… it works. CCU is online and found my things.

Thank you DIM to goiing through with me :slight_smile:

Maybe the Homematic Guide should be updated with a warning or hint to deactivate the option in the CCU.

1 Like

Same problem with CCU. How can I disable it on the CCU?

Settings --> Security --> Authentication (2nd from the bottom). Deactivate the checkbox

That did it. Thanks a lot!!!

This should be fixed in the next ESH stable release (probably build 318).

donativo: that and you’re running on 2.4M6 right? so it wouldn’t work on 2.3 even without the auth turned off? Mine is turned off by default and it doesn’t work on 2.3…

…answering my own question - yes, the same config which didn’t work on 2.3, works flawlessly on 2.4M6 after an upgrade by apt-get upgrade as described in the upgrade/installation manual

Thank you all for the advice to upgrade, guys!

I have a same problem with ccu3. I have disable the authetification Bottom on security values for XML_RPC.

My openhab version is on Synology.

I can not update this Verion of 2.4. i d´nt have a spk file for this.

What can do?

HI, I have the same issue.

I use raspberrymatic in the current version and openhabian with version 2.3.0-S1451-1.

I disabled the authentication on the ccu, but in openhabian I have the rror


Unknown XML-RCP tag:title

Same message is in the /var/log/open2/events.log

I’m using Zulu Embedded

Any idea guys?

As DIM said it seems to work only with OH 2.4 M6.

Hi Don,

thanks for your answer.
I changed my environment to the testing channel and got version

cleared the cache but still the same issue.

I had a look here

They wrote Get 2.4.0 Milestone 6 from here: [JFrog.io](https://openhab.jfrog.io/openhab/libs-milestone-local/org/openhab/distro/openhab/2.4.0.M6/) (or the testing repo)

but it wasn’t a m version for me.

How can I get the m version? :thinking:



This is the latest Snapshot Build, so you can’t get any better/newer than this :slight_smile:

let me see how we can debug this

1 Like

first of all, let’s see which version of the binding is being loaded

Use the openhab console and:

bundle:list -s |grep -i homematic

That’s the output
192 │ Active │ 80 │ │ org.eclipse.smarthome.binding.homematic

1 Like