Homematic IP window contact state doesn't update

  • Platform information:

    • Hardware: Raspberry Pi 4 4GB RAM
    • OS: openHABian 3.0
    • Java Runtime Environment: “11.0.9” 2020-10-20 LTS
    • openHAB version: 3.0
  • Issue of the topic: Homematic IP window contact state (open/close) doesn’t update to openHAB

The updated Data reaches the CCU3 but isn’t forwarded to openHAB.
On the other Hand it works properly with the radiator control.

I don’t think this is related, but I found that this error is coming up every 30 seconds:
2020-12-30 15:35:52.097 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler HomematicBridgeHandler of thing homematic:bridge:4b781f66c6 tried updating channel DUTY_CYCLE_RATIO although the handler was already disposed.

Thanks for your help!

I don’t think this is related, but I found that this error is coming up every 30 seconds:

This message means that there is a problem with the binding (maybe a connection problem). And maybe this causes the problem.

Before continuing please make sure that all necessary ports are open in the firewall on the CCU and also on your Raspberry (here especially ports 9125, 9126).

If there ports seem to be OK. Please enable the TRACE log mode for the Homematic binding, restart openHAB, wait until the binding is completely started, open/close the window. Then please post the openhab.log file here.

1 Like

I’m not sure how to open ports on the Raspberry however I think I TRACEd the homematic binding but as a new user I can’t upload the log and it is 20000 lines log so I think I must have logged too much. After rebooting the error message didn’t show up anymore.

By the way thanks for your very quick response! :+1:

You can send the log to my mail address: develop@mherbst.de. The number seems to be OK.

I’m not sure how to open ports on the Raspberry

I don’t use openHABian on my Raspi, where I have disabled the firewall. So I don’t know how it exactly works with openHABion (probably iptables of ufw).

By the way thanks for your very quick response!

You are welcome. I am currently working on some improvements in the Homematic binding. Therefore I am just in the topic :-).

1 Like

Thank you,
I’ve sent the log.

I can see that the binding receives from the CCU. Firewall should not be the problem.

Which device is causing the problem? I can see events from several devices.

Can you also send a hardcopy of the thing’s channel definitions. I would like to see what channel types are derived.

1 Like

All of the window / door contacts or sensor are causing the problem.
I don’t know where to find the “hardcopy” channel definitions, but here is the code from the PaperUI definition of one of the windows:

    UID: homematic:HmIP-SWDM:28f0beb247:001558A9A7FC7B
    label: Fenster Gästeklo
    thingTypeUID: homematic:HmIP-SWDM
    HMP_0_LOW_BAT_LIMIT: 2.2
    bridgeUID: homematic:bridge:4b781f66c6
    location: Gästeklo

I can see an event for this device in the log but no further information. Maybe there is problem with the item definition.

So I need some more information.

How did you define the items? If you used a text file, please send me the file. If you did in the Main UI please perform the following step:

  • Open Settings / Things
  • Select the device
  • In the following window select the “Channels” tab
  • For channel “State” click on the triangle on the right side to make the connect item visible
  • Create a screenshot

It should look similar to this one:

1 Like

Oh yes now I see!

OK, I see the problem. The channel is defined as “String” but it should be of type “Contact” like in my screenshot from a different device.

Looks like a bug in the binding. Will take a closer look.

1 Like

Ok, thank you very much! That’s really kind of you! :+1: :smile:

I t looks like I have the same problem with a Homematic window contact, while “Actual Temperature” and “Set Point Temperature” of radiator thermostat are working properly in the UI (OH 3)

@MHerbst dear Sir, how can I change channel from “String” to “Contact” using the UI ?

Using only CCU3, everything is working properly, but I would like to add some rule for example light ON when a window is open etc…

1 Like

@alamak You can’t simply change the channel type. Homematic uses for the HmIP versions of this device a different data point type than for older devices. This type is currently not supported in the binding and the implementation is not so easy. But it is on my “todo” list.

As a bypass, you could create an additional item of type “contact” that is not bound to a channel and then use a script the maps the values received from the “String” contact to the contact item.

1 Like

It is really strang that the item state is not updated. Maybe a trace can help to figure out what’s going wrong.

Please perform the following steps:

  • in the Karaf console enter log:set TRACE org.openhab.binding.homematic to enable TRACE log mode
  • open close a window

Attach the excerpt from openhab starting from the enablement of the TRACE log.

1 Like

When I open and close a window (the SRH in this instance), this is what openhab receives:

2021-02-09 18:30:06.695 [DEBUG] [ommunicator.AbstractHomematicGateway] - Received new (Integer) value ‘2’ for ‘0007DA49A8BB16:1#STATE’ from gateway with id ‘4b781f66c6’
2021-02-09 18:30:09.386 [DEBUG] [ommunicator.AbstractHomematicGateway] - Received new (Integer) value ‘4’ for ‘00201A499D8A04:1#VALVE_STATE’ from gateway with id ‘4b781f66c6’
2021-02-09 18:30:09.392 [DEBUG] [ommunicator.AbstractHomematicGateway] - Received new (Integer) value ‘1’ for ‘00201A499D8A04:1#WINDOW_STATE’ from gateway with id ‘4b781f66c6’

If you want I can send you the whole log via Email, but I can’t post it here, because its too big.

Yes, please zip it and send by mail. Before you create it, please change the log setting to TRACE and repeat the steps. DEBUG mode seems not to be sufficient.

1 Like

I thought I set it to TRACE already, but now it is on TRACE and I send you the .log via Email.
Thanks for your help! :grinning: :+1:


I have the same issue with all my contact-devices. Should I also prepare a openhab.log? Or do you allready have enough information?

Best regards

today I checked my inbox and under ignored there were all of the Homematic a second time. I tried them and it works perfectly now. I don’t know for how log they have been there.
Thank you very much for your help, I’m sorry I didn’t see them sooner.
Best regards

I am on 3.1.0-SNAPSHOT - Build #2198 but facing still the same problem, and I dont see any (double) items under “show ignored”. So, unfortunately not working for me.