Homeseer Floodlight HS-FLS100-G2 - missing parameter 5?

Running openhabian on pi4, openHAB 3.2.0.M3

I am trying to configure the Homeseer Floodlight HS-FLS100-G2 light to only react to z-wave control (i.e. do not auto turn on the light due to motion / lux conditions.

I believe parameter 5 controls this feature but it doesn’t appear to be configurable in the binding:

According to the current binding parameter settings, parameter 2 can disable the light from auto control. I dont believe this is the same for this version of the device. When I set this param to zero, it gets reset back to 50 and doesn’t work as described.

Here’s a link to the manual for this device:

Here’s a thread on the initial missing device that was added:

@chris, can you take a look?

It looks like we need to create a new device for this in the database since this version has more parameters than the older one which (according to the doc attached to the database) only has 4 parameters.

If you provide the XML that OH created for your device, I’ll create the initial entry and copy over the old parameters - it would then be appreciated if you can take a look over the new entry to make sure everything is correct, and add the new parameters?

Sounds great Chris, thank you!

Here are both devices (same type) I have (just in case there is something different):

network_efb6781f__node_4.xml (12.9 KB)

network_efb6781f__node_2.xml (12.8 KB)

I’ve created the device -:

Please can you take a look over this and update anything that needs updating for the newer device. If you don’t have an account, please create one and let me know your user id so I can give you edit access.

Ok I’ve registered as JamesR

Thanks - you should have access now.

Hi Chris - I’ve been out of service for a bit :slight_smile: … curious if you’ve had a chance to add this new device? I made the updates to database (a while back). Thanks!

From the status it looks like it was approved and should be in the snapshot.

1 Like

Thanks Chris … yes 'm running 3.2.0.M4 and it appears that the new device is now there, however, I’m having issues:

  1. The first time I deleted the old device and then went through the inclusion process the device was recognized and the correct Device name showed up etc. … So I thought things were good. I tried to change the parameters that allows only Zwave control (overrides local PIR/Luminance triggers) … but when I hit save, the parameter stayed in the pending state.

  2. So, after a few failed tries, I decided to delete it and try the process again. The second time, the device is no longer recognized and I get the following debug log after a “Scan”: (Node 2 is the new device, Node 4 is the another device of the same type but I haven’t deleted it yet so it is still coming up as the old device type)

2021-12-01 16:13:39.229 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 16: Device discovery completed
2021-12-01 16:13:39.236 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 16: Device discovery resolved to thingType zwave:kwikset_smartcode888_00_000
2021-12-01 16:13:39.243 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery completed
2021-12-01 16:13:39.250 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! Manufacturer data not known.
2021-12-01 16:13:39.254 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 4: Device discovery completed
2021-12-01 16:13:39.258 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 4: Device discovery resolved to thingType zwave:homeseer_hsfls100g2_00_000
2021-12-01 16:13:39.262 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 6: Device discovery completed
2021-12-01 16:13:39.265 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 6: Device discovery resolved to thingType zwave:elexa_dms01_00_000
2021-12-01 16:13:39.268 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 8: Device discovery completed
2021-12-01 16:13:39.270 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 8: Device discovery resolved to thingType zwave:kwikset_914trl_00_000
2021-12-01 16:13:39.272 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 9: Device discovery completed
2021-12-01 16:13:39.274 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 9: Device discovery resolved to thingType zwave:honeywell_39351_00_000
2021-12-01 16:13:39.277 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 10: Device discovery completed
2021-12-01 16:13:39.280 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 10: Device discovery resolved to thingType zwave:rtc_ct101_00_000
2021-12-01 16:13:39.284 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 13: Device discovery completed
2021-12-01 16:13:39.286 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 13: Device discovery resolved to thingType zwave:zooz_zse40_00_000
2021-12-01 16:13:39.289 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 14: Device discovery completed
2021-12-01 16:13:39.293 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 14: Device discovery resolved to thingType zwave:kwikset_smartcode888_00_000
2021-12-01 16:13:39.296 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 15: Device discovery completed
2021-12-01 16:13:39.299 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 15: Device discovery resolved to thingType zwave:kwikset_smartcode888_00_000

Not sure why the first time it recognized the new device type but now it won’t … I wanted to gather the Debug for the parameter setting issue but I can’t get the device added yet :frowning:

Any ideas of what I can try to get back to the point where the Parameter Set is not completing? (Then I can get the debug log for that case)