[ZWave Unknown Device] Homeseer Floodlight HS-FLS100-G2

I just purchased this Homeseer Floodlight new model: HS-FLS100-G2
It’s showing as unknown device, maybe not supported since it’s a newer model?

Log shows following warning:
14:22:53.454 [WARN ] [zwave.discovery.ZWaveDiscoveryService] - NODE 39: Device discovery could not resolve to a thingType! 000C:0201:000C::1.0

Openhab v2.5.11

HS-FLS100-G2 Manual:

1 Like

We have that model in our database but not that exact variant. I can add it and , after the next database export, you can install a snapshot version of the binding with the updated database.

Yes please, am happy to try when ready. Let me know

@Bruce_Osborne I haven’t done separate updates to the binding before. Would you share the URL where I can download the snapshot please? I can search online for steps on how to do the update, am sure it’s been asked by others.
Thanks in advance, good night!

1 Like

@Bruce_Osborne looks like I can use this script to perform the update?

That script should work after the export happens. It is usually exported about once a week and is a manual process. The script has been testes more with OH2 than OH3.

Just a wild guess but I think a snapshot generated on January 16 should have the changes. I know the current one does not.

EDIT: somebody posted it does not work directly for OH3. The manual installation instructions in the README should still work though.

1 Like

I downloaded the script in the addons folder and changed the owner and group to openhab:

I get following error when running the script. I ran it with openhab stopped and with it running, same error:

For reference, I am running openhab 2.5.11 release build

I do not know. I did not write the script. Perhaps try asking in the script thread.

I used the command mentioned in this comment:

Keep in mind that you need to ssh into openhab, in my case:

ssh -p 8101 openhab@localhost

update command:

bundle:update org.openhab.binding.zwave [SNAPSHOT URL HERE]

I grabbed the snapshot url from here:


for example, below is the update command that I used with the latest snapshot url:

bundle:update org.openhab.binding.zwave https://ci.openhab.org/job/openHAB2.5.x-ZWave/99/artifact/target/org.openhab.binding.zwave-2.5.12-SNAPSHOT.jar

I ran the following command to check the zwave binding version:

bundle:list | grep ZWave

it returned the updated zwave binding version:

289 │ Active │  80 │     │ openHAB Add-ons :: Bundles :: ZWave Binding

Thanks to Luis for posting the original post on this device … I am a total OpenHab novice running
the openHAB 3.0.1 Release Build … I just bought a few of these unsupported HomeSeer Floodlights and am just beginning to play around with OpenHab … (I’m on a track to replaces my SmartThings with OH and just trying to learn at this point)

Question: Can anyone say when this device will be rolled out in a 3.0 build?

It would only be in a 3.0 build if there is a 3.0.2 which is unlikely since 3.1.0M3 was recently released. That is why I recommend a snapshot version of the binding.

1 Like

Hi Bruce - I have attempted to install a snapshot of the zwave binding following the manual install sequence in the readme … I almost understand what I am doing. I have tried both manually adding the jar file to the addons directory (and changing the ownership to openhab) … and also just using the bundle:update method mentioned by Luis that was successful for him. Anyway, I am unsuccessful installing it (and now have no zwave binding at all) … I am getting the error:

Error executing command: Error executing command on bundles:
Error starting bundle 288: Could not resolve module: org.openhab.binding.zwave [288]
Unresolved requirement: Import-Package: org.osgi.framework; version="[1.9.0,2.0.0)"

I assume this isn’t working for me because I am on OH3 and there must be something else I need to do. Any ideas would be appreciated.

FYI, I am using

Are you on 3.1.0 Milestone 3? I think I saw someone else reporting something similar with that version.

No. I am running 3.0.1 … after waiting a bit :slight_smile: the 3.0.1 zwave binding came back. Here is what I have:

288 │ Installed │  80 │      │ openHAB Add-ons :: Bundles :: ZWave Binding
289 │ Active    │  80 │ 3.0.1                   │ openHAB Add-ons :: Bundles :: ZWave Binding

Attempting to bundle:start 288 will yield the Unresolved requirement error.

You need to stop & uninstall the 3.0.1 binding.

Well yes, I have done this multiple times … here’s what happens:

bundle:stop 289 ... it changes to resolving
bundle:uninstall 289 .... 3.0.1 disappears
bundle:start 288 ... get the Unresolved requirement

then I tried:
bundle:update org.openhab.binding.zwave https://ci.openhab.org/job/openHAB-ZWave/52/artifact/target/org.openhab.binding.zwave-3.1.0-SNAPSHOT.jar

But the bundles remain the same (i.e. no change)
288 │ Installed │ 80 │ │ openHAB Add-ons :: Bundles :: ZWave Binding

The jar files are still in the addons directory (not sure if that matters)

Not making much progress :frowning: (but I’m not giving up either :slight_smile: )

Any ideas @chris ?

bump … still not making any progress …

OH 3.1.0 SNAPAHOTs are no longer compatible with 3.0.x. 3/0.2 was just released but it has a database dated back to last December when 3.0.0 was released.

Apparently there is a separate GitHub branch for 3.0.x and the database in the binding source there has been updated. I do not know when the next 3.0.x binding will be built.

1 Like

Thanks Bruce - I updated to 3.0.2 … are you saying there is a snapshot I can get for the 3.0.x branch that does have the updated binding?