How I got the Razberry 2 to work on a Raspberry 3 b+

First of all, I’m a complete beginner when it comes to home automation and openHAB. As a result, getting the z-wave binding to work took me a lot of hours with trial, error and an unhealthy blood preasure!

There is a lot of different tips and tricks around, but the one that worked for me at was pretty straight forward.

  1. follow the Quick Start instructions on https://www.openhab.org/docs/installation/openhabian.html
  2. when openhabian is up and running, connect to the raspberry pi via ssh. On Mac and Linux, you can use the terminal, on windows, I prefer Putty.
  3. Username: openhabian, password, openhabian (worked for me at least)
  4. run “sudo openhabian-config” (the sudo password is openhabian)
  5. choose system settings, serial port, check all 3 items and choose ok
  6. open the /boot/cmdline.txt file as sudo with your favourite editor and remove “console=tty1”. In other answers, it said to remove “console=serial0,115200”. If you have something else after “console=”, it shouldn’t matter, just remove it, that’s what I did at least. If in doubt, take a backup of the /boot/cmdline.txt file
  7. open the /boot/config.txt as sudo and change the line “dtoverlay=pi3-miniuart-bt” to “dtoverlay=pi3-disable-bt”
  8. reboot by typing “sudo reboot”

If you don’t know how to set up openHAB, this guy will explain you https://www.youtube.com/watch?v=R2T5Mg3RLq0.

The serial port under the port configurator section was /dev/ttyAMA0 on my device.

Good luck and enjoy!

7 Likes

Thank you for this! This was what I needed for connecting Razberry to my Openhabian on Rpi4!
One minor change since 2019: in /boot/config.txt I changed dtoverlay=miniuart-bt to dtoverlay=disable-bt