How-to Article on MakeUseOf

Tags: #<Tag:0x00007f832e6929f0> #<Tag:0x00007f832e692798> #<Tag:0x00007f832e692630>

Here is a nice how-to article on setting up openHAB on the Raspberry Pi:

MakeUseOf Article

actually more than “nice”, verging into “excellent”

Very good beginners guide! Would have made my OpenHAB baptism of fire a lot easier :grinning:

I have been following this guide, but cannot get samba to work. I have Google other tutorials as well, still not working. Tried to view on network on both win7 and win8 machines. I can ping the pi, and it repsonds, also can ssh via putty, but it doesn’t show up in my network. Any ideas?

You know…just thinking a bit…I started with a noobs install, which I don’t believe he did as I could not apt-get the openhab runtime, had to curl it. Does this have anything to do with why I can’t get samba to work?

@Branden_Smale — I just reviewed your posts and am willing to help. It is not clear from your searchable posts exactly where you are in this journey.

So, let’s do “horsey,doggie,ducky” basics here.

Are you using a Raspberry Pi 2 ? (the “2” is important if a Raspberry Pi) ?

If so are you using Raspian OS package ?

What is your technical skill level ? e.g. can you program in any language ? if so which one(s) ? (This is just to assess how to frame my answers…NOT an “if you haven’t programmed you are not worth my time” response)

What is it you are trying to accomplish via Openhab ? If you are just “playing”, that is fine. We all started that way, more or less. If you have a focused objective, probably better but not necessarily so ( you may be “solving the wrong problem”)

Bob

I appreciate your willingness to help. I am using a pi2. I have learned enough to get by in app inventor, but that’s all the programming knowledge I have. I have uses, not just playing.

1st pi…utilize it as a media control for my home theater, as well as future home automation.

2nd pi…a zwave interface.

Oh, and yes, raspbian via noobs

keeping with the “clarify rather than assuming” approach…you mention 2 Rpi’s. are either of them fully-operational OR is this just your goal ?

Neither is fully functional. I just got openhab and habmin I stalled on one of them, but still having issues getting the zstick to be recognized. I used the tutorial on instructibles to get evert hinges up and running. I’ve been here before, which is why I tried a different install tutorial.

Are you familiar with the zwave and aeon z stick set up?

If so, I have configured the binding using /dev/ttyACM0. Also added the user (pi) to dialout, sudo add user pi dialout.

I still cannot see the node in habmin. This was the issue I started my first post with, not this one, obviously…

I just don’t understand how it is that so many others don’t have issues, but apparently I am.

Just to clarify…both pi will use the z stick, but be at different houses.

One, I would like to control my hvac with, using dz, but they currently don’t integrate with oh. It will also have zwave, and rs232.

The other will have zwave and sonos.

It is my intention just to get one working, then I’ll know what to do with the other, hopefully…

I did lsusb and saw the stick as sigma

I did dmesg, but didn’t see the stick there, at least I dint see a manual tureen name, but did for my wireless keyboard and WiFi dongle. Definitely didn’t see a port. I’ve tried ACM0 and USB both in the binding, but it does not shoe up.

The add user to dialout says to add user openhab. I tried that but it said there is no user openhab. Is openhab supposed to be a user?

you should see it in dmesg output.

mine says:

cdc_acm 1-1.4:1.0: This device cannot do calls on its own. It is not a modem
cdc_acm 1-1.4:1.0:TTYACM0: USB ACM device
usbcore: registered new interface driver usb_acm
cdc_acm USB Abstract Control Model driver for usb modems and ISDN adapters

I’ll check mine again and let you know

I may have found the issue. I found a post about the openhab user. Says using wget the openhab user is added. I couldn’t use the wget, had to curl, and when I tried to add the openhab user to dialout, it said there was no user openhab so I figured I had to add the standard user (pi) in my case. Apparently I have to add the user openhab.

I’ll try this and see if it works.

Any idea why I can’t wget the openhab runtime?

Ok, so I did as follows

watou
Aug 21
I use a straight Raspian image, latest, and then applied these steps8 to boot/run from external disk. I created an openhab user with sudo adduser openhab (openHAB install might do this anyway). I added the openhab user to the dialout group so it could access the USB Z-Stick with sudo usermod openhab -a -G dialout. I installed openHAB using apt-get method here6. Installed addons using same apt-get method. Changed logging to events.log to WARN to stop that log from …

At least to add the user and allow to dialout.

My dmesg did have it. In habmin, under zwave bindings, set as /dev/ttyACM0, healtime 2.

Still not showing up as a node.

When I added the user, I entered a password to match, maybe I shouldn’t have a password? Do I need to change security settings?

I’ve not followed the whole thread here so apologies if I’m telling you what you already know…

It seems that you’re focussing on the port not opening. What I don’t see anywhere is anything from the logs that show what errors you’re getting - just that you’re not seeing anything in HABmin. If the port isn’t being opened, then you’ll get an error in the log - you should check there. You should also run the logging in DEBUG mode - at least until things are up and running - logging is really your best friend here :smile:

You also seem to be unsure about the port name? to find the port name, simply type ls /dev/tty* - do this with and without the stick plugged in and see what changes.

Ok, I’ll try it. Also, I’ve seen about using symlinks, but the documentation is not clear as to how and where to actually write the link. Can you help me in the right direction with this?

So since I really have no clue…

I will start openhab in debug mode, what do I need to be looking for exactly and when?

It might pay to quote text when replying so that we know what you have no clue about and can help :smile:

When the binding starts, it prints messages about opening the COM port - it will give an error if it can’t open the port - the error will say why it can’t be opened… People will help if you post logs here, but the logs are one of the best ways to find out what’s wrong…

Chris

Ok. Should I remove the password created for the user openhab, as well as give it permissions to the openhab folders? I created the user openhab and it asked for a password so I gave it one, though now that I’ve done a little bit of searching the web, I have found that I didn’t have to give it one. Also , I have not given the user open hab any permissions to any particular folders, ie /opt/openhab.

I must say, the tutorials but adding user openhab really should be more specific about this. I know this is a community of people that share, but how can the community grow if people aren’t willing to help others get started without a little hand holding? This isn’t the only community I’ve found this behavior on, other open source communities as well are like this. I think that once people spend time hashing out the problems, they figure others should have trial by fire too.

Not saying anything negative about anyone helping me here, just the general tutorials I’ve found leave a little to be desired, and a whole lot to be figured out on one’s own. I feel like this is more discouraging than helping…

Thank you for your help so far. I will run the debug in a little bit and hopefully have a better idea of what’s happening.

you’ll definitely have to give whatever the user running openhab is permissions to /opt/openhab et al.

(I have the t-shirt on this one)