How to configure a thermostat for the Alexa OpenHAB skill?

Hello,

I am trying to configure my thermostats to be able to control the heating via Alexa. So far I was able to configure lights and rollershutters like written in the docs, but I am not able to get a thermostat controllable in the Alexa app.

I stripped it down to the easiest possible configuration without any connected channels. Alexa app finds a thermostat but is not controllable at all.

So my first question is: should the following configuration basically work?

Group                Thermostat     "Thermostat"                                   {alexa="Thermostat"}
Number:Temperature   Temperature    "Temperature [%.1f %unit%]"     (Thermostat)   {alexa="CurrentTemperature"}
Number:Temperature   HeatSetpoint   "Heat Setpoint [%.5f %unit%]"   (Thermostat)   {alexa="HeatingSetpoint"}

Thanks for any help,
Karsten

This works for me:

Number ALX_DiningroomSystemMode "Esszimmerheizung" (gAlexaThermostatMode) {alexa="ThermostatController.thermostatMode" [OFF=0,AUTO=1,ECO=11,HEAT=15]}
Number ALX_DiningroomHeatingSetpoint "Esszimmertemperatur" (gAlexaThermostatTemp) {alexa="ThermostatController.targetSetpoint"}

Here the link to the different Thermostat properties of the Alexa Service:

1 Like

And there’s also a helpful thread here

Thank you very much for pointing me into this direction. The ThermostatController and the TemperatureSensor interfaces did the trick. This is working fine for me:

Group                Thermostat     "Thermostat"                                   {alexa="Thermostat"}
Number:Temperature   Temperature    "Temperature [%.1f %unit%]"     (Thermostat)   {alexa="TemperatureSensor.temperature"}
Number:Temperature   HeatSetpoint   "Heat Setpoint [%.5f %unit%]"   (Thermostat)   {alexa="ThermostatController.targetSetpoint"}

But this documentation seems to be outdated then, does it?

It is the other way round. The solution that @JensD provided is using outdated syntax (although still backward compatible).

You should use the new syntax:

Group                Thermostat     "Thermostat"                                   {alexa="Thermostat"}
Number:Temperature   Temperature    "Temperature [%.1f %unit%]"     (Thermostat)   {alexa="CurrentTemperature"}
Number:Temperature   HeatSetpoint   "Heat Setpoint [%.5f %unit%]"   (Thermostat)   {alexa="TargetTemperature"}

I use the UI to configure my OH3.3 and I got this:

The main Group-item is a “Equipment” and is configured as “Thermostat” with Alexa, the corresponding items for TargetTemperature, Mode and CurrentTemperature are listed:

But still, my Alexa App tells my “device does not respond”?

What did I miss here?

The configuration looks good assuming you defined your Thermostat supported mode properly.

Have you gone through the troubleshooting guide?

It might also be related to:

1 Like

thanks, I didn’t check the HVAC mode-settings after moving my installation. HVAC mode was NULL!