How to configure the Nortek HUSBZB-1 Zigbee/Zwave radio on OH 3?

I am coming from the previous OpenHab version in which the Nortek HUSBZb-1 radio worked well, after manual configuration using this script :

Has anyone tried this yet with the new OpenHAB 3 ? Is there a particular, easier way to use this radio ? The documentation doesn’t seem to be updated and still mention config tweaks which aren’t needed anymore (like adding the openhabian user to different groups).

Before digging into this I thought I’d ask, thanks in advance.

Why do a manual install of the binding?

I have both the Z-Wave controller & the Zigbee Coordinator recognized in my OH3 test machine just installing the bindings through the UI.

Where is that? AFAIK the official docs are up to date,

I have used this stick with Z-Wave on & off for almost 2 years and never needed a manually installed binding to get the stick recognized.

I’ve never been able to install it directly using only the GUI. Can you provide step-by-step instructions ? Some guides indicate the serial binding is needed first.

I am looking at ZigBee - Bindings | openHAB which says :
“If you are running on Linux, then you probably need to add the user ‘openhab’ to the tty group” - this isn’t the case anymore.

The same document includes information on configuring the Nortek using 57600bps, Software flow control, High RAM - but the newer UI will only let you add one coordintator using one serial port… In previous versions I was able to add one for Zigbee, one for Zwave.

It also refers to the Linux install guide which includes other group change commands which aren’t explained and aren’t relevant or useful either.

It’s just pretty confusing so if anyone has done this from scratch I would appreciate a simple walk-through, I am willing to proof-read this and submit revisions to the current documentation so it’s simpler for new users.

Do I assume you are running OH on Linux?
What distribution?
What hardware?

Sorry for not including this initially - OpenHabian, rPi4.

OK, this is on a Pi 3B+ running OH in Docker but that should not matter. I started with a fresh install for this, with the bindings installed. My stick is on /dev/ttyUSB0 and /dev/ttyUSB1 The devices on a Pi 4 may be different.

Z-Wave
Settings -> Things -> + (lower left) -> Z-Wave Binding->Z-Wave Serial Controller

Serial Port: /dev/ttyUSB0 -> Create Thing

I usually then monitor events.log to see when things settle down.

Zigbee

For reference I use the following from the binding documentation.

Settings -> Things -> + (lower left) -> ZigBee Binding ->Ember EM35x Coordinator

Port /dev/ttyUSB1
Flow Control: Software (XOn / XOff)
Baud Rate: 57600
Everything else left at default.
Create Thing

Again, monitor events.log

1 Like

Thank you, this worked. I was making three mistakes before :

  • adding the serial binding (not needed anymore)
  • using tty0 for Zigbee
  • not using ZWave - I’ll have to try this again from scratch but it seems I need to install both so Zigbee is enabled.

Both now appear online. How can I force a scan to add new Zigbee devices ? The documentation still mentions “Discovery is performed by putting the binding into join mode (by starting an inbox search)” which I can’t seem to find or is outdated.

Thanks in advance for any guidance.

Z-Wave should not be required for Zigbee. I can test that if you wish. I have used Z-Wave without Zigbee installed with OH2.

I assume Settings -> Thing -> + (lower right) ->[select binding]-> Scan

Thanks a lot, this helped me scan a few devices. The (+) is on the right, though. Now on to discover the interface and rules creation.

I’ll just add about the HUSBZB-1:

  • I confirm Software flow control and 57600 baud worked.
  • If if doesn’t work the first time, remove the binding, restart OH3 (frees up ttyUSB1 if something went wrong). No matter how many times I checked the settings after getting them wrong the first time, I had to reinstall the binding to get the green “ONLINE”
  • that I had to check the “advanced” settings and at the bottom set the “Concentrator Type” to “High RAM”

Hello everyone,
Sorry to resurrect an old thread, but my HUSBZB-1 Zigbee coordinator stopped working today and is showing an ERROR: COMM message which causes the coordiantor to stay OFFLINE and as such all other Zigbee devices are non usable.
I didn’t do any changes in the coordinator settings and they are set to the recommended settings:
Ember Coordinator
Port: /dev/ttyUSB1
Flow Control: Software (XOn/XOff)
Baud Rate: 57600
Power Mode: Boost
Transmit Power: Normal
Child Aging Timeout: 4 Weeks
Network Size: Medium
Concentrator Type: High RAM

I tried to restart the OpenHAB docker app and then the whole computer, but it didn’t help.
I also tried removing and reinstalling the Zigbee binding, but that didn’t help either.

The onboard HUSBZB-1 Zwave controller located on Port: /dev/ttyUSB0 is working fine, so I assume it’s not a device malfunction.

Here are some errors info from the openhab.log file.

2022-10-01 15:13:38.078 [ERROR] [nding.zigbee.serial.ZigBeeSerialPort] - Serial Error: Port [/dev/ttyUSB1] does not exist.
2022-10-01 15:13:38.079 [ERROR] [zigbee.dongle.ember.ZigBeeDongleEzsp] - EZSP Dongle: Unable to open serial port
2022-10-01 15:13:39.081 [INFO ] [bee.handler.ZigBeeCoordinatorHandler] - ZigBee dongle inactivity timer. Reinitializing ZigBee
2022-10-01 15:13:40.264 [ERROR] [nding.zigbee.serial.ZigBeeSerialPort] - Serial Error: Port [/dev/ttyUSB1] does not exist.
2022-10-01 15:13:40.265 [ERROR] [zigbee.dongle.ember.ZigBeeDongleEzsp] - EZSP Dongle: Unable to open serial port

Hope someone can help solve this.

what is the version of openHAB?

You can try

dmesg | grep USB

in a command shell to find out which USB ports are connected to the device

Stable 3.3.0

Thank you.