How to enable 1-wire interface

Hello all,

I wanted to prepare aquarium controller with using Raspberry Pi 0.
To made it simpler i decided to install Openhabian.
The first problem I facing is temperature sensor on 1-wire interface, could you please help me to enable this interface?
I made it on a Raspbian with using software configuration tool:

I can’t find such option on Openhabian.

Then temperature can be read in file
cat /sys/bus/w1/devices/XXX/w1_slave

For now there is no w1 folder in bus folder.



What interface to the 1-wire devices do you use?

Sorry I am very very beginner in this and think I don’t understand your question…
I attached this temperature sensor (DS18B20) according to below instruction (sorry but instruction is in Polish):

Cześć Damian,
What you need to follow is owserver instructions on how to plug 1wire bus connected via GPIO. openHAB integration initializes network connection to owserver thus it does not read sensors directly.

You need to enable it with raspi-config.

1 Like

Installing OpenHABian removes raspi-config. Perhaps there is a menu option in openhabian-config. I cannot check now.

Menu Option 28 is about 1wire …

I checked menu option 28 and unfortunately i got an answer:

Paging @mstormi.

I have an idea, during openhabian installation with using Etcher I met a problem like on the picture:

I thought that I can forget about that because openhabian started and looks like everything was ok but maybe wasn’t…
I tried to reinstall it but still the same problem in Etcher appears…
What do you think, can it be connected?

After installing OH did you update the openhabian config tool and run apply needed packages, fix permission, and svr mounts?