How to stop: Feature named 'openhab-ui-dashboard/0' is not installed in openhab.log

I turn on debugging for other reasons and found the following error that happen every minutes. What can i do to stop it? or does it not matter? I search for other threads and do not see any way to stop. thanks.

2020-01-11 17:55:30.449 [DEBUG] [core.karaf.internal.FeatureInstaller] - Running scheduled sync job
2020-01-11 17:55:30.452 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is not installed

It’s a debug level log. If it were something you couldn’t just ignore it would be a warn or error level log statement. So if say it doesn’t matter, unless you are experiencing some problem that seems related.

I posted about it here in another thread after upgrading to 2.5.

It may be coincidence but when it occurs (it came back after a restart), HABpanel appears very unresponsive to the point of being almost unusable.

Restarting openHAB (after stopping and clearing caches) gives a different start up result every time. Sometimes all the ‘items’ in HABpanel become un-linked to their openHAB items. Sometimes the UIs do not appear in the dashboard.

I will ignore it for now, but this is a brand new install. I started using OH last week.

In the link above you posted that you deleted the addons.cfg file. Did you delete the file or the contents inside the file?

I ask because /var/lib/openhab2/config/org/openhab/addons.config contains the parameters that we set in /etc/openhab2/services/addons.cfg (this file is parsed, and entered in ConfigAdmin with config pid: org.openhab.addons ).

Even if everything is commented out in the addons.cfg you still need that file. You may want to consider a fresh install if recreating the file (and adding back all the commented out stuff) does not work.

I deleted the addons.config file - the whole file (not the addons.cfg file). This was a recommendation from more knowledgeable people on this forum as a possible fix for this error. The addons.cfg file gets auto-generated from the data in the addons.cfg file.

Didn’t work for me. I still get the error.

I did that a week ago - it took ages - not sure I want to do it again.
The error reappeared when I did a restart a couple of days ago.
I don’t have a special setup and as lots of other people seem to have the same problem, it’s not unique to me.

I have not seen that. I see people wondering about the dashboard stopped message after their initial configuration. That is normal.
The only similar issue is the 2.5 bug that if you install the addons package before running the initial web setup, the initial dashboard gets uninstalled and you get a web page error.
Neither one is an error repeated in the logs.

It’s at least three and possibly more as there aren’t too many “me too!” posts on the forum.

Post the contents of /var/lib/openhab2/config/org/openhab/addons.config and maybe we can see if there is somehting odd or recommend a different setting to try.

addons.cfg (verbose, just in case)

# The base installation package of this openHAB instance
# Note: This is only regarded at the VERY FIRST START of openHAB
# Optional. If not set, the dashboard (https://<yourserver>:8080/) will ask you to choose a package.
# Valid options:
#   - minimal  : Installation only with dashboard, but no UIs or other addons
#   - simple   : Setup for using openHAB purely through UIs - you need to expect MANY constraints in functionality!
#   - standard : Default setup for normal users, best for textual setup
#   - expert   : Setup for expert users, especially for people migrating from openHAB 1.x
#   - demo     : A demo setup which includes UIs, a few bindings, config files etc.
package = standard

# Access Remote Add-on Repositories
# Defines whether the remote openHAB add-on repository should be used for browsing and installing add-ons.
# This not only makes latest snapshots of add-ons available, it is also required for the installation of
# any legacy 1.x add-on and all experimental features. (default is false for offline distro, true for online distro)
remote = true

# Include legacy 1.x bindings. If set to true, it also allows the installation of 1.x bindings for which there is 
# already a 2.x version available (requires remote repo access, see above). (default is false)
legacy = true

# A comma-separated list of bindings to install (e.g. "sonos,knx,zwave")
binding = mqtt1,kodi,homematic,astro,rfxcom,hue,wifiled,mihome,miio,nest,lgwebos,amazonechocontrol,mail,expire1

# A comma-separated list of UIs to install (e.g. "basic,paper")
ui = paper,habmin,restdocs,classic,homebuilder,basic,habpanel

# A comma-separated list of persistence services to install (e.g. "rrd4j,jpa")
persistence = influxdb,rrd4j,mapdb

# A comma-separated list of actions to install (e.g. "mail,pushover")
#action = mail,pushover,mqtt1
action = pushover

# A comma-separated list of transformation services to install (e.g. "map,jsonpath")
transformation = map,jsonpath

# A comma-separated list of voice services to install (e.g. "marytts,freetts")
#voice = 

# A comma-separated list of miscellaneous services to install (e.g. "myopenhab")
misc = hueemulation,openhabcloud,gcal1



Any help much appreciated!

Stop OH, edit the first line and change L"1" to L"14" then clean cache and reboot.

What does that line do? I have seen that mentioned a few times as resolving issues.

I’ve ask the same question. :upside_down_face:

1 Like

That made no difference to the log file messages but did additionally stop the items from loading so HABpanel did not work at all.

I did a fresh install. All OK. I then added my backup conf and userdata folders and the problem re-appeared. I suppose I could repeat the exercise with a commented-out addons.cfg folder but I really didn’t want to install and configure all the bindings again as I did that last week.

Not sure what else to try.

So the problem seems to be in ^^ configuration. Below is the changes to OH version 2.5 I would remove any of the bindings you have in the list below then once OH is working reinstall them.

Legacy Add-ons

The following openHAB 1.x add-ons have been replaced by openHAB 2.x add-ons and are now part of the legacy add-ons:

  • Denon Binding
  • IHC Binding
  • KM200 Binding
  • Mail Action
  • Neohub Binding
  • Network UPS Tools Binding
  • Pushbullet Action
  • SNMP Binding
  • XMPP Action

To continue using legacy add-ons, enable “Include Legacy 1.x Bindings” in the UI system configuration.
When using file based configuration add legacy = true to addons.cfg .

Discontinued Add-ons

Azure IoT

Due to changes in the Azure API, this add-on is no longer working and has been removed. Persistence Service

The service has been discontinued, therefore there is no longer any use of this openHAB persistence service. It has thus be removed from the distribution.

Breaking Changes in Add-ons

DarkSky Binding

The item type of ‘rain’ and ‘snow’ channels have been changed to ‘Number:Speed’.

EnOcean Binding

Channel ‘receivingState’ has been removed, because this was a string containing many information. For this, there are three new channels: ‘rssi’, ‘repeatCount’ and ‘lastReceived’.


Some tags have been renamed. Old names will not be supported in future versions. Please check documentation.

LGWebOS Binding

The binding parameter ‘localIP’ has been removed. The binding now uses system defaults for network communication. The thing type parameter ‘deviceId’ is no longer a parameter, but a property. Parameters ‘host’ and ‘key’ have been added.

MQTT Binding

Homie channel names may have changed if special characters are used for MQTT topic names.

OneWire Binding

The thing types ms-th and ms-tv have been marked deprecated and will be updated to ms-tx automatically.
The thing types counter2 , digitalio , digitalio2 , digitalio8 , ibutton , temperature have been marked deprecated and will be updated to basic automatically.

Please note that auto-upgraded things keep their thing UID including the deprecated thing type .

Manually (via textual configuration) defined things need to be changed to ms-tx or basic respectively.

Deprecated thing types will be removed with the next official release.

OpenSprinkler Binding

The stationXX channels have been removed and replaced by a bridge/thing combination. See documentation for further information.

OpenSprinkler Binding

The Pi interface was removed, as it does not provide all of the features of the binding anymore. Please use the HTTP interface instead.

senseBox Binding

The senseBox binding is now using Units of Measurements, and the channel name for Illuminance has changed. The Items must be reconfigured.

Somfytahoma Binding

The following channels have been renamed: ‘cyclic_button_state’ to ‘cyclic_button’, ‘battery_status_state’ to ‘battery_status’ and ‘lighting_led_pod_mod_state’ to ‘lighting_led_pod_mode’.

Systeminfo Binding

The ‘cpu#load’ channel has been removed because the OSHI library no longer provides this information.

TP-Link Smart Home Binding

The energy and rssi channels are now using Units of Measurements. Items must be adapted and the things must be recreated.

Tesla Binding

The binding has been heavily refactored. It is required to delete old Tesla Things and set them up from scratch.

Vitotronic Binding

The following channels have been renamed: ‘outsite_temp’ to ‘outside_temp’, ‘pelletburner:power’ to ‘pelletburner:powerlevel’, ‘party_temp’ to ‘party_temp_setpoint’ and ‘save_temp’ to ‘save_temp_setpoint’

1 Like

Thanks for your help. I had tried all that.

Going through all the userdata and config files carefully, one thing I noticed was that in the profile.cfg file, there are two lines relating to the dashboard:


There are no dashboard references in an old backup. I did delete these but it made no difference.

Do other people have these lines too?

What does Karaf features:list | grep dashboard say? I am not home so have not yet installed 2.5.1.

openhab-ui-dashboard        x 2.5.1   x     x Started     x distro-2.5.1      x Dashboard UI

I seem to have sort of fixed it. Fixed in that I don’t get the messages every minute and the system actually runs (it was so unresponsive as to be unusable).
However, every time I make a change, I get this message (but only once) -

Failed uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is not installed

I suspect there is still an error there but whatever was happening every minute is no longer happening.

The only problem is I’m not quite sure what I did to fix it and nor and I sure whether a restart (for whatever reasons) won’t cause it to start up again.

What I had done:
Comment out the legacy bindings from from addons.cfg. When I did this, none of the bindings loaded -except the homeconnect one which was a .jar file in the addons folder.
I restarted twice with the same result and then wondered whether I had some problem with my commenting out (tab rather than a space??? - it looked OK though) so I copied and pasted the same bindings section of the addons.cfg file from a backup version. I deleted the addons.config file and restarted.
I also deleted the following (again, but for good measure) from the profile.cfg file and deleted the profile.config file:


I’ve just checked and there have been no references to the dashboard in the profile.config file (last time I tried this, they got added back). This time they didn’t.

I’d be interested in what other people have in this file (profile.cfg) and if there are any differences to mine that could be causing my problems. Here’s the whole file:

# Profile generated by Karaf Assembly Builder

# Parent profiles
attribute.parents = generated-startup generated-boot generated-installed

# Attributes
attribute.overlay = true

# Feature XML repositories
repository.mvn\:org.apache.karaf.features/standard/4.2.7/xml/features = mvn:org.apache.karaf.features/standard/4.2.7/xml/features
repository.mvn\:org.apache.karaf.features/framework/4.2.7/xml/features = mvn:org.apache.karaf.features/framework/4.2.7/xml/features
repository.mvn\:org.openhab.distro/distro/2.5.1/xml/features = mvn:org.openhab.distro/distro/2.5.1/xml/features
repository.mvn\:org.openhab.distro/openhab-addons/2.5.1/xml/features = mvn:org.openhab.distro/openhab-addons/2.5.1/xml/features
repository.mvn\:org.openhab.distro/distro-kar/2.5.1/xml/features = mvn:org.openhab.distro/distro-kar/2.5.1/xml/features

# Features
feature.framework = framework
feature.eventadmin = eventadmin
feature.jaas = jaas = shell
feature.ssh = ssh
feature.bundle = bundle
feature.config = config
feature.deployer = deployer
feature.diagnostic = diagnostic
feature.feature = feature
feature.instance = instance
feature.kar = kar
feature.log = log
feature.package = package
feature.service = service
feature.system = system
feature.openhab-runtime-base = openhab-runtime-base
feature.wrapper = wrapper
feature.wrap = wrap
feature.openhab-package-demo/2.5.1 = openhab-package-demo/2.5.1
feature.openhab-package-simple/2.5.1 = openhab-package-simple/2.5.1
feature.openhab-package-standard/2.5.1 = openhab-package-standard/2.5.1
feature.openhab-package-expert/2.5.1 = openhab-package-expert/2.5.1
feature.openhab-core-base/2.5.0 = openhab-core-base/2.5.0
feature.openhab-core-auth-jaas/2.5.0 = openhab-core-auth-jaas/2.5.0
feature.openhab-core-auth-oauth2client/2.5.0 = openhab-core-auth-oauth2client/2.5.0
feature.openhab-core-automation/2.5.0 = openhab-core-automation/2.5.0
feature.openhab-core-automation-module-script/2.5.0 = openhab-core-automation-module-script/2.5.0
feature.openhab-core-automation-module-script-rulesupport/2.5.0 = openhab-core-automation-module-script-rulesupport/2.5.0
feature.openhab-core-automation-module-media/2.5.0 = openhab-core-automation-module-media/2.5.0
feature.openhab-core-automation-rest/2.5.0 = openhab-core-automation-rest/2.5.0
feature.openhab-core-config-serial/2.5.0 = openhab-core-config-serial/2.5.0
feature.openhab-core-config-discovery-usbserial/2.5.0 = openhab-core-config-discovery-usbserial/2.5.0
feature.openhab-core-ephemeris/2.5.0 = openhab-core-ephemeris/2.5.0
feature.openhab-core-io-bin2json/2.5.0 = openhab-core-io-bin2json/2.5.0
feature.openhab-core-io-console-karaf/2.5.0 = openhab-core-io-console-karaf/2.5.0
feature.openhab-core-io-http-auth/2.5.0 = openhab-core-io-http-auth/2.5.0
feature.openhab-core-io-http-auth-basic/2.5.0 = openhab-core-io-http-auth-basic/2.5.0
feature.openhab-core-io-rest-auth/2.5.0 = openhab-core-io-rest-auth/2.5.0
feature.openhab-core-io-rest-log/2.5.0 = openhab-core-io-rest-log/2.5.0
feature.openhab-core-io-rest-sitemap/2.5.0 = openhab-core-io-rest-sitemap/2.5.0
feature.openhab-core-io-rest-audio/2.5.0 = openhab-core-io-rest-audio/2.5.0
feature.openhab-core-io-rest-voice/2.5.0 = openhab-core-io-rest-voice/2.5.0
feature.openhab-core-io-rest-mdns/2.5.0 = openhab-core-io-rest-mdns/2.5.0
feature.openhab-core-io-transport-coap/2.5.0 = openhab-core-io-transport-coap/2.5.0
feature.openhab-core-io-transport-dbus/2.5.0 = openhab-core-io-transport-dbus/2.5.0
feature.openhab-core-io-transport-http/2.5.0 = openhab-core-io-transport-http/2.5.0
feature.openhab-core-io-transport-mdns/2.5.0 = openhab-core-io-transport-mdns/2.5.0
feature.openhab-core-io-transport-mqtt/2.5.0 = openhab-core-io-transport-mqtt/2.5.0
feature.openhab-core-io-transport-serial/2.5.0 = openhab-core-io-transport-serial/2.5.0
feature.openhab-core-io-transport-serial-javacomm/2.5.0 = openhab-core-io-transport-serial-javacomm/2.5.0
feature.openhab-core-io-transport-serial-rxtx/2.5.0 = openhab-core-io-transport-serial-rxtx/2.5.0
feature.openhab-core-io-transport-serial-rfc2217/2.5.0 = openhab-core-io-transport-serial-rfc2217/2.5.0
feature.openhab-core-io-transport-upnp/2.5.0 = openhab-core-io-transport-upnp/2.5.0 =
feature.openhab-core-model-item/2.5.0 = openhab-core-model-item/2.5.0
feature.openhab-core-model-item-ide/2.5.0 = openhab-core-model-item-ide/2.5.0
feature.openhab-core-model-persistence/2.5.0 = openhab-core-model-persistence/2.5.0
feature.openhab-core-model-persistence-ide/2.5.0 = openhab-core-model-persistence-ide/2.5.0
feature.openhab-core-model-rule/2.5.0 = openhab-core-model-rule/2.5.0
feature.openhab-core-model-rule-ide/2.5.0 = openhab-core-model-rule-ide/2.5.0
feature.openhab-core-model-script/2.5.0 = openhab-core-model-script/2.5.0
feature.openhab-core-model-script-ide/2.5.0 = openhab-core-model-script-ide/2.5.0
feature.openhab-core-model-sitemap/2.5.0 = openhab-core-model-sitemap/2.5.0
feature.openhab-core-model-sitemap-ide/2.5.0 = openhab-core-model-sitemap-ide/2.5.0
feature.openhab-core-model-thing/2.5.0 = openhab-core-model-thing/2.5.0
feature.openhab-core-model-thing-ide/2.5.0 = openhab-core-model-thing-ide/2.5.0
feature.openhab-core-model-lsp/2.5.0 = openhab-core-model-lsp/2.5.0
feature.openhab-core-storage-mapdb/2.5.0 = openhab-core-storage-mapdb/2.5.0
feature.openhab-core-storage-json/2.5.0 = openhab-core-storage-json/2.5.0
feature.openhab-core-ui/2.5.0 = openhab-core-ui/2.5.0
feature.openhab-core-ui-icon/2.5.0 = openhab-core-ui-icon/2.5.0
feature.openhab-runtime-base/2.5.0 = openhab-runtime-base/2.5.0
feature.openhab-runtime-certificate/2.5.0 = openhab-runtime-certificate/2.5.0
feature.openhab-runtime-jna/2.5.0 = openhab-runtime-jna/2.5.0
feature.openhab-runtime-compat1x/2.5.0 = openhab-runtime-compat1x/2.5.0
feature.openhab-transport-coap/2.5.0 = openhab-transport-coap/2.5.0
feature.openhab-transport-http/2.5.0 = openhab-transport-http/2.5.0
feature.openhab-transport-mdns/2.5.0 = openhab-transport-mdns/2.5.0
feature.openhab-transport-mqtt/2.5.0 = openhab-transport-mqtt/2.5.0
feature.openhab-transport-serial/2.5.0 = openhab-transport-serial/2.5.0
feature.openhab-transport-upnp/2.5.0 = openhab-transport-upnp/2.5.0 = = = = = = = = = = = = = = = = = = = = = = = =
feature.distro/2.5.1 = distro/2.5.1
feature.distro-kar/2.5.1 = distro-kar/2.5.1

I appreciate that this was all a bit ‘poke and hope’ but my knowledge is pretty limited in these matters.
I have appreciated though that although I have a plan B for most of my home automation, my son’s snake cage controls don’t so I had to use mqttfx to turn on the lamps and heater manually so I ought to put some accessible switches on there too!