HPEx - HabPanel Extension

Tags: #<Tag:0x00007f616e4c9d58> #<Tag:0x00007f616e4c9998>

I’m thinking it’s more of an iOS issue than Safari in particular since none of the browsers i’ve tried seem to work, even though i’m using the same saved dashboard that works on my Android and Windows devices so I know the server side is good. From what I recall, all browsers on iOS all have to use the same underlying engine because of an Apple requirement or something like that. I’m going to try jailbreaking and seeing if there’s an alternate browser that will work.

AS I said all seems to work now…not sure if it was the restart or the cache clear…

Fixed missing () on catch {} block. Modern browsers do not require parentheses on the catch block. I loaded it code onto an older IE and I was able to recreate the issue. Please take latest. Should fix other browsers…

Added on steps:

Note on Upgrading

If you have a previous installation of HabPanelEx, I have noticed that the browser may sometimes cache the javascript file. Always clear your browser’s cache when upgrading so you know you have the latest js file loaded.

you should try now

Changes:

Please take latest from

It seems to have fixed my iPad issue, but i’m using the Matrix theme from Matrix Theme for HABPanel and theater mode doesn’t seem to work on any dashboards but the hpex setup screen. It’s a css conflict somewhere for sure, because if I take the external css file out of my habpanel config theater mode works as expected - just need to figure out where.

Looks like I spoke too soon. I changed the screen change time to get more time to troubleshoot and now everything seems to be working fine, including theater mode.

Hey Lucky,

Thanks for adding the Theater Mode; I’ve just installed your panel for the first time and I’m trying the “basic” screen save mode first and have discovered another “feature needed” at least for me ;-(

I have 3 tablets on the wall; one is vertically placed and the other two are horizontally placed.

The way I have the panels in HabPanel setup is; I have one for Horizontal and one for Vertical since the layout and widget sizes are so much different based on the orientation of the tablet.

For example, I have a panel called Weather and another called Weather-V which means a vertical layout. I have many panels setup like this . . .

The issue I’m having is; if I enable the screen saver and choose the panels I want to rotate through, it applies to both my horizontal and vertical tablets which means its going to show panels that will not fit or look proper on one of the tablet orientations.

I’m not sure if I’m SOL or is there something we can do to address this scenario?

Vertical:

Horizontal:

Yes, those temps are accurate!

Best, Jay

That’s pretty much the issue with HabPanel in general. All settings are shared across ALL devices. Let me see if I can come up with a way to have different hpex configs per device, stored on different String items.

Chicago temperature…1… yikes!!!
me is in florida… and I’m bummed because 60 F

Done. Get latest from the git

You can have as many device as you want, and all of them can be configured to have their own settings/configuration.

Thanks Lucky for allowing this change. It will be a HUGE help for everybody. My issue is getting the updated JSON into the panel. I have cleared the browser cache and tried another browser (Windows Chrome and Firefox) but it continues to bring in the same looking JSON for configuration.

I did download the latest ZIP off of GIT per your recommendation and the date of the JSON file is 1/29/19 @ 5:39 pm so I’m pretty sure I got the last update of it.

Every time I try from scratch it seems to keep my OLD configuration (panel rotation ids) which means to me it’s NOT really getting deleted when I delete the panel and the JSON widget.

Any advise?

Best, Jay

Json config will look the same lol. You need to go to Advanced tab under the settings page and use a different Item string. You need to type “I understood” in the box to make it editable.

For some reason the image upload isn’t working…

Here’s my screen shots of what I’m seeing. Yup, the platform for displaying images is down.

I’m not seeing anywhere to type in “I understood”, I even typed it in the RAW white space but that didn’t work.

Best, Jay

Yup. Seems like you’re still on the older version. My commits can be seen from https://github.com/LuckyMallari/hpex/commits/master

You need to download from github and replace everything in the habpanelex folder with the files from the download.

The images seem to be working now. You can see the new version from the image in the above post…

Yup, I did it again this morning and pulled it from this tree https://github.com/LuckyMallari/hpex/tree/facf703843f5014a5fdb211481005eec728d990c

I deleted the widget on Habpanelex, the panel itself and the JSON import.

I deleted the habpanelex folder in HTML and then put the new version in there and re-did the same process all over again.

It’s still showing the OLD setup along with it remembering my panel configuration IDs in the order I want them in.

Do I need to blow away cache/tmp directories?

Best, Jay

Yeah try emptying your cache. It might be caching the js files and html

I cleared the cache & tmp directories along with a clean boot up with your latest download and it’s still showing the last version of the functionality.

I’m not sure how to remove this from my system completely to get the updated version?

Best, Jay

Hey Lucky,

Just to confirm I have the latest version from GIT, what file can I look into and see what to confirm I have the actual changes?

Best, Jay