Icons no longer updating in BasicUI

Ever since the merge of https://github.com/eclipse/smarthome/issues/640 , the icons and sometimes statuses of items are no longer reflected in the BasicUI.

As an example, a light switch, toggled ON physically, does respond correctly at the API level, but the BasicUI sitemap does not update the icon to the yellow one any longer. If the page is refreshed, then the icon is correct for the state of the item.

The same happens if the switch is toggled on through BasicUI. The slider shows the status of the switch as it was just moved, but the icon does not update. All back-end functionality using APIs still works, such as rules triggered.

Has this ever worked for you? I’ve actually never seen BasicUI update icons it states without a refresh. I just assumed that was a feature BasicUI didn’t support. I admit I didn’t sirens much time playing with it.

Yes, it had worked pretty well up until, as stated, #640 was merged. Granted, it could have been a coincidence of something else that was merged at the same time, but it was that build. I have been pulling a new snapshot as they come available for the last couple weeks.

I am seeing the same thing.

Item status and icons are not longer updating automatically in the Basic UI.

Paper UI, Classic UI and HABpanel are all updating as expected.

I am running build #526

An example of what is not now working is if you operate a slider on say HABpanel, the slider in the Basic UI does not reflect the change.

This used to work prior to my update to build #526. Pretty sure it was all Ok with build #511.

There were some problems with icon updates after sitemap events were merged. I would suggest running a recent (1-2 day old) build or running code from git. If the problem persists, it would be great to see the item and sitemap configuration as I cannot reproduce mentioned problems on a demo sitemap.

The latest distro #533 contains the very latest code from ESH. If the problems exist on this, they are definitely still there and you should report bugs with example sitemaps at https://github.com/eclipse/smarthome/issues.

I’m on #532 online and am seeing icons update instantly.

1 Like

I am on #531, so will try 532 tonight and report back.

Ok, I updated to build #535 today and the problem seems to be when running the Basic UI under Firefox and Chrome (both latest versions) on WIN 7. It also does not work on Safari on the iPad. However it does work OK on IE v11 running on WIN 7 (not my favourite choice of browser).

I can confirm the following:


  • Basic UI does not automatically refresh
  • HABpanel refreshes as expected
  • Classic UI refreshes as expected
  • HABmin refreshes as expected
  • Paper UI refreshes as expected

Chrome & Safari - as per Firefox

IE v11 - Basic UI refreshes as expected!

The items I am testing are quite simple. The definitions are as follows:

MQTT item - data is currently updated every 5 seconds

Number temp_return "Return Temperature [%.1f °C]" <temperature> (temperature , GF_Mancave) { mqtt =
"<[mqttService:myHouse/services/hvac/unit1/temp2:state:default]" }

Dimmer Item - each UI should reflect any change automatically

Dimmer Light_GF_mancave_Ceiling "LED Spot" (GF_Mancave , Lights)

Perhaps this is related to: https://github.com/eclipse/smarthome/issues/2295 but that does not explain the fact that it works on IE.

P.s. the above is true if I run Firefox on the both the server and my development PC.

1 Like

build 536 is no better. Will open a ticket tomorrow.

I can confirm that there are several issues with refresh. But I have also seen differences between icon updates, state updates and even valuecolor updates.

I have a Switch (based on presence detection), where I get icon updates and state updates (both on BasicUI and ClassicUI), but the defined valuecolor doesn’t change in BasicUI.

Then I have another Switch (door contact), where I do not get any updates. No icon, no state update. Both in ClassicUI and BasicUI. PaperUI and HABmin meanwhile do get updated. Of course, after a refresh the browser (Safari) also gets updated. So it’s definitly an UI issue. And at least the state update has worked with an older build. But I never got an icon update (AFAIK) for this Switch (that could be related to other issues though…).

I am using #536 and have tried this with Safari on OS X 10.12. A quick check with Chrome showed the same behavior.

So not exactly the same behavior as above, but also clearly a related issue.

Strange, I updated again to 536 to see if I could replicate and am still getting instant updates with no problems with icons. Windows 10, Chrome.

Do you use zwave devices? The switch item with problems is a zwave device and the switch item which is working isn’t (presence detection with exec binding). So maybe we can reduce this to zwave devices?

If you have zwave devices acting as a SWITCH item, which device is it (light, door sensor etc.)? I have used my door sensor in OH1 as CONTACT with working icon updates. In OH2 it isn’t a CONTACT any longer, but a SWITCH. So maybe that’s the problem as the according dynamic icon is an -open/-closed icon and no -on/off-icon. Which icon do you use? OH2 standard icons or individual?

I tested this on another browser and got the same issue you’re having now. Even stranger I have gone back to chrome and now no icon or status updates are working! The Event items are coming up as failed after their first load.

This happens for all of my items, not just zwave.

IE does not support server-side events and therefore uses a fallback — longpolling request mode.

After a while and without doing anything, my status updates and icons are working again. I am at a loss in understanding what’s going on here.

What network traffic looks like when events are working:

ticket opened: https://github.com/eclipse/smarthome/issues/2322

A fix has been merged in ESH and should be part of openHAB within the coming days.

For people who can’t wait, there is also a bundle with the fix, see: https://github.com/eclipse/smarthome/issues/2322#issuecomment-254593811

1 Like

Did this get included into openhab 2.0 as i’m having the same problem with basicui on openhab 2.0