Installed MQTT but no mqtt.cfg file exists

This issue has been addressed before here. Unfortunately the solution and troubleshooting within did not help my issue. I have installed the most current OH as well as switched to a snapshot. Even reflashed the SDCard and started from scratch.
Any ideas?

mqtt

Not sure Daniel, but configuration of MQTT 2.4 should be done in PaperUI, not in a config file.

You may need to post more info to get help:
Which MQTT version are you trying to use (MQTT 2 does not need this file anymore, there are many posts on this, also see recent blog entry)?
If you are using MQTT1, on the latest OH version, did you enable to use legacy bindings?
Any errors in the log?

Would figure I missed that blog post. Not sure whats up with the config file, however, with the GUI having the same ability that should matter little. Thank you both for the heads up!

In MQTT2, by default, you do not need the .cfg file anymore. Everything, can be configured in the Thing definition. (see also the docs)
Just a note: you may want to continue to use an external MQTT broker (just like for MQTT1). Ver 2 comes with a built-in broker, but as documentation is sparse, this was for me too frustrating.

I have the same issue. Following step by step configuration MK_Smarthouse. I’m new at OH2. I have a running Domoticz system, but I wanted to try OH2 because it seems better… But without MQTT it wont go.

@mlaj This video is outdated, or at least it is using the version 1 of the MQTT binding. Unless you have configured your PaperUI with legacy=true (to be able to access the version1 of bindings where there is a version 2 available), you will have installed the version 2 of MQTT binding. This version works substantially different than the version used in the video you have been watching. I would not recommend to use the version 1, as this version will not be updated anymore. Version 2 is greatly improved, start with that, but ignore the video and focus on the documentations:

For more details on the MQTT binding, start be reading here:

and this:


and this:

2 Likes

THX I will go on reading. Will report the progress.

Hello,

to configure system mqtt in openhab2 add those lines in services/runtime.cfg:

org.eclipse.smarthome.mqttbroker:name=mosquitto
org.eclipse.smarthome.mqttbroker:host=127.0.0.1
org.eclipse.smarthome.mqttbroker:port=1883
org.eclipse.smarthome.mqttbroker:esh.servicecontext=mosquitto
org.eclipse.smarthome.mqttbroker:keepAlive=60
org.eclipse.smarthome.mqttbroker:lwtQos=0
org.eclipse.smarthome.mqttbroker:lwtRetain=false
org.eclipse.smarthome.mqttbroker:qos=0
org.eclipse.smarthome.mqttbroker:retain=false
org.eclipse.smarthome.mqttbroker:retainMessages=false
org.eclipse.smarthome.mqttbroker:secure=false

then I add this file: services/mqtt-eventbus.cfg:

broker=mosquitto

and my things file things/mqtt.things:

Bridge mqtt:systemBroker:mosquitto “MQTT Broker” [ brokerid = “mosquitto” ] {
}

1 Like

I see no reason for these settings nor for creating such, using the version 2 of the MQTT binding the setup is possible through PaperUI alone (although a file setup with .things files is possible too). All the settings you posted inside your runtime.cfg can be set via PaperUI or .things file, the settings you used look like defaults (not 100% sure on that) and might be used anyhow.

I use a .things file with the brigde setup like this:

Bridge mqtt:broker:MyMQTTBroker [ host="192.168.178.50", secure=false, username="MQTTUser", password="MQTTPwd" , clientID="MQTTClient" ]

1 Like

Hello,

There are two brokers available:

MQTT Broker

A connection to a MQTT broker

System MQTT Broker

A system configured and therefore read-only broker connection. Properties are reflecting the configuration and internal connection status.

My example configures system broker.

Ed

You missunderstood something, the “system MQTT Broker” is a broker but the “MQTT Broker” is a thing-type of the MQTT-binding which creates “A connection to a MQTT broker”.
The later is needed be the first as well!

1 Like

Thank you. After a month of using OH, I have finally found out something that is not sounding like mambo Jambo and is clear.